Old 15th October 2012, 21:30   #1
thesabear
Junior Member
 
Join Date: May 2011
Posts: 13
trouble with song ratings

hi all, i have all my music stored on an external hd and have just re-added the library into winamp. for some of the music i have the ratings written in the files and now in the new database these values have been imported incorrectly. for example songs i know that have 5 star ratings in the files (and i have checked) are being shown in winamp as 4 stars.


please help
thanks
thesabear is offline   Reply With Quote
Old 15th October 2012, 22:39   #2
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,730
Send a message via AIM to MrSinatra
what file format?

you may have rated the song with another app that uses different data ranges. (mp3 for instance uses 0-255 for 0-5 stars, so the "cutoff" can vary between apps)

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 15th October 2012, 22:46   #3
thesabear
Junior Member
 
Join Date: May 2011
Posts: 13
hi, the files are in mp3 format. i use winamp to write the ratings. i found a way a long time ago on a winamp forum-by going into AppData\Roaming\Winamp\Plugins and the gen_ml and entering writeratings=1. i have had this for many years and only today has this problem occured.

mike
thesabear is offline   Reply With Quote
Old 15th October 2012, 22:54   #4
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,730
Send a message via AIM to MrSinatra
you no longer need to manually edit the ini file, the pref to turn on/off writing ratings to tags is in winamp natively now.

in any case, without you being able to say "this version rated the file this way, the new one rates them that way" i don't know that anything can be done.

in my usage, ratings have remained consistent across versions after they got the initial kinks worked out.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 16th October 2012, 08:25   #5
thesabear
Junior Member
 
Join Date: May 2011
Posts: 13
when this issue began i was using winamp 5.63 and did not update or anything. since i first began rating songs i have gone thru all the different versions and, like you, my ratings have stayed with me. i have just done a clean install of winamp and still the problem is here?

if writing the rating directly to file is now natively supported, where do i turn it on, as in this new install i did this morning it is not on

thanks
mike
thesabear is offline   Reply With Quote
Old 16th October 2012, 11:29   #6
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,730
Send a message via AIM to MrSinatra
Prefs > ML > Library Options > check the box for saving ratings to tags, (its off by default unfortunately)

what i am suggesting about your issue, is that you likely are doing a user error. the data does not change in the file unless something instructs it to, and the way winamp reads (or writes) that data has not changed either.

so maybe its your recall in error, or maybe another app like WMP or windows explorer is being used to rate files, or who knows what? but winamps implementation of ratings in tags has been consistent and reliable since they worked the kinks out in the beginning. afaik, they haven't made any changes to their paradigm since ver 5.61 which came out in Mar of 2011.

so unless you can demonstrate in a reproducible way how to recreate your issue, no one is likely to blame winamp, and instead they will simply say its somehow unique to you, if it truly exists at all.

don't get huffy, i had the same said to me, and i worked on those bugs until i WAS able to demonstrate how it WASN'T unique to me, and the devs then were able to fix the bugs.

also, you need to post a one for nunz plugin list, to be sure everything you are using is stock. and it would be better if you could more fully expound on your scenario, as i am not totally clear on what you are saying happened. step by step.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 16th October 2012, 14:54   #7
thesabear
Junior Member
 
Join Date: May 2011
Posts: 13
hi, it seems that after a reboot of my machine and adding my music back into the winamp library all the ratings are back as per normal. it would seem that the problem is unique to me and my machine-just not sure what caused it.

its nice to now know that the ratings are natively done from winamp too so i guess all this bother was not totally useless.

thanks for your help
winamp is the best!!
mike
thesabear is offline   Reply With Quote
Old 18th October 2012, 07:11   #8
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,730
Send a message via AIM to MrSinatra
sometimes i need to right click items in the ML and click "read metadata from selected items" to get the proper info to show, not often though.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump