Old 28th May 2008, 11:37   #1
-=NW=-
Junior Member
 
Join Date: May 2008
Posts: 1
Release Date for TV Shows not properly set

Hey there.

First and foremost, I'd like to thank the development team of ml_ipod for creating such a wonderful plugin, thus allowing us to delegate the task of managing an iPod to better suited alternatives instead of the bloatware iTunes.

However, I would like to request a feature, which, as small as it may appear, is actually the source of a very enduring inconvenience.

Even though, I have properly set the MP4 atoms on the TV Shows I have uploaded to the iPod, the firmware fails to read the Release Date, and thus displays the videos completely out of order, as opposed to in a chronological fashion, which one would generally find appropriate.

This occurs, it seems, due to the fact that the Release Date itself is never written to the iTunesDB file, and as such, causes the iPod (Classic, 80gb on my case) to display 'Unknown Release Date' under the episode name.

I've managed to get it to work however, by manually editing the iTunesDB and adding the correct value in the Release Date field (offset 140 within 'mhit'), but it truly is quite a hassle to do this manually for each file, when the process could be otherwise automated by having ml_ipod write this value for TV Shows.

I'd be glad to see this feature added, and I'm sure others would too benefit from it.

Regards,

NW.
-=NW=- is offline   Reply With Quote
Old 28th May 2008, 21:02   #2
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
Please add this to the feature request list at SF, to insure that it gets tracked. Thanks.

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE
abu is offline   Reply With Quote
Old 29th May 2008, 00:40   #3
Bilbo9955
Senior Member
 
Join Date: Jan 2007
Posts: 223
@Abu
FYI, your sig still shows ml_iPod 3.04
Bilbo9955 is offline   Reply With Quote
Old 29th May 2008, 07:26   #4
abu
mlipod moderator
(Senior Member)
 
abu's Avatar
 
Join Date: Jun 2005
Location: Germany
Posts: 3,457
@Bilbo: Sig fixed, thanks

WinAmp Pro 5.5 with ml_iPod 3.10 + dev.patches (download it)
ml_iPod documentation Wiki - ml_iPod FAQ - search ml_iPod forum - iPhone/iTouch - Found a bug?
Donations to support the ml_iPod project can be done HERE

Last edited by abu; 29th May 2008 at 20:24.
abu is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp iPod Plugin Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump