Old 3rd November 2012, 13:00   #1
Manohar
Junior Member
 
Join Date: Nov 2012
Posts: 2
Registry Plugin Behaviour in 64bit PC

Hi there...

I am trying to find out whether a particular registry key exist or not with the macro ${registry::KeyExists}. I am checking for a 64bit application's regkey. Since It is 64bit application, Its regkey resided at "HKEY_LOCAL_MACHINE\SOFTWARE\[APPLICATION]".

But the registry plugin is looking for this at
"HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\[APPLICATION]"

Is there any way to check the 64bit regkey with registry plugin ? I tried to use "SetRegView 64" before calling the macro ${registry::KeyExists}., but still it is looking under Wow6432Node. any help please...
Manohar is offline   Reply With Quote
Old 3rd November 2012, 15:21   #2
Afrow UK
Moderator
 
Afrow UK's Avatar
 
Join Date: Nov 2002
Location: Surrey, England
Posts: 8,434
Are you using the most recent version? I'm pretty sure Instructor updated it to use SetRegView 64.

Stu
Afrow UK is offline   Reply With Quote
Old 3rd November 2012, 18:49   #3
Manohar
Junior Member
 
Join Date: Nov 2012
Posts: 2
Oh...!!! I missed it to check the registry plugin version. I was just working on a PC which has older version of registry plugin. With just downloading and replacing the new version of registry., my problem solved and Its working now perfectly...

Thank you so much for your reply.. and I am sorry for not checking the version before posting here..!! Thank you.

Manohar..
Manohar is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Developer Center > NSIS Discussion

Tags
registry, registry plugin, setregview

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump