Old 30th July 2015, 14:41   #1
ascTim
Junior Member
 
Join Date: May 2015
Posts: 32
Install in C:\

Hello,

I want to install my program on "C:\" but every time I run the installer, the "Install" button gets grey, because I have to insert a different path (like "C:\Program Files") to install.

Can I turn this setting off and where?

edit: I am using nsis v3.0b1

Last edited by ascTim; 30th July 2015 at 16:18.
ascTim is offline   Reply With Quote
Old 30th July 2015, 18:58   #2
LoRd_MuldeR
Major Dude
 
LoRd_MuldeR's Avatar
 
Join Date: Sep 2005
Location: Somewhere over the Slaughterhouse
Posts: 797
Look for AllowRootDirInstall in the NSIS manual

My Plugins: StdUtils | NSISList | CPUFeatures | ExecTimeout | KillProc
My source of inspiration: http://youtu.be/lCwY4_0W1YI
LoRd_MuldeR is offline   Reply With Quote
Old 31st July 2015, 03:01   #3
JasonFriday13
Major Dude
 
JasonFriday13's Avatar
 
Join Date: May 2005
Location: New Zealand
Posts: 882
It sounds like you are wanting to choose the drive, not the directory.

The directory page is for the full install path, so '$PROGRAMFILES\My Test Program' is a typical install path. Installing to a root directory is a bad idea which is why nsis doesn't allow it by default.

"Only a MouseHelmet will save you from a MouseTrap" -Jason Ross (Me)
NSIS 3 POSIX Ninja
Wiki Profile
JasonFriday13 is offline   Reply With Quote
Old 31st July 2015, 11:42   #4
ascTim
Junior Member
 
Join Date: May 2015
Posts: 32
Quote:
Originally Posted by LoRd_MuldeR View Post
Look for AllowRootDirInstall in the NSIS manual
That was exactly what I was looking for.
This helps me alot and our clients will be happy as well!

Thank you very much and have a good day / weekend!
ascTim is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Developer Center > NSIS Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump