Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Bug Reports

Reply
Thread Tools Search this Thread Display Modes
Old 5th August 2012, 05:50   #1
ralish
Junior Member
 
Join Date: Nov 2006
Posts: 4
Incorrect docked toolbar handling on some multimon configs

I'm able to reliably reproduce what appears to be a bug in Winamp's Docked Toolbar feature on certain types of multi-monitor configurations. Assume we have a multi-monitor setup consisting of a 2 x 3 grid of displays (ie. three on the bottom row, three on the top row). The size, resolution, and other properties of the displays are irrelevant as it seems to be a topology issue, so we can assume that they are all exactly the same displays in this case.

If I have Winamp placed on any of the bottom row of displays and enable the Docked Toolbar in "Top" mode, Winamp will correctly place itself at the top of the given display and autohide, however, when "hidden", it actually appears at the bottom of the display above it.

In contrast, if I have Winamp placed on any of the top row of displays and enable the same, Winamp will reposition itself to the bottom row of displays, giving the exact same effect as if I had enabled "Top" mode while Winamp was located on the bottom row of displays.

It may also be relevant that the middle display on the bottom row is the primary monitor. This has the effect of seemingly making all the displays above it exist on a negative Y axis with respect to window positioning while the two displays to the left of the primary have a negative X axis. I wonder if Winamp is assuming that a negative Y axis position is never visible? This assumption is potentially incorrect in these sorts of multimon configurations.

It would be fantastic if this could be looked into as it does make this feature unusable in these configurations.
ralish is offline   Reply With Quote
Old 5th August 2012, 05:57   #2
ralish
Junior Member
 
Join Date: Nov 2006
Posts: 4
I've just tested changing the primary display to the middle display on the top row and can confirm that the witnessed behaviour is now "reversed" with Winamp now docking correctly to the top row of displays and any attempt to dock to the bottom row resulting in Winamp docking to the top row. We of course no longer see the window hiding issue as it always docks to the top row now and there's no displays above it on the window Y axis.

This would seem to strongly suggest the issue relates to bad assumptions on the nature of the Y axis for window positioning in Windows. The top left of the primary monitor is always (0,0) and so depending on monitor topology and position of the primary monitor negative X and Y axis positions are absolutely possible.

Please let me know if I can provide any further help as it would be grand to get this fixed in a new release! This has all been tested on Winamp v5.63 Pro by the way.
ralish is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Bug Reports

Tags
bug, docked toolbar, multimon, multiple monitors

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump