Old 21st September 2019, 04:06   #1
GenesisAria
Junior Member
 
Join Date: Sep 2012
Posts: 6
DSP conflict with Winamp 5.x

I have come extremely fond of HeadPlug, and i've run into a problem. It refuses to work with mp3 and ogg vorbis (it works fine on FLAC and WAV).

That isn't entirely correct however, it does work perfectly well if i use in_mp3.dll and in_vorbis.dll from winamp 2.x, but when i do that all of my unicode id3 tags are totally broken.

I read that plugins like Peter's 4P whatever it was called plugin pack may have unicode-fixed versions of winamp 2.x dlls, but every single site that is linked for downloading them everywhere is dead.

Is there any way i can find/get either unicode fixed 2.x plugins, or legacy dsp fixed 5.x plugins? Well i say 5.x, but i tried every single plugin between winamp 2.8 and 5.8, and all 5.x plugins below 5.58 wouldn't even play any tracks n winamp 5.8.

I'm dying for a solution. All i want is the ability to both have unicode tag reading and my HRTF plugin working without having to reencode everything i have into a bloated format (ogg is my preferred). I have no desire to use any other player, and have not found any other crossfeed HRTF that is any good.
GenesisAria is offline   Reply With Quote
Old 26th September 2019, 21:17   #2
musicf8
Major Dude
 
musicf8's Avatar
 
Join Date: Apr 2013
Location: Orange, CA
Posts: 786
your only best bet is to reach out to the DSP author

(┛◉Д◉)┛彡ʎɯouoıpɐɹ

Current status of Winamp: (Winamp 5.8) is not an ongoing project get wacup

5.8 beta issue quick fix - Install 5.666 (there's no further 5.8 releases)
musicf8 is offline   Reply With Quote
Old 28th November 2020, 00:21   #3
hotzenplotz
Junior Member
 
Join Date: Nov 2020
Posts: 2
@GenesisAria
Hi,
I realize that it's been a year now, so not sure if this is still relevant.

Anyway, if you tell me the setup you're using like which player and anything else out of the ordinary needed to reproduce this, I can see if I can reproduce the problem and fix it.

I didn't think anyone was still using my plugin

Bye,
Paul
hotzenplotz is offline   Reply With Quote
Old 28th November 2020, 01:55   #4
hotzenplotz
Junior Member
 
Join Date: Nov 2020
Posts: 2
I've just checked with a default Winamp 5.8 install - works fine for me

One issue is that HeadPlug does not support 24 bit. Or, to be exact, it only supports 16 bit, stereo (obviously), with sample rates between 8.02 and 101 kHz.
I could probably add support for 24 bit rather easily, but the "current" version simply can't handle it.

So if you've enabled "Allow 24 bit" in General Preferences/Playback, then ... well, it won't work. If that's the cause, then you at least have a workaround now.
hotzenplotz is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump