Old 25th October 2010, 09:41   #1
XebozZ
Junior Member
 
Join Date: Oct 2004
Posts: 17
Several Bugs

I was really excited when I heard about the new wireless sync features but I immediately stumbled upon a couple of bugs...

Before I begin I want to mention that I did a clean install of Winamp (5.59 Build 3033) and also wiped the winamp device information on my phones SD card.

Here are the bugs:
* The device shows up fine in the devices list, but it took a while for me before I was even able to connect. This was because the verification popup on Android didn't show up the first couple of times when I hit "Connect". (Maybe use Androids internal notifcation feature that puts a message in the pull down status bar so you cant miss it)

* Transfer speeds are pretty slow and sometimes it takes a couple of seconds for a file to even begin transfering

* There is no option that allows me to set the default music folder (e.g. \sdcard\Music\), instead winamp completely messes up the root directory of my sd-card.

* Even though I have only selected 3 playlists to be synchronised ("Android Phone -> Preferences -> Update selected playlists only") winamp still tries to upload all 12.000 tracks from my media library when I hit "sync".

* Remotely deleting files on my Android phone doesn't work via Desktop Winamp

* Right clicking a playlist in Dekstop Winamp and hitting "Send to -> Android Phone" doesn't work at all

* Creating playlists on the Android phone from Desktop Winamp doesn't work ("Right click -> Create Playlist" doesn't work at all)

* Playlists already on the phone are not shown in device manager on Desktop Winamp

* Tracks are being duplicated when they are already on the phone instead of just not being transfered

My desktop computer is running Windows 7
My phone: HTC Nexus One, Android 2.1 (CM 6.0.0 rc2), root access
XebozZ is offline   Reply With Quote
Old 25th October 2010, 15:58   #2
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,812
Quote:
Originally Posted by XebozZ View Post
* Even though I have only selected 3 playlists to be synchronised ("Android Phone -> Preferences -> Update selected playlists only") winamp still tries to upload all 12.000 tracks from my media library when I hit "sync".
Thanks for the report. Some are known, others will be looked into...

For the one I quoted, scroll down on that same Prefs page (Portables -> (Device) -> Sync tab)
and uncheck "Update all songs from my Local Media Library" under Library Sync.

(Note: I moved your post from the Winamp 5.59 Beta thread to here)
DJ Egg is offline   Reply With Quote
Old 25th October 2010, 18:20   #3
XebozZ
Junior Member
 
Join Date: Oct 2004
Posts: 17
Still can't get the device to connect.

The device shows up under "Devices" but when I click on the attach button it says "Connecting" for a while and then goes back to the original state. There is no message on the Android Phone whatsoever.

I guess the whole thing would be a lot easier if there was a console or some sort of error returns?

Don't know if that helps but here is my tcpdump:

XebozZ is offline   Reply With Quote
Old 26th October 2010, 17:11   #4
XebozZ
Junior Member
 
Join Date: Oct 2004
Posts: 17
Turns out, regarding the connection problems, there was a faulty VPN configuration messing up my network.

So, connecting works fine, but here is another (minor) bug I discovered:

* When the WifiSyncService is closed (e.g. by a task manager, or force close?) on the device the only way to get it back up is by unchecking and checking the "activate wifi sync" option within Winamp for Android or by rebooting the phone and starting Winamp (the service doesnt start itself after reboot). Just exiting and restarting Winamp for Android won't help.

Other bugs are still present (slow transfer, playlist issues, file deletion)

Quote:
scroll down on that same Prefs page
Ha, thanks a lot. I didn't even realize that you could scroll down on that page
XebozZ is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp for Android

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump