Old 13th September 2017, 14:42   #1
MadJack
Junior Member
 
Join Date: Oct 2013
Posts: 38
LOTS of red in my log

Since updating to SC v 2.5.5.732 I have a few issues. A ton of red in the log with this type of message.


[DST xx.xxx.xxx.xxx] Badly formed HTTP request [GET / HTTP/1.1
Icy-MetaData: 1
Host: 98.168.140.157:8822
Accept-Encoding: gzip, identity
Connection: Close, TE
TE: identity
Content-Length: 0]

What is this and is it a problem I can fix?

Thanks

P.S. It also says access to W3c log is "access denied".
MadJack is offline   Reply With Quote
Old 15th September 2017, 00:12   #2
dopelabs
Senior Member
 
dopelabs's Avatar
 
Join Date: Oct 2006
Location: Silicon Valley
Posts: 470
Send a message via AIM to dopelabs
there are some know issues with the windows version of the new dnas. this could be related if your using windows.

but about the log. make sure you have the w3c logfile path entered correctly, and that the user you are running the dnas under has read/write access to that file.
dopelabs is offline   Reply With Quote
Old 15th September 2017, 01:47   #3
BLCR
Junior Member
 
Join Date: Feb 2014
Posts: 43
Seeing this also:

2017-09-14 15:13:46 ERROR [DST xxx.xxx.xxx.xxx:xxxx] Badly formed HTTP request [GET /stream HTTP/1.1
User-Agent: WinampMPEG/5.09
Icy-MetaData: 1
Host: 107.191.38.213:10042
Accept-Encoding: gzip, identity
Connection: Close, TE
TE: identity
Content-Length: 0]


The other issue we are now facing is that those that use the software B.U.T.T. are unable to connect. We've had to convert their servers to v1 - works fine that way.

Server is not Windows based.
BLCR is offline   Reply With Quote
Old 15th September 2017, 01:57   #4
dopelabs
Senior Member
 
dopelabs's Avatar
 
Join Date: Oct 2006
Location: Silicon Valley
Posts: 470
Send a message via AIM to dopelabs
have you tried any other source apps? i dont have any issues with any of the source tools i use...
dopelabs is offline   Reply With Quote
Old 15th September 2017, 02:02   #5
BLCR
Junior Member
 
Join Date: Feb 2014
Posts: 43
Quote:
Originally Posted by dopelabs View Post
have you tried any other source apps? i dont have any issues with any of the source tools i use...
Hi - if you are referring to the B.U.T.T issue - we have tried with other source software and they are fine... just seems to be this one in particular
BLCR is offline   Reply With Quote
Old 15th September 2017, 06:39   #6
dopelabs
Senior Member
 
dopelabs's Avatar
 
Join Date: Oct 2006
Location: Silicon Valley
Posts: 470
Send a message via AIM to dopelabs
what does it show in the logs on the dnas when butt tries to connect? is there any log output or error msgs from butt?
dopelabs is offline   Reply With Quote
Old 15th September 2017, 22:36   #7
BLCR
Junior Member
 
Join Date: Feb 2014
Posts: 43
Quote:
Originally Posted by dopelabs View Post
what does it show in the logs on the dnas when butt tries to connect? is there any log output or error msgs from butt?
ERROR [SRC xx.xx.xx.xx:52763 sid=1] SHOUTcast 1 source connection denied for user (gepma53peq
Host). Bad password: 198.27.70.26

The password is in correct, and in BUTT there is no where to add a "User Name"

The only thing BUTT tells us is that it is trying to connect. nothing more
BLCR is offline   Reply With Quote
Old 15th September 2017, 23:11   #8
MadJack
Junior Member
 
Join Date: Oct 2013
Posts: 38
Quote:
Originally Posted by dopelabs View Post
there are some know issues with the windows version of the new dnas. this could be related if your using windows.

but about the log. make sure you have the w3c logfile path entered correctly, and that the user you are running the dnas under has read/write access to that file.
Than you for getting back. What are these messages anyway? Was this always going on before and it not show up?
MadJack is offline   Reply With Quote
Old 15th September 2017, 23:21   #9
dopelabs
Senior Member
 
dopelabs's Avatar
 
Join Date: Oct 2006
Location: Silicon Valley
Posts: 470
Send a message via AIM to dopelabs
Quote:
Originally Posted by BLCR View Post
ERROR [SRC xx.xx.xx.xx:52763 sid=1] SHOUTcast 1 source connection denied for user (gepma53peq
Host). Bad password: 198.27.70.26

The password is in correct, and in BUTT there is no where to add a "User Name"

The only thing BUTT tells us is that it is trying to connect. nothing more
maybe try using the following password:

stream:<password>:#<sid>

so if its stream id 4 you want the source to connect to and the password is 'hackme', the entire password entered into butt would look like this

stream:hackme:#4
dopelabs is offline   Reply With Quote
Old 15th September 2017, 23:23   #10
dopelabs
Senior Member
 
dopelabs's Avatar
 
Join Date: Oct 2006
Location: Silicon Valley
Posts: 470
Send a message via AIM to dopelabs
Quote:
Originally Posted by MadJack View Post
Than you for getting back. What are these messages anyway? Was this always going on before and it not show up?
logfile errors of 'access denied' means that the dnas either can not create the file because of no read/write permissions (on the directory), or the file exists but you can not make changes because you dont have read/write permissions (on the file)
dopelabs is offline   Reply With Quote
Old 16th September 2017, 17:38   #11
BLCR
Junior Member
 
Join Date: Feb 2014
Posts: 43
I was able to load an older version of v2 on one of our servers just to test the waters and the B.U.T.T. software worked well - but if we keep using it, they won't be listed in the directory. So now I am looking to see where I can get a copy of v2.5.1 (Build 724), since that is what we were on prior to the update. We know the software worked well with this version.

Anyone know where I might be able to find it?
BLCR is offline   Reply With Quote
Old 16th September 2017, 22:25   #12
dopelabs
Senior Member
 
dopelabs's Avatar
 
Join Date: Oct 2006
Location: Silicon Valley
Posts: 470
Send a message via AIM to dopelabs
SHOUTcast Server v2.5.1.724/posix(linux x64)?
dopelabs is offline   Reply With Quote
Old 17th September 2017, 02:03   #13
BLCR
Junior Member
 
Join Date: Feb 2014
Posts: 43
Quote:
Originally Posted by dopelabs View Post
SHOUTcast Server v2.5.1.724/posix(linux x64)?
Yes
BLCR is offline   Reply With Quote
Old 17th September 2017, 02:44   #14
dopelabs
Senior Member
 
dopelabs's Avatar
 
Join Date: Oct 2006
Location: Silicon Valley
Posts: 470
Send a message via AIM to dopelabs
msg sent
dopelabs is offline   Reply With Quote
Old 18th September 2017, 05:57   #15
MadJack
Junior Member
 
Join Date: Oct 2013
Posts: 38
What do these "Badly formed HTTP requests" in red indicate? Am I losing listeners?
MadJack is offline   Reply With Quote
Old 18th September 2017, 06:05   #16
dopelabs
Senior Member
 
dopelabs's Avatar
 
Join Date: Oct 2006
Location: Silicon Valley
Posts: 470
Send a message via AIM to dopelabs
well.. whats the addressort of your shoutcast server.. i will try tuning in using a number of different players. if they are successful then you shouldnt be loosing any listeners.
dopelabs is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > SHOUTcast > SHOUTcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump