Old 27th February 2015, 09:11   #161
mjbrown
Senior Member
 
Join Date: Aug 2001
Posts: 114
Peter, in your last post, your links are all messed up. You've got 3 mentions of out_yasapi but they actually link to in_ffsox.
mjbrown is offline   Reply With Quote
Old 27th February 2015, 19:00   #162
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
Quote:
Originally Posted by mjbrown View Post
Peter, in your last post, your links are all messed up. You've got 3 mentions of out_yasapi but they actually link to in_ffsox.
Many thanks! The links where right but the labels are wrong (that's the result from copy&paste ...).

Hopefully the following is right:
pbelkner is offline   Reply With Quote
Old 25th April 2015, 12:49   #163
ravermeister
Senior Member
 
ravermeister's Avatar
 
Join Date: Feb 2009
Location: Cologne
Posts: 194
Send a message via ICQ to ravermeister
Rescan Media Folders with in_ffsox -> audio files are falsely identified as videos

Hi, I've noticed following issue:
I'm using following configuration:
- the original in_mp3.dll has removed all files in the configuration
- the original in_mp4.dll has removed all files in the configuration

in_ffsox is configured to handle following files: FLAC;MKV;OGG;WAV;WEBM;WV;MP3;MP2;MP1;AAC;VLB;WMA;WMV;M4A;MP4;M4V

when I now add new mp3 files to the directories that I've configured in the Media Library,
and do a 'rescan' these files are falsely recognized as Video files.
this is bad becaue they do not appear in the dynamic playlists.

When I remove the file handles from in_ffsox, and reset to the defaults in in_mp3.dll/in_mp4.dll and again do 'rescan' of the media library, the files are identified correctly. (changing then back to in_ffsox works, but this just a 'workaround')

can you validate the issue?
if you need more info please let me know

P.S I've postet this to sourceforge too: https://sourceforge.net/p/in-ffsox/d...read/f432f045/

(maybe you could add an information on sourceforge, where you like to get feature/issue requests. I mean via forums.winamp.com or sourceforge.net)

Kind regards and nice Weekend!
raver

lastfm.rimkus.it - last.fm Youtube Radio (buy me)
www.rimkus.it - Contact Music & More
ravermeister is offline   Reply With Quote
Old 27th April 2015, 03:48   #164
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
Quote:
Originally Posted by ravermeister View Post
Hi, I've noticed following issue:
I'm using following configuration:
- the original in_mp3.dll has removed all files in the configuration
- the original in_mp4.dll has removed all files in the configuration

in_ffsox is configured to handle following files: FLAC;MKV;OGG;WAV;WEBM;WV;MP3;MP2;MP1;AAC;VLB;WMA;WMV;M4A;MP4;M4V

when I now add new mp3 files to the directories that I've configured in the Media Library,
and do a 'rescan' these files are falsely recognized as Video files.
this is bad becaue they do not appear in the dynamic playlists.

When I remove the file handles from in_ffsox, and reset to the defaults in in_mp3.dll/in_mp4.dll and again do 'rescan' of the media library, the files are identified correctly. (changing then back to in_ffsox works, but this just a 'workaround')

can you validate the issue?
if you need more info please let me know

P.S I've postet this to sourceforge too: https://sourceforge.net/p/in-ffsox/d...read/f432f045/

(maybe you could add an information on sourceforge, where you like to get feature/issue requests. I mean via forums.winamp.com or sourceforge.net)

Kind regards and nice Weekend!
raver
Do these files contain album art?
pbelkner is offline   Reply With Quote
Old 27th April 2015, 06:37   #165
ravermeister
Senior Member
 
ravermeister's Avatar
 
Join Date: Feb 2009
Location: Cologne
Posts: 194
Send a message via ICQ to ravermeister
yes, the files I checked did contain Album art.

lastfm.rimkus.it - last.fm Youtube Radio (buy me)
www.rimkus.it - Contact Music & More
ravermeister is offline   Reply With Quote
Old 27th April 2015, 12:23   #166
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
Quote:
Originally Posted by ravermeister View Post
yes, the files I checked did contain Album art.
Propably that's the cause, I have to check for it.

You may do another test by trying a file without embedded album art.

EDIT: Which "in_ffsox" version you are using?
pbelkner is offline   Reply With Quote
Old 27th April 2015, 22:06   #167
ravermeister
Senior Member
 
ravermeister's Avatar
 
Join Date: Feb 2009
Location: Cologne
Posts: 194
Send a message via ICQ to ravermeister
Hi,
I'm using in_ffsox version v0.3.3

your guess was right,
I did the following with a fresh user folder
(I renamed my Winamp directory in %appdata% to have clean settings,
and an empty media library):

1. set in_ffsox to handle mp3 files (disable mp3 in in_mp3.dll)
2. create a new folder and add a mp3 with an image inside and one without.
3. add this folder to the media library
3.1 eventually do rescan (the scan is done immediately after adding a new folder)

The Result is as you guessed:
the mp3 without an image inside is identified correctly as Audio File
--> it appears in the 'Audio' Dynamic playlist

the mp3 with an image inside is identified falsely as Video File.
--> it appears in the 'Video' Dynamic playlist

hope that helps,
if you need more info let me know

Kind regards
Raver

lastfm.rimkus.it - last.fm Youtube Radio (buy me)
www.rimkus.it - Contact Music & More
ravermeister is offline   Reply With Quote
Old 29th April 2015, 08:29   #168
ravermeister
Senior Member
 
ravermeister's Avatar
 
Join Date: Feb 2009
Location: Cologne
Posts: 194
Send a message via ICQ to ravermeister
can you reproduce the problem?

lastfm.rimkus.it - last.fm Youtube Radio (buy me)
www.rimkus.it - Contact Music & More
ravermeister is offline   Reply With Quote
Old 5th May 2015, 07:57   #169
ravermeister
Senior Member
 
ravermeister's Avatar
 
Join Date: Feb 2009
Location: Cologne
Posts: 194
Send a message via ICQ to ravermeister
any news, according the last issue?

lastfm.rimkus.it - last.fm Youtube Radio (buy me)
www.rimkus.it - Contact Music & More
ravermeister is offline   Reply With Quote
Old 5th May 2015, 10:48   #170
DrO
 
Join Date: Sep 2003
Posts: 27,880
you're probably better off sending a direct email than waiting on the chance of a forum reply (as per the address at the bottom of http://home.snafu.de/pbelkner/)
DrO is offline   Reply With Quote
Old 10th September 2015, 03:46   #171
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
v0.3.4

What's new?
  • Upgrade to avcodec-57.dll, avformat-57.dll, avutil-55.dll, and swresample-2.dll.
  • Moved to MSYS2.
pbelkner is offline   Reply With Quote
Old 10th September 2015, 14:11   #172
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
Dependency of Zeranoe's FFmpeg to third party DLLs

Quote:
Originally Posted by pbelkner View Post
What's new?
  • Upgrade to avcodec-57.dll, avformat-57.dll, avutil-55.dll, and swresample-2.dll.
  • Moved to MSYS2.
I've just been informed that the latest Zernoe's builds contain references to third party DLLs. These dependencies make it impossible to dynamically load them from "in_ffsox".

Please note that it is sufficient for upgrading to just substitute "avformat" and "avcodec".
pbelkner is offline   Reply With Quote
Old 9th October 2015, 06:47   #173
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
v0.3.5

What's new?
  • Just recompiled in_ffsox.dll because the latest FFmpeg seems not to be binary compatible any longer with prior versions with the same major/minor version numbers (which let it crash e.g. when upgrading to the latest FFmpeg build from Zeranoe).
Quick links:
pbelkner is offline   Reply With Quote
Old 10th October 2015, 00:18   #174
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
Wrong claim by "ravermeister" on SF project page

On the SF project page "ravermeister" claims
the current version is not fully compatible to the last zeranoe ffmpeg builds.
This is wrong:
  • For a short period of time Zeranoe's FFmpeg contained references to DLLs not available on each system. These FFmpeg could not be run on those systems (including, of course, "in_ffsox"). I.e. it's not the fault of "in_ffsox" but the other way round: Zeranoe's builds where not compatible with each system. Even on those days you could configure and build your own FFmpeg compatible with your system and plug it into your "in_ffsox".
  • With the latest builds Zeranoe seems to have dropped those references, i.e. you can plug in Zeranoe's FFmpeg into "in_ffsox" as before without any problem.
pbelkner is offline   Reply With Quote
Old 13th October 2015, 13:42   #175
ravermeister
Senior Member
 
ravermeister's Avatar
 
Join Date: Feb 2009
Location: Cologne
Posts: 194
Send a message via ICQ to ravermeister
Thanks for your Info ,
This are good news. will try it out later!

lastfm.rimkus.it - last.fm Youtube Radio (buy me)
www.rimkus.it - Contact Music & More
ravermeister is offline   Reply With Quote
Old 21st October 2015, 08:25   #176
ravermeister
Senior Member
 
ravermeister's Avatar
 
Join Date: Feb 2009
Location: Cologne
Posts: 194
Send a message via ICQ to ravermeister
confirmed
great work, everything is fine now,

tested with Windows 7 Ultimate 64bit
and the zeranoe builds from 20.10.2015

Thanks and kind regards
Raver

lastfm.rimkus.it - last.fm Youtube Radio (buy me)
www.rimkus.it - Contact Music & More
ravermeister is offline   Reply With Quote
Old 2nd March 2017, 22:20   #177
ravermeister
Senior Member
 
ravermeister's Avatar
 
Join Date: Feb 2009
Location: Cologne
Posts: 194
Send a message via ICQ to ravermeister
Update: still everything fine, even with the current ffmpeg build from 25-Feb-2017 17:30
Great work!

just saw a new version of yasapi, maybe it is time to replace Maiko, will try the new Version. (I liked the upsampling features in Maiko, sothat input/output are in sync)

lastfm.rimkus.it - last.fm Youtube Radio (buy me)
www.rimkus.it - Contact Music & More
ravermeister is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump