Old 7th March 2006, 15:05   #81
Comm@nder21
Major Dude
 
Join Date: Jul 2003
Location: germany, b-w
Posts: 734
Send a message via ICQ to Comm@nder21
thanx, works great

what about adding user vars to the outline window?
Comm@nder21 is offline   Reply With Quote
Old 7th March 2006, 15:23   #82
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Maybe in the next version?

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 7th March 2006, 19:56   #83
Comm@nder21
Major Dude
 
Join Date: Jul 2003
Location: germany, b-w
Posts: 734
Send a message via ICQ to Comm@nder21
why not
Comm@nder21 is offline   Reply With Quote
Old 9th March 2006, 12:52   #84
xilay
Junior Member
 
Join Date: Aug 2005
Posts: 29
Re: EclipseNSIS 0.9.4 HOTFIX

Quote:
Originally posted by iceman_k
EclipseNSIS 0.9.4 HOTFIX
========================

Installation Instructions:
==========================
1. Close any running instances of Eclipse.
2. In Windows Explorer, navigate to the Eclipse plugins folder.
3. Backup the net.sf.eclipsensis_0.9.4.jar file.
4. Copy the net.sf.eclipsensis_0.9.4.jar file in the hotfix to the Eclipse plugins folder, overwriting the old version.
5. Restart Eclipse. The new version of NSIS should now be accepted.
I did it, but when I try to configure NSIS, I have "Invalid NSIS home. MakeNSIS v2.0 or better is required."
I the only in this case?
xilay is offline   Reply With Quote
Old 9th March 2006, 14:35   #85
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Check the timestamp of eclipse\plugins\net.sf.eclipsensis_0.9.4.jar
It should be dated March 6th.
Several others have applied this hotfix successfully.
You may have missed a step somewhere.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 9th March 2006, 15:14   #86
xilay
Junior Member
 
Join Date: Aug 2005
Posts: 29
I don't understand.
I use Eclipse 3.1.2, your plugin 0.9.4, this afternoon, I downloaded two times net.sf.eclipsensis_0.9.4.jar from 2 different mirrors, the timestamp of the jar is dated March 6th (and in the jar, NSISValidator.class too), but always the same problem, I don't know where is my mistake...

I did a flashback (??? sorry, I'm french with a bad english, how you say in english when you install an old version?) and now it's ok, too tired to search.
xilay is offline   Reply With Quote
Old 9th March 2006, 18:06   #87
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Couple of things to try:
a) Start eclipse with -clean option (this clears the configuration cache).
b) Verify that Eclipse is indeed pointing to the correct plugins location, i.e. that there isn't a second plugins location with the old 0.9.4 jar. One way to do this: start Eclipse, access EclipseNSIS and then try to delete net.sf.eclipsensis_0.9.4.jar. If it lets you delete it, that means it is picking up the older version from somewhere else.

One more question- are you using the standard or the French version of NSIS?

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 10th March 2006, 09:32   #88
xilay
Junior Member
 
Join Date: Aug 2005
Posts: 29
Thanks, it's ok now.
But I have lost all my nsis plugin with the flashback and reinstall nsis 2.15 (never forget a backup...)
xilay is offline   Reply With Quote
Old 10th March 2006, 12:50   #89
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Just out of curiosity, what was the problem?

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 10th March 2006, 13:39   #90
xilay
Junior Member
 
Join Date: Aug 2005
Posts: 29
I tried to delete net.sf.eclipsensis_0.9.4.jar during EclipseNSIS used, and I was able to do it.
So, I started eclipse with '-clean' and copy the new jar, and all was ok.
Your advices were perfect.
xilay is offline   Reply With Quote
Old 28th March 2006, 04:58   #91
danh2000
Junior Member
 
Join Date: Mar 2006
Posts: 2
Invalid NSIS Home

Hi,

I was using EclipseNSIS succesfully last week - nothing on my PC has changed, however today when starting eclipse (or attempting to create a new NSIS script) I am prompted to configure NSIS and configure the path to MakeNSIS.exe - I've tried but I get the error:

'Invalid NSIS Home'

I have tried uninstalling everything and re-installing (with a clean eclipse startup), but it still doesn't work.

I have the most recent EclipseNSIS plugin from the update manager (http://eclipsensis.sf.net/update) and have obtained and installed the most recent NSIS install (nsis-2.15-setup.exe)..

Any suggestions?

Thanks,

Dan Humphrey
danh2000 is offline   Reply With Quote
Old 28th March 2006, 12:02   #92
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
http://forums.winamp.com/showthread....35#post1881635

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 28th March 2006, 21:50   #93
danh2000
Junior Member
 
Join Date: Mar 2006
Posts: 2
Thanks...

..the hotfix did the trick.

Great Product and Great Support!!

Dan Humphrey
danh2000 is offline   Reply With Quote
Old 6th April 2006, 11:47   #94
empezar
Senior Member
 
empezar's Avatar
 
Join Date: Sep 2003
Posts: 123
ok for the last hour i've been trying to get this to work

i got the eclipsensis to work after installing the hotfix, but the installtoptions just won't show up in the plugins, i have tried redownloading from several mirrors but it simply will not work.

i'm getting frustrated here and i hope someone can help me.
empezar is offline   Reply With Quote
Old 6th April 2006, 16:20   #95
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
What do you mean by "installtoptions just won't show up in the plugins"? Is it that you cannot use it to open INI files or it doesn't show up in the plugins list in the Help->About menu?
Some things to try:
a) Make sure you have installed GEF 3.1.
b) Open Help->Software Updates->Manage Configuration menu and check the status of the net.sf.eclipsensis.installoptions feature.
c) Check the error log and see if there are any messages indicating why the plugin did not start. The error log can be either seen using the Error Log view, or by opening the .log file in the .metadata folder in your workspace.

http://forums.winamp.com/showthread....14#post1817314

The best way to install/update EclipseNSIS is by using the Eclipse Updates Manager. It ensures that all prerequisites are met before you can install the plugins. Downloading and unzipping does not guarantee that the plugins will work, especially if some other necessary plugin is missing.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 6th April 2006, 17:38   #96
empezar
Senior Member
 
empezar's Avatar
 
Join Date: Sep 2003
Posts: 123
ok now i'm going to sound very stupid, but i won't get anything done if i don't ask questions here

first off, the installoptions eclipsensis doesn't show up anywhere, the eclipsensis+update shows up and works fine, but not installoptions.

a) yes 3.1

b) what am i looking for here? there's just junk on the left side and the 5 options i'm given all lead to nothing useful.

c) error log? where? i can't find any error.log in the eclipse directory, and i can't find any "error log view" in the eclipse menus.

eclipse updates manager? where? help -> software updates -> find and install? where am i supposed to enter the "net.sf.eclipse... etc" stuff?

Bored with the real world? Try QuakeWorld!
empezar is offline   Reply With Quote
Old 6th April 2006, 18:28   #97
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Quote:
ok now i'm going to sound very stupid, but i won't get anything done if i don't ask questions here

first off, the installoptions eclipsensis doesn't show up anywhere, the eclipsensis+update shows up and works fine, but not installoptions.
You can check if EclipseNSIS InstallOptions Editor is installed by trying File->New->Other.... The wizard that opens should have a folder named EclipseNSIS. Within that folder should be an entry for "InstallOptions Script".

Quote:
a) yes 3.1

b) what am i looking for here? there's just junk on the left side and the 5 options i'm given all lead to nothing useful.
How did you install EclipseNSIS? If you installed it manually, then Manage Configuration is not applicable.
Otherwise, there should be an entry for "EclipseNSIS InstallOptions Editor 0.9.4" in the tree view at the left.
If GEF 3.1 (or better) is properly installed, you should see something like "Graphical Editing Framework 3.1".

Quote:
c) error log? where? i can't find any error.log in the eclipse directory, and i can't find any "error log view" in the eclipse menus.
To open the view, use the Window->Show View->Error Log.
If that menu item is not available, try Window->Show View->Other.... The wizard that opens should have a folder named "PDE Runtime" (I am assuming you did a complete Eclipse SDK installation). That folder should have any entry named "Error Log".
To read the log directly, you have to know where your Eclipse workspace folder is. Within that folder will be a subfolder named .metadata which, in turn, will contain a file named .log

Quote:
eclipse updates manager? where? help -> software updates -> find and install? where am i supposed to enter the "net.sf.eclipse... etc" stuff?
If you had installed EclipseNSIS using the update manager, an entry would be automatically created for you.
Otherwise, instructions are at http://help.eclipse.org/help31/topic...s/tasks-36.htm and http://localhost/index.html#download.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 7th April 2006, 04:30   #98
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Quote:
Originally posted by iceman_k
If you had installed EclipseNSIS using the update manager, an entry would be automatically created for you.
Otherwise, instructions are at http://help.eclipse.org/help31/topic...s/tasks-36.htm and http://localhost/index.html#download.
Well... duh!!! Obviously not at localhost!!!
The second URL should be:
http://eclipsensis.sourceforge.net/index.html#download

For instructions on how to add an update site, see:
http://help.eclipse.org/help31/topic...s/tasks-34.htm

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 7th April 2006, 21:00   #99
empezar
Senior Member
 
empezar's Avatar
 
Join Date: Sep 2003
Posts: 123
i feel kind of stupid, but i actually did not have GEF installed

it all works fine now.

except one thing i noticed (a bug?) in installoptions.

when I put C:\distfiles\ as the "default directory" for a directory field, it displays C:\\distfiles\\.

Bored with the real world? Try QuakeWorld!
empezar is offline   Reply With Quote
Old 7th April 2006, 21:17   #100
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Quote:
Originally posted by empezar
except one thing i noticed (a bug?) in installoptions.

when I put C:\distfiles\ as the "default directory" for a directory field, it displays C:\\distfiles\\.
I will look at this. However, any fix will probably not appear until 0.9.5, which is probably going to be in June or so.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 9th April 2006, 09:21   #101
giddy_guitarist
Junior Member
 
Join Date: Apr 2006
Location: Mumbai,India
Posts: 4
Unhappy HELP PLZ

Hie All ,

Could someone PLEASE help ME.

I installed Eclipse 3.1, NSIS 2.15.i downloaded EclipseNSIS and pasted it in the plug-ins folder , i unzipped it even.When i start eclipse and open the plug-ins window i see "net.sf.eclipsensis(0.9.4)" , so now how do i use it.How do i open an editor for NSIS script.

Please i need someones help , i 've been racking my brains on this for a week now.I need to make an installer urgently.Please

Thanx
giddy_guitarist is offline   Reply With Quote
Old 9th April 2006, 09:37   #102
Afrow UK
Moderator
 
Afrow UK's Avatar
 
Join Date: Nov 2002
Location: Surrey, England
Posts: 8,433
Double click on one of the Modern UI example scripts under Exampls\Modern UI. Right click on the .nsi file and select Compile to compile it.

-Stu
Afrow UK is offline   Reply With Quote
Old 9th April 2006, 15:18   #103
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Re: HELP PLZ

Quote:
Originally posted by giddy_guitarist
Hie All ,

Could someone PLEASE help ME.

I installed Eclipse 3.1, NSIS 2.15.i downloaded EclipseNSIS and pasted it in the plug-ins folder , i unzipped it even.When i start eclipse and open the plug-ins window i see "net.sf.eclipsensis(0.9.4)" , so now how do i use it.How do i open an editor for NSIS script.
It's no different from how you would open an editor for a Java file, a text file or any other file in Eclipse.
If you have a workspace with projects set up, then either double-click on an .NSI file or use the EclipseNSIS wizard to create a new one.
Or you can open any .NSI file on your computer using the File->Open menu item.
Remember to install the hotfix to get past the MakeNSIS 2.15 version number issue.
http://forums.winamp.com/showthread....35#post1881635

You can always try the help, which is either accessible using the standard Eclipse help viewer or online at http://eclipsensis.sourceforge.net/help/index.html.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 8th September 2006, 16:59   #104
AndreR
Junior Member
 
Join Date: Sep 2006
Posts: 9
HowTo install?

Hello, first sorry for my bad english .

I have installed Eclipse sucessfull but now I tried to install the NSIS-Plugin, but if I used the update installer of Eclipse, there occours an error-message:
Quote:
EclipseNSIS InstallOptions Editor (0.9.4) requires plug-in "org.eclipse.gef (3.1.0)", or later version.
Can you help me with this problem? Thanks!
AndreR is offline   Reply With Quote
Old 8th September 2006, 17:38   #105
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
You need to install the GEF plugin. It is available from the main Eclipse update site.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 20th September 2006, 13:05   #106
msroboto
Junior Member
 
Join Date: Sep 2006
Posts: 47
Eclipse NSIS throwing exception

I have installed the GEF plugin version 3.2. I have installed the EclipseNSIS stuff (everything including the hotfix).

I get the following error in a new project when I try to create a new NSIS script.

I get 4 exceptions. The first on is..

java.lang.NullPointerException
at java.util.Arrays.sort(Unknown Source)
at net.sf.eclipsensis.help.NSISPluginManager.loadPluginInfo(NSISPluginManager.java:130)
at net.sf.eclipsensis.help.NSISPluginManager.loadPlugins(NSISPluginManager.java:109)
at net.sf.eclipsensis.help.NSISPluginManager.loadDefaultPlugins(NSISPluginManager.java:73)
at net.sf.eclipsensis.help.NSISKeywords.loadKeywords(NSISKeywords.java:454)
at net.sf.eclipsensis.help.NSISKeywords.start(NSISKeywords.java:80)
at net.sf.eclipsensis.EclipseNSISPlugin$4.run(EclipseNSISPlugin.java:211)
at org.eclipse.jface.operation.ModalContext.runInCurrentThread(ModalContext.java:369)
at org.eclipse.jface.operation.ModalContext.run(ModalContext.java:313)
at org.eclipse.jface.window.ApplicationWindow$1.run(ApplicationWindow.java:763)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:67)
at org.eclipse.jface.window.ApplicationWindow.run(ApplicationWindow.java:760)
at org.eclipse.ui.internal.WorkbenchWindow.run(WorkbenchWindow.java:2283)
at net.sf.eclipsensis.EclipseNSISPlugin.run(EclipseNSISPlugin.java:261)
at net.sf.eclipsensis.EclipseNSISPlugin.startServices(EclipseNSISPlugin.java:238)
at net.sf.eclipsensis.EclipseNSISPlugin.start(EclipseNSISPlugin.java:178)
at

..clipped...

I can send more of the error information if you need it.
Thanks for any help you can provide.

Added: I reinstalled NSIS and it's working so my firedrill is over for now. I do not know what happened.

Last edited by msroboto; 20th September 2006 at 13:32.
msroboto is offline   Reply With Quote
Old 20th September 2006, 13:41   #107
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Yes, if you still have the error information, please post all of it. It might be a good idea to attach it as a text file, so as to keep the post short.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 20th September 2006, 13:58   #108
msroboto
Junior Member
 
Join Date: Sep 2006
Posts: 47
Attached log file for your enjoyment.
I think I captured averything.
Attached Files
File Type: txt smblog.txt (37.1 KB, 438 views)
msroboto is offline   Reply With Quote
Old 20th September 2006, 15:19   #109
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Thanks, the bug has been fixed and will be released in version 0.9.5.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 21st September 2006, 13:51   #110
msroboto
Junior Member
 
Join Date: Sep 2006
Posts: 47
Thanks that was very fast response.

One other thing. I first encountered the exceptions opening my workspace that had a .nsi file open. Would this be the same issue or would you need to need the logs from that to determine?
msroboto is offline   Reply With Quote
Old 21st September 2006, 15:58   #111
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Sure, attach those log files as well.
It wouldn't hurt to look into it.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 21st September 2006, 19:12   #112
Comm@nder21
Major Dude
 
Join Date: Jul 2003
Location: germany, b-w
Posts: 734
Send a message via ICQ to Comm@nder21
iceman_k, release the new version!
i'm still missing support for all the new commands and features that were implemented since the release of eclipsensis 0.9.4 ...
Comm@nder21 is offline   Reply With Quote
Old 21st September 2006, 19:36   #113
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
I anticipate releasing it within the next couple of weeks.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 2nd October 2006, 18:55   #114
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Quote:
Originally posted by iceman_k
I anticipate releasing it within the next couple of weeks.
Update: Development for 0.9.5 is complete and the code has been frozen. I am going to be doing QA for the next week or so. My goal is to release it by middle of next week.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 2nd October 2006, 19:20   #115
Joost Verburg
NSIS MUI Dev
 
Join Date: Nov 2001
Posts: 3,717
Good work! Your development environment is really the best one available.
Joost Verburg is offline   Reply With Quote
Old 5th October 2006, 15:29   #116
Comm@nder21
Major Dude
 
Join Date: Jul 2003
Location: germany, b-w
Posts: 734
Send a message via ICQ to Comm@nder21
great!

i totally agree with joost
Comm@nder21 is offline   Reply With Quote
Old 2nd November 2006, 11:09   #117
Laslie
Junior Member
 
Join Date: Dec 2003
Location: Hungary
Posts: 37
When release the new version?
Laslie is offline   Reply With Quote
Old 3rd November 2006, 13:28   #118
SDPHammer
Junior Member
 
Join Date: Nov 2006
Posts: 1
Any update on 0.9.5? I was under the impression it was supposed to be released over a month ago. Thanks.
SDPHammer is offline   Reply With Quote
Old 21st November 2006, 12:54   #119
Laslie
Junior Member
 
Join Date: Dec 2003
Location: Hungary
Posts: 37
Quote:
Originally posted by iceman_k
Update: Development for 0.9.5 is complete and the code has been frozen. I am going to be doing QA for the next week or so. My goal is to release it by middle of next week.
Hi iceman_k!

When do you release the next version?
Laslie is offline   Reply With Quote
Old 21st November 2006, 13:40   #120
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Sorry it has been delayed.
A couple of reasons for it:
1) I have been traveling for 3 of the last 5 weeks on my "real" job (the one that pays the bills).
2) This is the most rigorous testing cycle I have ever performed, and it is turning up a lot of little things that I had missed earlier or broken during the current development cycle.
Rest assured that I am still putting in at least a couple of hours a day testing and fixing the application. I still hope to get it out by the end of the month.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Developer Center > NSIS Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump