Old 30th April 2014, 00:52   #201
Victhor
Late skinner & Moderator
 
Victhor's Avatar
 
Join Date: May 2003
Location: Argentina
Posts: 1,382
Like Jack said: lets do it by parts:

1st: Windows 7 trick: In Winamp, when you lose the main window for whatever reason but Winamp keeps running fine, go to the Winamp icon in the taskbar and right click it while holding Shift, you'll get a "traditional Windows" menu with Winamp's menu access on top.

2nd: About your main issue.. I will let Pieter know about it, maybe he has some idea on what it can be..

· · TMCT · KOMODO X
Victhor is offline   Reply With Quote
Old 2nd May 2014, 16:46   #202
Sabine Klare
Forum Queen
 
Sabine Klare's Avatar
 
Join Date: Nov 2010
Location: Berlin, Germany
Posts: 2,404
Thank You, Victhor. I will remember that.

The solution for the "not working" monitor was so simple: The power cable wasn't connected correctly... I have the XP machine on, but maybe no Winamp will come to there. It has 2 user-accounts. Maybe Frank could need it as second machine, although only offline, because XP is not supported anymore. I hope, my infos for Vista & Win7 (the main issues) are enough for You...

Sabine Klare Aka Sternenmaschinebine
Music, Art, Lyrics, Videos
AMBIENT... AMBIENT music forever...
Sabine Klare is offline   Reply With Quote
Old 23rd May 2014, 21:37   #203
Sabine Klare
Forum Queen
 
Sabine Klare's Avatar
 
Join Date: Nov 2010
Location: Berlin, Germany
Posts: 2,404
After the "Cable Not Connected Story" it has continued with the "Window Behind Window Story". I am trying to describe it as well as I can.

If used by default the first time, the cPro2-Skins are much bigger than the cPro-Skins. I didn't know, that the cPro-Skins are so small the first time, if not maximized. They have the same width like the Widgets Manager Window. On my notebook the Widgets Manager was behind the Winamp Window some day and not in front of anymore. Suddenly I saw the cPro-Skin.

I myself had to laugh about why I didn't see the cPro-Skins, and during the dinner suddenly I had a poem in my head, so that I opened the Text Editor on my PC to write it down and to publish it before going to bed and before forgetting it on the next day. I didn't know how to find the right text for my posting in this thread, but finally I am able to write here.

At least everything is okay. It's very interesting, that the user can customize the size and the elements inside. Many people don't use Winamp in fullscreen. I myself use the cPro- & cPro2-Skins maximized.

The SUI-Skins are much better than the non-SUI Modern Skins, they can be loaded more quickly and especially the cPro- & cPro2-Skins can be loaded without getting a script error and maybe also a crash with the gen_ff.dll (I have deleted 2 non-SUI Modern Skins later, not a big loss for me anyway, although the most other non-SUI Modern Skins look more ugly).

Now I just need to wait for the next cPro- & cPro2-Skins, after I have pasted nearly all the others, which I was able to get...

Sabine Klare Aka Sternenmaschinebine
Music, Art, Lyrics, Videos
AMBIENT... AMBIENT music forever...
Sabine Klare is offline   Reply With Quote
Old 24th May 2014, 01:06   #204
Victhor
Late skinner & Moderator
 
Victhor's Avatar
 
Join Date: May 2003
Location: Argentina
Posts: 1,382
Be careful Sabine.. cPro it's a one way trip....

· · TMCT · KOMODO X
Victhor is offline   Reply With Quote
Old 24th May 2014, 01:16   #205
DrO
 
Join Date: Sep 2003
Posts: 27,880
Quote:
Originally Posted by Sabine Klare View Post
they can be loaded more quickly and especially the cPro- & cPro2-Skins can be loaded without getting a script error and maybe also a crash with the gen_ff.dll
the irony of that comment is from what i've measured, cPro2 skins take typically half a second or more to load compared to the natively provided skins on my test setups. i know half a second isn't a lot and that it all depends on the skin (since the wasabi fallback parts + gen_ff can load in under 200ms) but when i'm looking at ~600ms for gen_ff + Big Bento to be loaded on startup compared to ~1100ms for gen_ff+cPro2 Modern, it becomes somewhat noticeable (and that's after some of the loading tweaks i've been able to apply).

as for gen_ff crashing or throwing script errors, that's the nature of the beast and is most likely from using older modern skins (or forbid the thought, enabling compatibility mode as that can and very much will break modern skins and i've never been able to work out what happens to cause it other than a lot of the skin files appear to be skipped over completely).
DrO is offline   Reply With Quote
Old 24th May 2014, 05:23   #206
Victhor
Late skinner & Moderator
 
Victhor's Avatar
 
Join Date: May 2003
Location: Argentina
Posts: 1,382
I'm not too versed on the deep arquitecture of the skins system, but I think it does have more merit the general lightweight of cPro if you take into account it loads a plugin AND then the skin.. (and it adds some tweaks and features not present in Winamp, like the playlist search).

Anyway, I think that what Sabine notices as a quick loading is more of a quick handle of the skins itself, and maybe the switching between cPro skins too. In the every day use, cPro feels more like if you were handling "Classic skins in SUI mode", quite on the contrary of what Modern skins usually feel like (heavy slow beasts draining RAM and video..).

· · TMCT · KOMODO X
Victhor is offline   Reply With Quote
Old 24th May 2014, 20:12   #207
DrO
 
Join Date: Sep 2003
Posts: 27,880
the plug-in loading is probably negligible compared to what gen_ff and / or the plug-in is doing once loaded (and is adding no more time to loading that i can determine than is seen by the other plug-in types which are loaded).

yes when running a cPro based skin can often feel lighter / responsive compared to a number of other modern skins, but any modern skin is going to use more system resources and depends completely on the type of images used, how complex the scripts are and a number of other factors.

i just thought i'd comment on Sabine's observation against what i've been able to measure. as i find it goes winamp modern (400ms) -> bento (600ms) -> cPro (1100ms)
DrO is offline   Reply With Quote
Old 25th May 2014, 05:14   #208
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,555
Quote:
Originally Posted by DrO View Post
i just thought i'd comment on Sabine's observation against what i've been able to measure. as i find it goes winamp modern (400ms) -> bento (600ms) -> cPro (1100ms)
Yes, on my desktop, the time to start Winamp with a cPro skin selected is noticeably longer (around a second, like you say) than when the Winamp Modern skin is selected. However, once Winamp is running, the time to switch between modern skins seems to be about the same (a little over a second). Is this because gen_ff.dll (and the other plug-ins) is already loaded?

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 12th December 2014, 17:17   #209
Victhor
Late skinner & Moderator
 
Victhor's Avatar
 
Join Date: May 2003
Location: Argentina
Posts: 1,382
Ssssneak peek!! http://victhor.deviantart.com/art/cP...m-II-499816140

· · TMCT · KOMODO X
Victhor is offline   Reply With Quote
Old 7th March 2016, 18:37   #210
Krisztofen
Junior Member
 
Join Date: Mar 2016
Posts: 3
Hi there ClassicPro v2.01 and v2.02 ClassicPro downloaded and always opens the winamp v2.02 who writes in the ClassicPro to download the new version but has been on the go, this is one problem, and it would be nice if it were an exact the same time and there would only be in a separate window that shows you each have to write what time would play when the program element is such a rádióbossnak and it would be nice if it would be in ClassicPro.
Krisztofen is offline   Reply With Quote
Old 8th March 2016, 14:42   #211
Krisztofen
Junior Member
 
Join Date: Mar 2016
Posts: 3
Hi there ClassicPro v2.01 and v2.02 ClassicPro downloaded and always opens the winamp v2.02 who writes in the ClassicPro to download the new version but has been on the go, this is one problem, and it would be nice if it were an exact the same time and there would only be in a separate window that shows you each have to write what time would play when the program element is such a rádióbossnak and it would be nice if it would be in ClassicPro.
Krisztofen is offline   Reply With Quote
Old 12th May 2016, 18:37   #212
osmosis
Major Dude
 
osmosis's Avatar
 
Join Date: Jan 2006
Location: Cananada
Posts: 837
I'm using cPro2 - minimal by iron2000 (Neon White color theme) which looks fantastic on Windows 10, and wanted to share a mod/hack I made to get rid of the reflection in the NowPlaying Widget, since I wanted the album art to be front-and-center, not a png of a CD case, or plastic glare, or a reflection below it.

This is also to save myself time in the future, since I figured this out once awhile back but lost it in a reinstall and had to figure it out all over again.

%ProgramFiles%\Winamp\Plugins\ClassicPro\engine\widgets\Data\NowPlaying\NowPlaying2.xml;38-59:
PHP Code:
<!--hack <groupdef id="sc.nowplaying.cdbox.holder.top"> -->
<
groupdef id="sc.nowplaying.cdbox.holder">
    <
group id="sc.nowplaying.cdbox" fitparent="1"/>
<!--
hack--><group id="sc.nowplaying.cdbox.holder.top"/>
</
groupdef>
<
groupdef id="sc.nowplaying.cdbox.holder.bottom">
    <
group id="sc.nowplaying.cdbox.reflection" x="0" y="0" w="0" h="50" relatw="1"/>
    <
group id="sc.nowplaying.cdbox.reflection.mask" fitparent="1"/>
</
groupdef>

<!--
hack <groupdef id="sc.nowplaying.cdbox.holder"> -->
<
groupdef id="sc.nowplaying.cdbox.holder.top">
    <!--
hack <group id="sc.nowplaying.cdbox.holder.top" x="0" y="0" w="50" h="50"/> -->
    <
group id="sc.nowplaying.cdbox.holder.bottom" x="0" y="0" w="50" h="50"/>
</
groupdef>

<
groupdef id="sc.nowplaying.cdbox" move="1">
    <
layer id="sc.cdbox.3" fitparent="1" image="sc.cdbox.bg" ghost="1"/>
    <!--
hack <AlbumArt id="main.albumart" x="12" y="4" w="85" h="93" relatx="2" relaty="2" relatw="2" relath="2" notfoundimage="cover.notfound" wantfocus="1" stretched="1"/> -->
    <
AlbumArt id="main.albumart" x="8" y="4" w="85" h="93" relatx="2" relaty="2" relatw="2" relath="2" notfoundimage="cover.notfound" wantfocus="1" stretched="1"/>
    <
layer id="sc.cdbox.1" fitparent="1" image="sc.cdbox.fg" ghost="1" alpha="175"/>
</
groupdef
Looking at the file, starting at line 38 it should be pretty self-explanatory, basically I just forced everything into the parent but still retained the other groupdefs nested out-of-the-way so as not to trigger any maki errors.

Now.. anyone ever figure out how to get rid of the garbage characters that show up at the end of titles in the main player in cPro2 - minimal? It's probably the only issue I have with an otherwise perfect skin.

Request: A little SmartView Query Language love.
osmosis is offline   Reply With Quote
Old 12th May 2016, 20:08   #213
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,555
Quote:
Originally Posted by osmosis View Post
I'm using cPro2 - minimal by iron2000 (Neon White color theme) which looks fantastic on Windows 10, and wanted to share a mod/hack I made to get rid of the reflection in the NowPlaying Widget, since I wanted the album art to be front-and-center, not a png of a CD case, or plastic glare, or a reflection below it. ...
Good job. Some cPro skins have built in options to disable those things. The glare and reflection are distracting, imo. I kinda like the CD case.


Quote:
Originally Posted by osmosis View Post
... Now.. anyone ever figure out how to get rid of the garbage characters that show up at the end of titles in the main player in cPro2 - minimal? It's probably the only issue I have with an otherwise perfect skin.
Try this plug-in (http://winampplugins.co.uk/unicodetaskbarfix/index.html). It gets added to Winamp's system components.

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 14th May 2016, 10:45   #214
Dachip
Junior Member
 
Dachip's Avatar
 
Join Date: May 2016
Location: Michigan
Posts: 17
Looks super clean, been enjoying this for a long time now, great job
Dachip is offline   Reply With Quote
Old 14th May 2016, 22:32   #215
osmosis
Major Dude
 
osmosis's Avatar
 
Join Date: Jan 2006
Location: Cananada
Posts: 837
Quote:
Originally Posted by Aminifu View Post
Try this plug-in (http://winampplugins.co.uk/unicodetaskbarfix/index.html). It gets added to Winamp's system components.
Unfortunately it's unrelated to Unicode since I've been using that from the Essentials pack for ages. It only happens with cPro2 - minimal, no other cPro2 skins even.

It's just random characters, sometimes changing while you watch them during playback, so it's got to be some kind of leak or something in the skin code.. maybe from the live bitrate display?

Request: A little SmartView Query Language love.
osmosis is offline   Reply With Quote
Old 15th May 2016, 19:24   #216
ariszlo
Senior Member
 
Join Date: Jun 2015
Location: Hungary
Posts: 270
Victhor has fixed another cPro skin with the garbage characters bug by adding
  • images/songinfo.png
  • scripts/ticker.maki
removing the
  • xui directory
and editing
  • skin.xml
  • xml/player-elements.xml
  • xml/player-normal.xml
ariszlo is offline   Reply With Quote
Old 19th May 2016, 20:53   #217
osmosis
Major Dude
 
osmosis's Avatar
 
Join Date: Jan 2006
Location: Cananada
Posts: 837
Quote:
Originally Posted by ariszlo View Post
Victhor has fixed another cPro skin with the garbage characters bug by adding
  • images/songinfo.png
  • scripts/ticker.maki
removing the
  • xui directory
and editing
  • skin.xml
  • xml/player-elements.xml
  • xml/player-normal.xml
Hmm thanks! I'll look into it. Hopefully it's easily reproducible.

Request: A little SmartView Query Language love.
osmosis is offline   Reply With Quote
Old 20th May 2016, 16:28   #218
osmosis
Major Dude
 
osmosis's Avatar
 
Join Date: Jan 2006
Location: Cananada
Posts: 837
Things are split up differently in the xml files for minimal and there's a lot more in xui so I'm not sure how to apply it like Victhor did..

Here's a full diff for future reference however:

HTML Code:
diff -r "cPro2 - Winamp for Mac Sync.wal/colorthemes.xml" "cPro2 - Winamp for Mac Sync v1.03 (Victhor fix).wal/colorthemes.xml"
167a168,181
> 
> <gammaset id="Vic surprise">
>   <gammagroup id="player_background" value="833,1418,2677" gray="2" boost="0" />
>   <gammagroup id="player_background_text" value="-2430,-1845,-1118" gray="2" boost="0" />
>   <gammagroup id="player_screen" value="0,0,0" gray="0" boost="0" />
>   <gammagroup id="player_screen_text" value="833,1418,2677" gray="2" boost="0" />
>   <gammagroup id="player_color" value="4096,-2536,-1366" gray="2" boost="0" />
>   <gammagroup id="player_list_bg" value="-2962,-2873,-2572" gray="1" boost="1" />
>   <gammagroup id="player_list_text" value="-1295,-638,904" gray="2" boost="0" />
>   <gammagroup id="player_list_selectbg" value="-2891,-2802,-2430" gray="2" boost="1" />
>   <gammagroup id="player_buttons_dark" value="833,1418,2677" gray="2" boost="0" />
>   <gammagroup id="player_buttons_light" value="-2288,-1703,-1118" gray="2" boost="0" />
>   <gammagroup id="player_bolt" value="1365,-2536,-1366" gray="2" boost="0" />
> </gammaset>
\ No newline at end of file
Only in cPro2 - Winamp for Mac Sync.wal/: Helvetica_n.ttf
Only in cPro2 - Winamp for Mac Sync v1.03 (Victhor fix).wal/images: songinfo.png
Only in cPro2 - Winamp for Mac Sync v1.03 (Victhor fix).wal/scripts: ticker.maki
diff -r "cPro2 - Winamp for Mac Sync.wal/skin.xml" "cPro2 - Winamp for Mac Sync v1.03 (Victhor fix).wal/skin.xml"
5,7c5,7
< 		<version>1.01</version>
< 		<name>cPro2 - Winamp for Mac Sync</name>
< 		<comment>This skin use the cPro2 xui object and was created using the graphics of Winamp for Mac Sync Beta.</comment>
---
> 		<version>1.03</version>
> 		<name>cPro2 - Winamp for Mac Sync (Victhor fix)</name>
> 		<comment>This skin use the cPro2 xui object and was created using the graphics of Winamp for Mac Sync Beta. + Victhor's clumsy fix of random gibberish text</comment>
29d28
< 	<include file="xui/xui-objecs.xml"/>
diff -r "cPro2 - Winamp for Mac Sync.wal/xml/player-elements.xml" "cPro2 - Winamp for Mac Sync v1.03 (Victhor fix).wal/xml/player-elements.xml"
5a6,11
> 	<bitmap id="player.songinfo.mono" file="images/songinfo.png" x="0" y="21" h="5" w="40" gammagroup="player_screen_text"/>
> 	<bitmap id="player.songinfo.stereo" file="images/songinfo.png" x="0" y="27" h="5" w="40" gammagroup="player_screen_text"/>
> 	<bitmap id="player.songinfo.multi" file="images/songinfo.png" x="0" y="33" h="5" w="40" gammagroup="player_screen_text"/>
> 	<bitmap id="player.songinfo.multi2" file="images/songinfo.png" x="41" y="33" h="5" w="40" gammagroup="player_screen_text"/>
> 	<bitmap id="player.songinfo.na"  file="images/songinfo.png" x="0" y="0" h="5" w="40" gammagroup="player_screen_text"/>
> 	
13,15c19,21
< 	<bitmap id="frame.bottomleft" file="images/window_bg.png" x="0" y="112" w="92" h="24" gammagroup="player_background"/>
< 	<bitmap id="frame.bottom" file="images/window_bg.png" x="93" y="112" w="92" h="24" gammagroup="player_background"/>
< 	<bitmap id="frame.bottomright" file="images/window_bg.png" x="186" y="112" w="92" h="24" gammagroup="player_background"/>
---
> 	<bitmap id="frame.bottomleft" file="images/window_bg.png" x="0" y="112" w="92" h="44" gammagroup="player_background"/>
> 	<bitmap id="frame.bottom" file="images/window_bg.png" x="93" y="112" w="92" h="44" gammagroup="player_background"/>
> 	<bitmap id="frame.bottomright" file="images/window_bg.png" x="186" y="112" w="92" h="44" gammagroup="player_background"/>
diff -r "cPro2 - Winamp for Mac Sync.wal/xml/player-normal.xml" "cPro2 - Winamp for Mac Sync v1.03 (Victhor fix).wal/xml/player-normal.xml"
3,21c3,13
< 	<Wasabi:AlbumArt x="3" y="3" w="65" h="65"/>
< 
< 	<SC:SongNews
< 		x="176" y="54" w="-179" h="16" relatw="1"
< 		id_layout="main;normal"
< 		id_volume="vol.slider"
< 		id_seeker="seeker"
< 		id_prev="two.playback.prev"
< 		id_next="two.playback.next"
< 		id_open=""
< 		id_shuf="two.playback.shuf"
< 		id_rep="two.playback.rep"
< 		id_mute="mute.nbutton"
< 		mytext="%bitrate%kbps   %frequency%kHz   %channels%"
< 		refresh="1"
< 		align="right" font="cpro2.font.status.text" bold="0" 
< 		color="screen.font.color" fontsize="13" fix_ghost="1" alpha="225"
< 	/>
< 
---
> 	
> <text id="songTitle" ticker="1" display="songtitle" default="" sysregion="1"
>      align="left" x="176" y="40" w="-179" h="16" relatw="1" font="cpro2.font.status.text" bold="0" color="screen.font.color" fontsize="14"/>
> <text id="songArtist" ticker="1" display="songartist" default=""
>      align="left" x="176" y="24" w="-179" h="16" relatw="1" font="cpro2.font.status.text" bold="1" color="screen.font.color" fontsize="16" move="1"/>
> <text id="songAlbum" ticker="1" display="songalbum" default="" sysregion="1"
>       align="left" x="176" y="8" w="-179" h="16" relatw="1" font="cpro2.font.status.text" bold="1" color="screen.font.color" fontsize="16" alpha="0"/>
> 
> <text display="SONGINFO" x="-176" y="54" w="170" h="16" align="right" relatx="1" font="cpro2.font.status.text" bold="0" color="screen.font.color" fontsize="13" alpha="225" dblclickaction="trackinfo" rightclickaction="trackmenu" move="1"/>
>   	
> <script id="ticker" file="scripts/ticker.maki"/>
22a15,17
>   <layer id="vic-patch-left" x="0" y="0" h="70" w="4" relath="0" image="meta.left" move="1"/>
> 	<layer id="vic-patch" x="4" y="0" h="70" w="173" relath="0" image="meta.middle" move="1"/>
> 	
30,34c25,26
< 	
< 	<SC:Text x="176" y="24" w="-179" h="16" relatw="1" mytext="%artist%" font="cpro2.font.status.text" bold="1" color="screen.font.color" fontsize="16" mymove="1"/>
< 	<SC:Text x="176" y="40" w="-179" h="16" relatw="1" mytext="%title%" font="cpro2.font.status.text" bold="0" color="screen.font.color" fontsize="14" mymove="1"/>
< 	
< 	
---
> 
> <Wasabi:AlbumArt x="3" y="3" w="65" h="65"/>
37c29
< <layout id="normal" minimum_h="114" minimum_w="450" default_w="800" default_h="600" w="800" h="600" appbar="top|bottom|left|right">
---
> <layout id="normal" minimum_h="114" minimum_w="450" default_w="800" default_h="600" w="800" h="650" appbar="top|bottom|left|right">
Only in cPro2 - Winamp for Mac Sync.wal/: xui
But either way, I guess it's more of a wider cPro2 issue.. something to do with the maki producing, processing, or displaying %artist% and %title%... So probably "SC Text Objects" - OneDirectionText.m or sc_text.m

Request: A little SmartView Query Language love.
osmosis is offline   Reply With Quote
Old 20th May 2016, 18:32   #219
Victhor
Late skinner & Moderator
 
Victhor's Avatar
 
Join Date: May 2003
Location: Argentina
Posts: 1,382
Quote:
Originally Posted by osmosis View Post
Things are split up differently in the xml files for minimal and there's a lot more in xui so I'm not sure how to apply it like Victhor did..
Indeed, these are 2 totally different skins made by 2 totally different skinners XD. So, it's not straight forward..

Quote:
Originally Posted by osmosis View Post
But either way, I guess it's more of a wider cPro2 issue.. something to do with the maki producing, processing, or displaying %artist% and %title%... So probably "SC Text Objects" - OneDirectionText.m or sc_text.m
Jackspot! OneDirectionText AND sc_text contain the problem. DrO suspected of something (and posted on that mentioned thread) but is too heavy stuff for me so I just aimed to replace the text strings for an equivalent using another script (any script other that OneDirectionText / sc_text will do the job..).

So I'll try to fix it on this case whenever I have the time, it may or may not be easy, IIRC iron2000 made a pretty complex "skin engine" to have that baby going..

· · TMCT · KOMODO X
Victhor is offline   Reply With Quote
Old 23rd May 2016, 22:42   #220
osmosis
Major Dude
 
osmosis's Avatar
 
Join Date: Jan 2006
Location: Cananada
Posts: 837
Quote:
Originally Posted by Victhor View Post
Indeed, these are 2 totally different skins made by 2 totally different skinners XD. So, it's not straight forward..


Jackspot! OneDirectionText AND sc_text contain the problem. DrO suspected of something (and posted on that mentioned thread) but is too heavy stuff for me so I just aimed to replace the text strings for an equivalent using another script (any script other that OneDirectionText / sc_text will do the job..).

So I'll try to fix it on this case whenever I have the time, it may or may not be easy, IIRC iron2000 made a pretty complex "skin engine" to have that baby going..
Ahh yes, I see it now:
Quote:
Originally Posted by DrO View Post
if you do the equivalent of str += 'initial text'; and str += 'more text'; instead of doing str = 'initial text'; and str += 'more text'; (note: not doing += both times but doing a = and then a += then that resolves that usage case). or you make sure that you start with str = "";

ii've probably got some of the maki specific aspects wrong (I think += works, otherwise it's something like using append maybe?) but it was one case that I remember seeing being wrong in one skin example that showed the issue irrespective of doing anything in the skin engine i.e. it can be worked around via the skin by doing things 'right' and making sure the string is correctly initialised when starting to use it.
So this suggests we could work around it with a newer compile of sc_text.m with probably just a minor tweak to the code.. probably in the updateTitle function. I'll mess around and see if I can fix it.


Edit: It's also present in fileinfo-kai.m / StatusText.m in minimal, and fileinfo-kai seems to set strings as desired by initializing with = ""; so I'm stumped again.

Request: A little SmartView Query Language love.

Last edited by osmosis; 23rd May 2016 at 23:46.
osmosis is offline   Reply With Quote
Old 11th September 2016, 10:11   #221
trey
Junior Member
 
Join Date: Sep 2016
Posts: 7
installation error in windows 10

hello
I'm trying to install cpro in my pc with windows 10. everything works fine until it try to pone some url in a directory that doesn't exist in my computer.
any solution for that?

thank you
trey is offline   Reply With Quote
Old 11th September 2016, 14:40   #222
Victhor
Late skinner & Moderator
 
Victhor's Avatar
 
Join Date: May 2003
Location: Argentina
Posts: 1,382
Quote:
Originally Posted by trey View Post
(...) until it try to pone some url in a directory that doesn't exist in my computer...
What are you trying to do in a directory that doesn't exist?

· · TMCT · KOMODO X
Victhor is offline   Reply With Quote
Old 11th September 2016, 21:46   #223
trey
Junior Member
 
Join Date: Sep 2016
Posts: 7
Quote:
Originally Posted by Victhor View Post
What are you trying to do in a directory that doesn't exist?
to open an url
sorry
trey is offline   Reply With Quote
Old 13th September 2016, 12:11   #224
Victhor
Late skinner & Moderator
 
Victhor's Avatar
 
Join Date: May 2003
Location: Argentina
Posts: 1,382
Ah! Not sure if I get exactly your point though.
If the skin is to be blame, you can reset your skins preferences by deleting xtudio.xnf (usually "C:\Users\USERNAME\AppData\Roaming\Winamp"). BUT if the original file is not being detected by Winamp, it's another road:
- On Winamp, go to a subview within Media Library, right click any item and select Remove > Remove all dead files.
- Aditionally, for your current Playslit, go to Remove button > Remove > Remove missing files from Playlist.

If the solution was the latter, there is another option you should use to avoid this on the future, but first let me know if it works.

· · TMCT · KOMODO X
Victhor is offline   Reply With Quote
Old 13th September 2016, 15:46   #225
trey
Junior Member
 
Join Date: Sep 2016
Posts: 7
no, I'm afraid you don't get my point. Thanks for your reply, though.
I'm trying to install CPro, and I get the error you can see in the image.
sorry it's in spanish

thanks
Attached Thumbnails
Click image for larger version

Name:	Captura de pantalla (3).png
Views:	87
Size:	126.0 KB
ID:	52619  
trey is offline   Reply With Quote
Old 14th September 2016, 15:23   #226
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,555
Hi trey,

I suggest you try the latest beta version 2.02, released 1 Sep 2013. Look for the download link at the bottom of post #1 of the following link (http://forums.skinconsortium.com/ind...=2093&pageNo=1).

Right click on the downloaded installation file and run it in Administrator mode.

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 14th September 2016, 15:30   #227
trey
Junior Member
 
Join Date: Sep 2016
Posts: 7
Quote:
Originally Posted by Aminifu View Post
Hi trey,

I suggest you try the latest beta version 2.02, released 1 Sep 2013. Look for the download link at the bottom of post #1 of the following link (http://forums.skinconsortium.com/ind...=2093&pageNo=1).

Right click on the downloaded installation file and run it in Administrator mode.
thanks for the suggestion, but... same problem
trey is offline   Reply With Quote
Old 14th September 2016, 16:14   #228
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,555
Quote:
Originally Posted by trey View Post
thanks for the suggestion, but... same problem
It appears that Windows 10 does not let the installer write the url link to that ProgramData folder. If so, then the installer would need to be updated. I had installed cPro v2.02 three years ago while running Windows 7, therefore that link was already there when I upgraded to Windows 10.

Anyway, that url just links to the old ClassicPro v2.01 page on the Skin Consortium website (http://cpro.skinconsortium.com/). If everything else installed ok, then the cPro v2.02 plug-in should allow you to use all cPro 1 & 2 skins with Winamp.

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 14th September 2016, 17:24   #229
trey
Junior Member
 
Join Date: Sep 2016
Posts: 7
it works! I haven't checked...
thank you both for your help
trey is offline   Reply With Quote
Old 14th September 2016, 17:51   #230
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,555
What works? What did you not check?

Anyway, all's well that ends well! Enjoy the cPro skins.

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 14th September 2016, 17:53   #231
trey
Junior Member
 
Join Date: Sep 2016
Posts: 7
I didn't check if the installation was complete, but it was, so yes, I can enjoy the cPro skins now.
cheers
trey is offline   Reply With Quote
Old 14th September 2016, 18:01   #232
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,555
I forgot that the link I told you about in post # 226 above is not to the latest version. Look for a download link in post #7 of the link I gave instead of post #1. Sorry, it was so long ago.

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 14th September 2016, 18:06   #233
trey
Junior Member
 
Join Date: Sep 2016
Posts: 7
no problem. thanks
trey is offline   Reply With Quote
Old 16th September 2016, 09:50   #234
rikverhoeven85
Junior Member
 
Join Date: Sep 2016
Posts: 3
Great skin, my standard. Thanks!
rikverhoeven85 is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Skinning and Design > Modern Skins

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump