Old 27th June 2013, 22:04   #121
ravermeister
Senior Member
 
ravermeister's Avatar
 
Join Date: Feb 2009
Location: Cologne
Posts: 194
Send a message via ICQ to ravermeister
Hi, I've got following problem:
whenever I want to shut down or log off from my pc while winamp plays music through in_ffsox,
the shutdown/logout process is interrupted, and windows says it can not continue, because it is waiting for the winamp process to close (screen gets dark) and let me choose whether to force close or to abort shutdown/log off.
is it a known problem?
how can i solve this....

I've got UAC on and Windows 7 64bit

the group Administrators has full control over C:\Program Files(x86)\Winamp (and subfolders)
and group Users has read/execute for C:\Program Files(x86)\Winamp (and subfolders)

I bet giving my logged in User complete control over this folder will solve the issue, but
I hope there is a better way to achieve it...
ravermeister is offline   Reply With Quote
Old 3rd July 2013, 07:26   #122
ravermeister
Senior Member
 
ravermeister's Avatar
 
Join Date: Feb 2009
Location: Cologne
Posts: 194
Send a message via ICQ to ravermeister
...nobody a tip for me?
ravermeister is offline   Reply With Quote
Old 3rd July 2013, 10:52   #123
DrO
 
Join Date: Sep 2003
Posts: 27,880
if the plug-ins is saving anything into those folders then the plug-ins is flawed. only the author can really comment on things though if this is such an issue for you then I'd stop using the plug-in until / if there's a solution as no input plug-in should be able to do such a thing.
DrO is offline   Reply With Quote
Old 6th July 2013, 05:31   #124
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
Quote:
Originally Posted by ravermeister View Post
whenever I want to shut down or log off from my pc while winamp plays music through in_ffsox,
the shutdown/logout process is interrupted, and windows says it can not continue, because it is waiting for the winamp process to close (screen gets dark) and let me choose whether to force close or to abort shutdown/log off.
Unfortunately I cannot reproduce this.

What happens if you simply stop playing?

As far as I can tell WA should call the plugin's stop() method in both cases. If WA misses calling the stop() method in your setup during log off it could be the reason.

Quote:
Originally Posted by DrO View Post
if the plug-ins is saving anything into those folders then the plug-ins is flawed. only the author can really comment on things though if this is such an issue for you then I'd stop using the plug-in until / if there's a solution as no input plug-in should be able to do such a thing.
Who was claiming this? It does not save anything during shutdown. It only saves something when you hit the ok button from the configuration dialog, and then at some location (users folder) where WA likes to do it (cf. discussion with Koopa above).

Instead I suspect WA misses calling the stop() method under the given circumstances.
pbelkner is offline   Reply With Quote
Old 6th July 2013, 09:18   #125
DrO
 
Join Date: Sep 2003
Posts: 27,880
ravermeister was so I thought I'd made a specific comment to make sure it wasn't doing what was being surmised. to my knowledge we do call stop as well as the quit methods on that closing method unless its taking too long and then its possible the process is getting suspended and prevented from being able to respond to it.
DrO is offline   Reply With Quote
Old 6th October 2013, 12:07   #126
kerimcem
Member
 
Join Date: Jan 2010
Posts: 76
2.0.1.0 fnal some mp3 not work seek
send pm
thanks..
kerimcem is offline   Reply With Quote
Old 6th October 2013, 13:03   #127
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
Quote:
Originally Posted by kerimcem View Post
2.0.1.0 fnal some mp3 not work seek
send pm
thanks..
Fixed and upload a new version: http://sourceforge.net/projects/in-f...n_ffsox-2/0.1/.

The reason was BMP as embedded album art was not supported yet. Thank you for providing a sample!
pbelkner is offline   Reply With Quote
Old 1st December 2013, 10:07   #128
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
Updated Online Documentation

The online documentation at http://in-ffsox.sourceforge.net/ is updated and now provides a description to all of the plugin's options.
pbelkner is offline   Reply With Quote
Old 18th December 2013, 13:31   #129
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
FFSoX Plyer 2 v0.1.4 released

Read on at Winamp Enthusiast Forum: http://winampforum.com/showthread.php?tid=254
pbelkner is offline   Reply With Quote
Old 20th December 2013, 07:14   #130
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
FFSoX Plyer 2 v0.1.5 released

We're still alive???

Anyway, read on at Winamp Enthusiast Forum: http://winampforum.com/showthread.ph...d=5345#pid5345
pbelkner is offline   Reply With Quote
Old 31st December 2013, 06:36   #131
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
FFSoX Player 2 v0.2 released

Read on at Winamp Enthusiast Forum: http://winampforum.com/showthread.ph...d=7842#pid7842
pbelkner is offline   Reply With Quote
Old 1st January 2014, 19:29   #132
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
FFSoX Player 2 v0.2.1 released

Read on at Winamp Enthusiast Forum: http://winampforum.com/showthread.ph...d=8035#pid8035
pbelkner is offline   Reply With Quote
Old 14th February 2014, 08:09   #133
ravermeister
Senior Member
 
ravermeister's Avatar
 
Join Date: Feb 2009
Location: Cologne
Posts: 194
Send a message via ICQ to ravermeister
can I see the changelog for 2.0.2.3 somewhere?
and I gently wanted to ask, if support of editing ID3 Tags is in the roadmap... would awesome?
Thanks anyway for your great plugin.

Kind regards
Raver
ravermeister is offline   Reply With Quote
Old 14th February 2014, 17:02   #134
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
Quote:
Originally Posted by ravermeister View Post
support of editing ID3 Tags is in the roadmap
I have this idea myself for a long time. Unfortunately my knowledge on how to use the FFmpeg-API for writing is up to now too limited for implementing it in a reliable way. Maybe someday ...
pbelkner is offline   Reply With Quote
Old 14th February 2014, 17:22   #135
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
Avoid "Winamp Enthusiasts Forum"

Quote:
Originally Posted by pbelkner View Post
Read on at Winamp Enthusiast Forum: http://winampforum.com/showthread.ph...d=8035#pid8035
After having made links to that forum invalid for several times they finally deleted several posts without notice (including the FFSoX thread):

pbelkner is offline   Reply With Quote
Old 16th May 2014, 08:59   #136
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
FFSoX Player 2 v0.3 released

What's new?Home: http://in-ffsox.sourceforge.net/
Download: http://sourceforge.net/projects/in-f...es/in_ffsox-2/
pbelkner is offline   Reply With Quote
Old 16th May 2014, 22:00   #137
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,326
Now I'm hijacking the next thread.

I've added detection support of the in_ffsox library files to the Info Tool reports. (take a look at the screenshot)

This is maybe useful for you in future, so you can see if the required dll files are present on the system or not.

-Chris
Attached Thumbnails
Click image for larger version

Name:	inffsox.png
Views:	185
Size:	47.1 KB
ID:	51160  
Koopa is offline   Reply With Quote
Old 17th May 2014, 04:28   #138
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
Quote:
Originally Posted by Koopa View Post
Now I'm hijacking the next thread.

I've added detection support of the in_ffsox library files to the Info Tool reports. (take a look at the screenshot)

This is maybe useful for you in future, so you can see if the required dll files are present on the system or not.

-Chris
Thanks a lot
pbelkner is offline   Reply With Quote
Old 21st May 2014, 13:01   #139
ravermeister
Senior Member
 
ravermeister's Avatar
 
Join Date: Feb 2009
Location: Cologne
Posts: 194
Send a message via ICQ to ravermeister
Thank you!

Thanks for the Updated version.
crossing fingers that you get the skills to implement ID3 Tagging

keep up the great work and
kind regards
ravermeister
ravermeister is offline   Reply With Quote
Old 28th September 2014, 16:16   #140
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,517
FFSoX Player 2 v0.3 crashes Winamp with the current 32 bit shared FFmpeg build.

http://ffmpeg.zeranoe.com/builds/win...in32-shared.7z

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 28th September 2014, 17:56   #141
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
Quote:
Originally Posted by Aminifu View Post
FFSoX Player 2 v0.3 crashes Winamp with the current 32 bit shared FFmpeg build.

http://ffmpeg.zeranoe.com/builds/win...in32-shared.7z
Thanks for pointing out. The latest FFmpeg has changed ABI:

Quote:
This means that this release is neither ABI-compatible nor fully API-compatible.

http://git.videolan.org/?p=ffmpeg.gi...hb=release/2.4
I'm already working on that.
pbelkner is offline   Reply With Quote
Old 29th September 2014, 09:00   #142
ravermeister
Senior Member
 
ravermeister's Avatar
 
Join Date: Feb 2009
Location: Cologne
Posts: 194
Send a message via ICQ to ravermeister
Great to see this project is not dead
ravermeister is offline   Reply With Quote
Old 4th October 2014, 10:32   #143
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
Quote:
Originally Posted by Aminifu View Post
FFSoX Player 2 v0.3 crashes Winamp with the current 32 bit shared FFmpeg build.

http://ffmpeg.zeranoe.com/builds/win...in32-shared.7z
A new release 0.3.1 is available:
https://sourceforge.net/projects/in-...n_ffsox-2/0.3/
@ravermeister: Sorry, no new features.
pbelkner is offline   Reply With Quote
Old 5th October 2014, 14:44   #144
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,517
Thank you, pbelkner. Version 0.3.1 works fine with the latest full FFmpeg support (as of the date of this post).

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 13th October 2014, 02:06   #145
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,517
Hi pbelkner,

I added and scanned 2 new .mkv music video files into my media library and they were registered as both audio and video files. After removing these records, disabling your plug-in and switching back to what I'd been using before, I rescanned and these files registered correctly as video only.

I'm not sure if this is a problem with only the latest version, since these are the first files I've added since I've been using your plug-in (latest and the previous version). Before trying your plug-in I was using DShow codecs and the official DirectShow Decoder v1.13 [in_dshow.dll] plug-in instead of the official video plug-ins.

When I installed your plug-in I disabled "in_dshow.dll", but I left the DShow codecs on my system. Could this be why these files registered as both audio and video when using "in_ffsox.dll"?

Another problem I have when using other than the official video plug-ins is that Winamp will not show the image file (cover.jpg) that is in the same folders with the video files. The standard 'no albumart' image file is shown instead in the media library albumart views of my video files. I have added the artist, albumartist, title, album, and genre metadata to each of the video file records. Do you have any ideas on why this is happening?

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 3rd November 2014, 12:42   #146
ravermeister
Senior Member
 
ravermeister's Avatar
 
Join Date: Feb 2009
Location: Cologne
Posts: 194
Send a message via ICQ to ravermeister
just a hint,
at the sourceforge site: https://sourceforge.net/projects/in-ffsox/
the version 2.0.3.0 is stated as the most recent version,
but if you browse the files section,
--> https://sourceforge.net/projects/in-...n_ffsox-2/0.3/
you can find the version 2.0.3.1, and according to the modification date this
is the last version.

maybe you should correct that, sothat more people can find your updated version

kind regards
Raver
ravermeister is offline   Reply With Quote
Old 3rd November 2014, 16:18   #147
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
Quote:
Originally Posted by ravermeister View Post
maybe you should correct that
Thanks for the hint!
pbelkner is offline   Reply With Quote
Old 5th November 2014, 13:18   #148
Jacobjm
Banned
 
Join Date: Nov 2014
Posts: 2
I had a look and it looked good.
Jacobjm is offline   Reply With Quote
Old 11th November 2014, 14:49   #149
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,517
I guess I'm the only one having videos show up in the media library as both audio and video records. That's unfortunate for me since this plug-in is a very good and simple solution for getting Winamp to play videos.

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 11th November 2014, 15:02   #150
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
Quote:
Originally Posted by Aminifu View Post
I guess I'm the only one having videos show up in the media library as both audio and video records. That's unfortunate for me since this plug-in is a very good and simple solution for getting Winamp to play videos.
I'm not certain what your problem is and whether this solves it: You need to have in_dshow in place but disabled via config (empty list of extensions).
pbelkner is offline   Reply With Quote
Old 11th November 2014, 16:15   #151
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,517
Quote:
Originally Posted by pbelkner View Post
You need to have in_dshow in place but disabled via config (empty list of extensions).
That did not work.

I assume you have removed all the native audio and video decoders. Other than 4 native audio decoders (in_flac, in_mp3, in_vorbis, in_wave), in_cdda and in_linein, and a 3rd party wavpack decoder (in_wv from the old Essentials pack); I only have 3 native input video decoders (not counting in_dshow) in_mp4 (configured for m4a only), in_wm (for windows media), and in_nsv (for Nullsoft stuff).

I only wanted to use your plug-in for video support, but I could try letting it handle everything (if I won't lose the ability to display embedded albumart).

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 12th November 2014, 08:51   #152
ravermeister
Senior Member
 
ravermeister's Avatar
 
Join Date: Feb 2009
Location: Cologne
Posts: 194
Send a message via ICQ to ravermeister
@Amnifu,
if you use a Dynamic Playlist, have you checked that you enabled
the 'is Audio' criteria?

see screenshot:
ravermeister is offline   Reply With Quote
Old 12th November 2014, 15:18   #153
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,517
Quote:
Originally Posted by ravermeister View Post
@Amnifu,
if you use a Dynamic Playlist, have you checked that you enabled
the 'is Audio' criteria?
After scanning new videos into the media library with "in_ffsox.dll" enabled, the new video files records show up in the default ML Local Library - Audio smartview. The only query this view has is "Is video equals 0". So somehow the video tag/flag/attribute (or whatever it is called) is not being set.

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 12th November 2014, 19:38   #154
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
Quote:
Originally Posted by Aminifu View Post
After scanning new videos into the media library with "in_ffsox.dll" enabled, the new video files records show up in the default ML Local Library - Audio smartview. The only query this view has is "Is video equals 0". So somehow the video tag/flag/attribute (or whatever it is called) is not being set.
I don't know how to achieve this. May be DrO can tell us how?
pbelkner is offline   Reply With Quote
Old 12th November 2014, 20:04   #155
DrO
 
Join Date: Sep 2003
Posts: 27,880
type = 1 in the metadata requests.
DrO is offline   Reply With Quote
Old 13th November 2014, 15:41   #156
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
Quote:
Originally Posted by DrO View Post
type = 1 in the metadata requests.
I've uploaded a new version.
pbelkner is offline   Reply With Quote
Old 13th November 2014, 16:18   #157
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,517
Hi pbelkner,

Version 0.3.2 fixed my issue (videos are now scanned in as videos only).

EDIT:
Unfortunately this version causes Winamp to crash when I try to open it's configuration dialog.

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 13th November 2014, 19:13   #158
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
Quote:
Originally Posted by Aminifu View Post
EDIT:
Unfortunately this version causes Winamp to crash when I try to open it's configuration dialog.
I switched back to the old gcc and now it seems to work (no new version, just new upload).
pbelkner is offline   Reply With Quote
Old 14th November 2014, 14:29   #159
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,517
Quote:
Originally Posted by pbelkner View Post
I switched back to the old gcc and now it seems to work (no new version, just new upload).
Ok, I can open the configuration dialog without a crash, but scanning in a video shows up as both a video and an audio file again. I don't understand what's so difficult about fixing this and why should in_dshow be enabled if it is not configured to handle anything?

I hope you get it figured out at some point. I'm rooting for ya.

In the meantime, I can use the new 0.3.2 to adjust the configuration and the old 0.3.2 to scan in new videos. This seems to work ok with the ffmpeg library files I linked to in post #140 above. I have not tried the latest library files.


Edit:
I notice something curious about the previous 0.3.2 release. The in_ffsox file version reported by Windows is 0.3.1 but Winamp reports it as 0.3.2. The in_ffsox file in the current 0.3.2 release is reported as 0.3.2 by both Windows and Winamp. The libdlgitemurl and libsox-2 files in both releases of 0.3.2 don't report version numbers and are the same sizes, but they have different dates so I assume they are different.

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system

Last edited by Aminifu; 14th November 2014 at 16:06.
Aminifu is offline   Reply With Quote
Old 2nd February 2015, 06:20   #160
pbelkner
Senior Member
 
Join Date: Jun 2010
Posts: 405
v0.3.3

What's new?
  • Pass -666 for bufferlenms to the output module when playing video.
According to the documentation for output modules:
pass bufferlenms==-666 to tell the output plugin that it's clock is going to be used to sync video
Possibly out_yasapi will make use of this.
pbelkner is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump