Old 5th February 2005, 16:52   #1
JNozum
Junior Member
 
Join Date: Feb 2005
Posts: 2
New versions of Flash Player not recognized

I have WinAmp 5.08d and Macromedia Flash 7 installed. However, WinAmp acts as if I have something older than version 6. Moreover, it will not allow me to update it. Instead, I get the following error:

Your current security settings prohbit running Active-X controls on this page. As a result, the page may not display correctly.

I can't seem to find anything in WinAmp itself to change this. I did move www.macromedia.com and www.silvertidemusic.com (which your Flash player update within WinAmp points to) to the Trusted Sites zone, in which I have basically everything enabled.

As for producing the error, here is how to trigger it:

1. Fire up WinAmp
2. Go into Media Library.
3. Click on "Now Playing" on the left panel.
4. Here, it will complain that I have to have at least Flash Player version 6.0.4 (or something like that).
5. Try to install Macromedia Flash Player 7. YOU CAN'T!

I went in and installed the latest Flash player within IE 6.0. However, this seems to have no bearing on WinAmp; WinAmp acts as if it is older than version 6.

Attached is a screen shot of the problem.

As for system specs, they include the following:

- 2 GHz Pentium-4
- 80 GB HD with 5 GB free on
main partition
- Windows 98 SE with most of the
latest updates
- IE 6



From John Nozum
Attached Images
File Type: jpg winamp error.jpg (56.4 KB, 298 views)
JNozum is offline   Reply With Quote
Old 5th February 2005, 18:12   #2
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
Sorry, but you'll have to report any errors with the bundled versions directly to winamp.com support.

What I suggest is that you do a clean install of Winamp 5.08d Full

Discussion | download

You can keep/backup the silvertide mp3 and/or skin first if you so wish... :/

The only way you'll get rid of those errors is to uncheck:
Prefs > Media Library > Library Options:
"Do not allow web content to execute javascript or activex controls"

However, we do not recommend doing that, as it then leaves you vulnerable to a whole plethora of Internet Explorer security exploits :/

Note that the flash error message is actually coming from the silvertide website, not from winamp. Also note that the silvertide mp3/skin/etc is only included with the bundle version that you downloaded, so therefore you won't even experience the problem with the Full (no bundled crap) version.
DJ Egg is offline   Reply With Quote
Old 6th February 2005, 00:41   #3
JNozum
Junior Member
 
Join Date: Feb 2005
Posts: 2
I thank you for your input. First of all, it WAS a clean installation (no prior version on the system).

I did, however, TEMPORARILY enable active-x just long enough to check things out. I then immediately disabled this due to the security concerns that you expressed. Oddly enough, the error disappeared when the active-x was enabled, but reappeared when I disabled active-x. Fortunately, the only component affected by this that I know of is the "Now Playing". I seem to be able to into the internet radio and TV, it works great.

Again, I thank you for your attempted help.

From John Nozum
JNozum is offline   Reply With Quote
Old 6th February 2005, 02:21   #4
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,878
Attempted help?
So you're still using the Silvertide bundled version then?
ie. you didn't uninstall it and clean install the plain Full version instead?

When said setting is checkmarked, the Now Playing (minibrowser) section of the Media Library only accepts javascript/activex-controls from the default info.winamp.com site.

When said setting is unchecked, then this enables global acceptance of Javascript and ActiveX for ALL sites. Shockwave Flash is an ActiveX Control and therefore won't work if ActiveX is disabled.

Note, you can quickly access that setting by right clicking "Now Playing" in the left pane of the Media Library. Note that for some strange reason, the setting is reversed here - ie. you need to checkmark "Allow Javascript/ActiveX" to enable it, and uncheck it to disable it (unchecked is default here). You can enable ActiveX if and when required, but we strongly recommend that you leave it disabled at all other times.

Also bear in mind that the Now Playing minibrowser is just an Internet Explorer front-end. Hence the need for those security settings.

Apart from that, none of the regulars here (including myself and any of the dev or betatester teams) have ever used any of the bundle versions. We all use either the plain Lite or Full versions. The bundle versions are all aol promotional packages, and I for one am not prepared to support them here. Support for any issues with the bundle packages must come from the provider, ie. winamp.com/aol support:
http://www.winamp.com/support/ > Contact Us
DJ Egg is offline   Reply With Quote
Old 13th February 2005, 17:49   #5
robdog2004
Major Dude
 
robdog2004's Avatar
 
Join Date: Jan 2005
Location: South Carolina
Posts: 843
Send a message via AIM to robdog2004 Send a message via Yahoo to robdog2004
i kind of have the same problem

i downloaded a swf file from a website and winamp won't play it windows media player will
robdog2004 is offline   Reply With Quote
Old 13th February 2005, 19:18   #6
drewbar
Sawg 2.0
Major Dude
 
Join Date: Mar 2004
Posts: 5,916
Winamp doesn't support playing flash files like a video. This thread refers to flash files embded in HTML in the Minibrowser

Count with us!
Jan 1st, 12AM (PST, GMT -8) 2010 - 282,246
drewbar is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump