Old 27th January 2020, 07:39   #1
Ethel Durkin
Junior Member
 
Join Date: Jan 2020
Posts: 2
Unable to use XSPF files.

G'day

I have been trying to get XSPF files to work with WinAmp with no luck. The best result I've been able to achieve is for WinAmp to open an "Open File(s)" windows at the location of the XSPF file. I've tried various syntaxes for the <location> element URL, but I have not been able to make the playlist work in WinAmp. M3U and M3U8 files work fine, but I would prefer to harness the advantages of an XML Schema playlist. Has anyone managed to use XSPF files successfully with WinAmp? What syntax for the URL did you use? Some sample working code will help me greatly!

Ethel Durkin
Ethel Durkin is offline   Reply With Quote
Old 27th January 2020, 17:16   #2
ryerman
Major Dude
 
ryerman's Avatar
 
Join Date: Mar 2010
Location: Canada
Posts: 694
Quote:
Originally Posted by Ethel Durkin View Post
...I've tried various syntaxes for the <location> element URL, but I have not been able to make the playlist work in WinAmp...
Try the full path, without any special formatting, enclosed in double quotes, like this:
code:
<location>"H:\AlbumArtist (R to Z)\S\Sharon Van Etten\2010 - Sharon Van Etten - Epic\01 - Sharon Van Etten - A Crime.flac"</location>

Windows 10 Home, 64 bit, Winamp 5.666, Bento Skin
ryerman is offline   Reply With Quote
Old 29th January 2020, 13:20   #3
Ethel Durkin
Junior Member
 
Join Date: Jan 2020
Posts: 2
Thanks for the response but no luck still. I've also tried WinAmp 5.666. A local file:/// URI schema string will work in VLC. An absolute MSDOS|CP/M filepath defeats the benefit of an open resource filepath string syntax. I'll keep tinkering.
Ethel Durkin is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump