Old 4th September 2000, 07:31   #1
fierywinter
Junior Member
 
Join Date: Sep 2000
Location: Sarasota, Florida USA
Posts: 1
Hey, when I go into the preferences and everything it says that winamp doesn't play mp3's, since last night I could but this morning something happened and I can't. The error message is:
"MMSYSTEM032 The specified format cannot be translated or supported. Use the Capabilities function to vies supported formats" That even comes up when I try to play WAV files!!! Could someone please help me out!

------------------
~~Dan
fierywinter is offline  
Old 5th September 2000, 04:28   #2
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,824
1. Try reinstalling your soundcard drivers.
Make sure they are the latest version.

2. If you've got an old soundcard, then maybe it's time to get a new one.
I recommend a full duplex card that allows multiple audio streams, eg:
Turtle Beach Santa Cruz; Guillemot GameTheatre XP; SBLive or 128 PCI; Diamond Monster MultiMedia / etc.

3. Try using Direct Sound Output instead of the WaveOut plug-in.
If you have problems with this, then I recommend you upgrade your DirectX
Also, try switching output devices in WaveOut/DirectSound config.
ie. Use your soundcard driver instead of Wavemapper/Primary Sound Driver.

4. Check out this thread in the TSGH forum for further info/tips/fixes:
TSGH -> Useful Links

5. Use the site search facility for even more topic related threads.
Search All Forums for MMSYSTEM032

6. Uninstall -& Reinstall Winamp & get wa2update

------------------
**********
DJ - Egg
**********
^/^
`v

[Edited by DJEgg : 21st Jan 2002]
DJ Egg is offline  
Old 21st January 2002, 14:59   #3
tricky_slider
Junior Member
 
Join Date: Jan 2002
Location: London
Posts: 7
Send a message via ICQ to tricky_slider
bad thread.

Invalid thread specified. If you followed a valid link, please notify the webmaster.


BTW, this appears to be a VERY common problem (I'm suffering from it now). Is there anyone out there who has actually encountered the problem AND overcome it (rather than someone who was able to replicate it) ?
tricky_slider is offline  
Old 21st January 2002, 15:58   #4
peter
ist death
 
peter's Avatar
 
Join Date: May 2000
Posts: 3,704
common ? it's been a few months since i saw an mmsystem last time. is it so bloody diffucult for you to use search function ?
peter is offline  
Old 21st January 2002, 16:16   #5
tricky_slider
Junior Member
 
Join Date: Jan 2002
Location: London
Posts: 7
Send a message via ICQ to tricky_slider
Excuse me ???!
I've used a number of search engines and newsgroup searches. I've also found a *great many* links (which is why I'm assuming it's a 'common' problem).
However, none of the hits have been posted by someone who has experienced the error message first hand and then gone on to solve it.
I have found no definitive solution, only suggestions.

FYI: I've tried ALL the suggestions posted on winamp.com - if any of them had worked I wouldn't still be looking for a solution...
Has it occurred to you that there have been no new posts because all the options have already been posted, and no-one has any new suggestions ? I'm hoping those that solved it (if they did so without a reformat) just need a little kick to post that fix.

Lastly, is it so 'bloody diffucult' [sic] for you to use a spellchecker trollboy? If you can't be helpful - don't bother.
tricky_slider is offline  
Old 21st January 2002, 16:27   #6
BlurPak2k1
Senior Member
 
Join Date: Jun 2001
Location: well you got to find me first :D
Posts: 201
jesus christ, just reformat and start over from the beginning you winer.
BlurPak2k1 is offline  
Old 21st January 2002, 16:30   #7
Kaboon
Moderator
 
Kaboon's Avatar
 
Join Date: Jun 2000
Location: Netherlands
Posts: 2,494
Send a message via ICQ to Kaboon
RE: MMSYSTEM032 Error : Problems with WAV & MP3 Files :
1. Couldn't Find Destination Format
http://forums.winamp.com/showthread.php?threadid=31604
http://forums.winamp.com/showthread.php?threadid=31799
http://forums.winamp.com/showthread.php?threadid=32572
http://forums.winamp.com/showthread.php?threadid=20722
2. Specified Format Not Supported, Use Capabilities Function
http://forums.winamp.com/showthread.php?threadid=32696
http://forums.winamp.com/showthread.php?threadid=31358
http://forums.winamp.com/showthread.php?threadid=32082
http://forums.winamp.com/showthread.php?threadid=31948
Guaranteed Fix c/o
http://members.aol.com/networldb/winampfix.html

You have tried all suggestions in these threads?
Kaboon is offline  
Old 21st January 2002, 16:34   #8
peter
ist death
 
peter's Avatar
 
Join Date: May 2000
Posts: 3,704
fyi, mmsystem032 is commonly caused by those smartass newbies touching config settings they aren't supposed to touch (eg. installing MAD mp3 decoder and enabling its 24bit output mode on a system which doesn't support 24bit output).
geez, sometimes i just don't know why i involve myself in all this shit. i don't think you've checked places like TSGH before posting here.
[edit] damn i'm slow
peter is offline  
Old 21st January 2002, 16:44   #9
tricky_slider
Junior Member
 
Join Date: Jan 2002
Location: London
Posts: 7
Send a message via ICQ to tricky_slider
yawn

BlurPak2k1: 'whiner' is spelled with an 'h'.

Kaboon: Cheers, I appreciate the help, but I've seen those links cut and pasted a thousand times. I said I'd tried all DJEgg's suggestions.

peter: 'fyi'? try 'imho'. yes... I've read the stuff about MAD. It's not that. Does TSGH have suggestions that aren't posted elsewhere ? And as for 'newbie'. Don't even try it. Only self-important dicks use the word 'newbie' it went out of fashion about five years ago. I bet you still talk about 'discos' and 'raves' as well don't you ?

...isn't this forum supposed to be moderated ?
tricky_slider is offline  
Old 21st January 2002, 16:50   #10
binary hero
Banned
 
Join Date: Jun 2001
Posts: 7,004
Send a message via ICQ to binary hero
Re: yawn

Quote:
Originally posted by tricky_slider
BlurPak2k1: 'whiner' is spelled with an 'h'.

Kaboon: Cheers, I appreciate the help, but I've seen those links cut and pasted a thousand times. I said I'd tried all DJEgg's suggestions.

peter: 'fyi'? try 'imho'. yes... I've read the stuff about MAD. It's not that. Does TSGH have suggestions that aren't posted elsewhere ? And as for 'newbie'. Don't even try it. Only self-important dicks use the word 'newbie' it went out of fashion about five years ago. I bet you still talk about 'discos' and 'raves' as well don't you ?

...isn't this forum supposed to be moderated ?
didn't YOU come here for help? so, the best way of getting any help is to troll, right.

moderated? yeah, you are right, only 3 mods have posted on this thread. damn they are soo solw these days, and they have no appreciation for NEWBIES like you coming in. They would never try to help now, would they.
binary hero is offline  
Old 21st January 2002, 16:55   #11
peter
ist death
 
peter's Avatar
 
Join Date: May 2000
Posts: 3,704
still no joy ? this should shut you up (or at least give better error messages). you didn't bother changing output plugins / device in output plugin settings, did you ?
peter is offline  
Old 21st January 2002, 17:00   #12
tricky_slider
Junior Member
 
Join Date: Jan 2002
Location: London
Posts: 7
Send a message via ICQ to tricky_slider
the word 'newbie' ? - I rest my case.

You're right. I did come here for help. So far, I've had a 'moderator' reply with a cut and paste from another thread, and a bunch of shelfstackers giving me abuse.

I'll ask again.
Is there anyone out there who has actually encountered the problem AND overcome it (rather than someone who was able to replicate it) ?
tricky_slider is offline  
Old 21st January 2002, 17:07   #13
peter
ist death
 
peter's Avatar
 
Join Date: May 2000
Posts: 3,704
am i invisible ?
peter is offline  
Old 21st January 2002, 17:33   #14
tricky_slider
Junior Member
 
Join Date: Jan 2002
Location: London
Posts: 7
Send a message via ICQ to tricky_slider
still trying...

peter. Are you saying you had this problem and you overcame it ? (and I don't mean you forced the problem by tinkering with settings)...
Did the problem manifest itself overnight following an otherwise unremarkable period of successful mp3 playing ?

oh, and call me mental, but I'm not about to install an executable you just uploaded.
tricky_slider is offline  
Old 21st January 2002, 17:44   #15
Kaboon
Moderator
 
Kaboon's Avatar
 
Join Date: Jun 2000
Location: Netherlands
Posts: 2,494
Send a message via ICQ to Kaboon
If you don't thrust it, well just don't download and install that file. Too bad though, then you'll just need to wait for a new Winamp version to come out. And belive me, that can take a while.

Please note: Peter now develops the output plug-ins from the new official upcomming Winamp releases. The (new) plug-ins that are going to be in the next release, are in that file. They will fix a lot of common problems, including this one.

Greetings.
Kaboon is offline  
Old 21st January 2002, 17:49   #16
tricky_slider
Junior Member
 
Join Date: Jan 2002
Location: London
Posts: 7
Send a message via ICQ to tricky_slider
at last! a reasonable voice ;-)

OK. Cheers Kaboon.
Aren't the fixes in Winamp3 beta 2 though ?

I'm quite happy to download and install that. Just not so happy to install something somebody just uploaded minutes after flaming me...
tricky_slider is offline  
Old 21st January 2002, 18:03   #17
peter
ist death
 
peter's Avatar
 
Join Date: May 2000
Posts: 3,704
i flamed you because:
1. if you really looked through TSGH etc, you would have downloaded wa2update already (well, maybe some TSGH topics are out-of-date); wa2update is our "recommended remedy for common problems (tm)". (or maybe you just didn't read all the shit on bug reports forum, thanks god not all people go there immediately after they see an error)
2. you claimed that you had read TSGH, FAQs, etc, but you didn't even tell us what solutions you had already tried (eg. switching output plugins, changing devices in output plugin config, etc). how can anyone look for a better solution without knowing that ?
peter is offline  
Old 21st January 2002, 20:29   #18
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,824
What a carry on!

1) Revived a 16 month old thread....
Naturally some of the links are going to be invalid, the forums have been upgraded twice since then, and many old threads have been deleted by admin (ie. mass pruning).

2) I've edited my ancient post above. Try again

If I had to update every single thread linked to in TSGH -> Useful links, I'd still be at it by this time next year. Seeing I'm just a lowly, voluntary (unpaid) helper, then this isn't ever likely going to happen.

3) The flames, the flames . . . omg, the flames.

4) Kaboon pasted from an old version of TSGH -> Useful Links

Current version:

RE: MMSYSTEM032 Error : Problems with DivX/MP3-Layered WAV Files:
1. Couldn't Find Destination Format
http://forums.winamp.com/showthread.php?threadid=53348
http://forums.winamp.com/showthread.php?threadid=31604
http://forums.winamp.com/showthread.php?threadid=31799
http://forums.winamp.com/showthread.php?threadid=32572

Guaranteed Fix for error #1 c/o
http://members.aol.com/networldb/winampfix.html
If this link is down, try here or here instead.

RE: MMSYSTEM032 Error : Problems with 24-bit/32-bit files
2. Specified Format Not Supported, Use Capabilities Function
http://forums.winamp.com/showthread.php?threadid=32696
http://forums.winamp.com/showthread.php?threadid=31358
http://forums.winamp.com/showthread.php?threadid=32082
http://forums.winamp.com/showthread.php?threadid=31948

Update: Please check this thread for further details/fixes for error #2 (wa2update)

5) If you still require assistance, please state the nature of the problem exactly and provide full system specs (incl. Windows OS, Soundcard, DirectX version, Winamp version, etc etc). Also confirm: what you've tried from above, whether you can play MP3's in other players (eg. WMP), whether you've installed any replacement input plugins (MAD, MP3Pro, etc), blah de blah.

6) Or just confirm it's fixed
DJ Egg is offline  
Old 23rd January 2002, 20:21   #19
BlurPak2k1
Senior Member
 
Join Date: Jun 2001
Location: well you got to find me first :D
Posts: 201
Quote:
the word 'newbie' ? - I rest my case.
yep im lookn over at j00, slider
BlurPak2k1 is offline  
Old 23rd January 2002, 20:47   #20
Wish
Major Dude
 
Join Date: Oct 2000
Posts: 702
Never insult/piss off the wa2/wa3 plugin god(coder), Peter Pawlowski.
Wish is offline  
Old 23rd July 2005, 04:46   #21
oliewankanobe
Junior Member
 
Join Date: Jul 2005
Posts: 1
I registered with this forum for the SOLE purpose of putting two cents in here:

A. Windows 98 users may have this problem if their directx settings were mucked about with by a virus or even system changes made by some system tools. That was my own experience, and updating directx fixed the problem.


B. I, too, explored all the links here and found no solutions.

C. I am a Winamp Pro user, but never bothered registering for this forum to get help or tips for precisely the reason this thread ended up offending people who asked for help. Nobody likes a smartass, particularly when they come to Nullsoft with legitimate questions.

D. Being a smartass is only charming when you can actually pull it off rather than sounding like one of those nerds who seem to know a lot but actually don't... you know, those guys who show up at the Trek conventions speaking Klingon and thinking that makes them the shit when actually it makes them about as likely to get laid as a leper at a convention for the obsessive-compulsively germaphobic.

Just a few thoughts and all.
oliewankanobe is offline  
Old 23rd July 2005, 13:03   #22
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,824
Please don't revive 5-year old threads. Thank you.
DJ Egg is offline  
Closed Thread
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump