Old 22nd October 2007, 20:14   #1
muckster
Senior Member
 
Join Date: Mar 2004
Location: New York
Posts: 124
Cover Art Downloads Fail

Hey y'all,
really love what you did with 5.5, the new skin is very nice indeed. And because the info box, I'm not really trying to update all my cover art... and finding out that I'm having a hard time. 90% of the time I try to get album art, there's either nothing found, or the download fails -- and these are files that are nicely tagged.

Any advice on how to improve the performance of the cover art downloader?

Cheers--
muckster
muckster is offline   Reply With Quote
Old 23rd October 2007, 03:13   #2
path2k7
Junior Member
 
Join Date: Oct 2007
Posts: 3
I had the same issue, it finds 8 matches for cover art and fails downloading all 8.
path2k7 is offline   Reply With Quote
Old 23rd October 2007, 20:20   #3
xchaosx674
Junior Member
 
Join Date: Oct 2007
Posts: 4
i get the same problem. i checked windows firewall(on vista x64), Winamp wasn't added to the exception list, so i added it thinking that would fix the problem. It still fails in downloading the cover art .
xchaosx674 is offline   Reply With Quote
Old 23rd October 2007, 20:55   #4
Redskin23
Junior Member
 
Join Date: Oct 2007
Posts: 7
Yes, this seems to be an issue. Even with some "very well known" albums, the cover art isn't being downloaded successfully. Also, there doesn't seem to be a way to add your your own art if it can't find it. I also noticed that 5.5 saves album art as a jpeg in the same location where the album itself is stored. I tried to copy and paste album art into the file location, that didn't work either. Other than that I have no complaints about 5.5.
Redskin23 is offline   Reply With Quote
Old 23rd October 2007, 20:58   #5
muckster
Senior Member
 
Join Date: Mar 2004
Location: New York
Posts: 124
My workaround has been to right-click the llama where the album art should be and select "open folder." I do a Google image search for the artist/album, drag the image into the folder, and rename it folder.jpg. If you right click the llama again and pick "refresh art", it shows up. I guess it works, but it's not as elegant as simply hitting "get album art."
muckster is offline   Reply With Quote
Old 23rd October 2007, 21:13   #6
Redskin23
Junior Member
 
Join Date: Oct 2007
Posts: 7
lol, thats so weird. It works though, thanks!!!
Redskin23 is offline   Reply With Quote
Old 23rd October 2007, 21:14   #7
Redskin23
Junior Member
 
Join Date: Oct 2007
Posts: 7
how did you know to rename the file "folder.jpg"?
Redskin23 is offline   Reply With Quote
Old 23rd October 2007, 21:18   #8
Redskin23
Junior Member
 
Join Date: Oct 2007
Posts: 7
Okay, you don't have to do the search part per se. If you have the album art in the folder, rename it to "folder.jpg" then right-click the llama and select refresh album art.
Redskin23 is offline   Reply With Quote
Old 23rd October 2007, 21:21   #9
muckster
Senior Member
 
Join Date: Mar 2004
Location: New York
Posts: 124
Oh right, sure. I don't remember how I knew it had to be named folder.jpg.

The other thing I'm wondering about is if this will work with ml_ipod and the iPod album art features.
muckster is offline   Reply With Quote
Old 24th October 2007, 11:25   #10
5354
Junior Member
 
Join Date: Oct 2007
Posts: 5
There should also be a function to edit the album art of ALLL songs or 1 single album.

I tried it and I did it one by one but it failed.
5354 is offline   Reply With Quote
Old 24th October 2007, 12:33   #11
WelshBoy
Junior Member
 
Join Date: Sep 2007
Posts: 49
It doesn't have to be named folder.jpg.

All my art is called 'album name'.jpg

If you get the artwork through Winamp it also calls it 'album name'.jpg
WelshBoy is offline   Reply With Quote
Old 24th October 2007, 12:35   #12
WelshBoy
Junior Member
 
Join Date: Sep 2007
Posts: 49
Oh, and if you have an album with a '?' in the title, eg (What's The Story) Morning Glory?, you can call the art "(What's The Story) Morning Glory_.jpg" and it'll pick it up.

Because you can't use '?' in filenames, but it seems to see the '_' as a '?'.
WelshBoy is offline   Reply With Quote
Old 24th October 2007, 22:04   #13
cs188
Member
 
cs188's Avatar
 
Join Date: Mar 2005
Location: New York, USA
Posts: 93
Send a message via AIM to cs188
From my experience, you can name the .jpg anything you want (mine is called "cover"). Winamp should pick it up and associate that cover art with all audio files in that folder. Excellent new feature in my opinion.

As far as the album art downloads failing most of the time, I have the exact same problem. So I just obtain my album art manually as a workaround, until this issue is fixed.
cs188 is offline   Reply With Quote
Old 24th October 2007, 22:25   #14
Redskin23
Junior Member
 
Join Date: Oct 2007
Posts: 7
Well I just renamed the .jpg file to "whatever".jpg, and it didn't pick up the art. I renamed it back to folder.jpg and it worked again. I don't know, its not a big issue I still love Winamp anyways!!!
Redskin23 is offline   Reply With Quote
Old 24th October 2007, 22:30   #15
Redskin23
Junior Member
 
Join Date: Oct 2007
Posts: 7
It would be sweet if I could ZOOM into the album art as a right-click option. I like to analyze album art, it tells me a lot about the artist/DJ or whatever. Love Ya!!!
Redskin23 is offline   Reply With Quote
Old 28th October 2007, 19:10   #16
gomjh
Junior Member
 
Join Date: Oct 2007
Posts: 2
It would just be a lot easier if they fixed the download problem. This was working great for me when I first installed, but now it's constantly finding art but failing to download it.
gomjh is offline   Reply With Quote
Old 31st October 2007, 23:07   #17
pipedreambomb
Junior Member
 
Join Date: Oct 2007
Posts: 8
Same here, Cover Art Downloader finds the image, but fails to download it. I tried turning off Windows Firewall, but it didn't help. Looking forward to this, when it works! Love the new skin etc.
pipedreambomb is offline   Reply With Quote
Old 31st October 2007, 23:15   #18
siebe83
Forum King
 
siebe83's Avatar
 
Join Date: Feb 2004
Posts: 9,222
Not really a fix for the problem you are having, but an alternative way to easily find and save album art:
http://team.thenexusnet.com/nexus/AAA/

(easier than using Google and saving as folder.jpg)


I haven't really tried Winamp's album art download feature myself.

Good Winamp plugins by Joonas, DrO and shaneh.
If you're bored go here or, if the boredom is more serious, here.
siebe83 is offline   Reply With Quote
Old 31st October 2007, 23:27   #19
pipedreambomb
Junior Member
 
Join Date: Oct 2007
Posts: 8
Looks like an interesting tool, but my music isn't saved in any particular directory structure (e.g artist\album (year)), but fairly randomly named folders, etc. I expect you can re-organise your files into a certain structure, but I don't really want to, especially as I have like 60gbs of music, so it would take a long time to process.
pipedreambomb is offline   Reply With Quote
Old 20th November 2007, 03:15   #20
moktoman
Member
 
moktoman's Avatar
 
Join Date: Oct 2003
Location: Bay Area, California
Posts: 71
Send a message via AIM to moktoman Send a message via Yahoo to moktoman
I can confirm this issue.
The strange thing is that the album art downloading worked fine the first few days after I installed 5.5, then suddenly stopped working out of the blue.
Maybe it is a server-side issue?

Whatever the case, I hope it is fixed soon, because I have to say that I love this feature!
moktoman is offline   Reply With Quote
Old 20th November 2007, 03:47   #21
gomjh
Junior Member
 
Join Date: Oct 2007
Posts: 2
I find it odd that we've posted this in the Tech Support forum yet there hasn't been any sort of response from the Winamp team.
gomjh is offline   Reply With Quote
Old 20th November 2007, 10:47   #22
pipedreambomb
Junior Member
 
Join Date: Oct 2007
Posts: 8
Just to follow up my post saying it wasn't working - it does now, without me having done anything to fix it or updating Winamp, so I guess it was a server-side problem. Some downloads still fail though.
pipedreambomb is offline   Reply With Quote
Old 5th February 2008, 17:05   #23
Wonderland
Junior Member
 
Join Date: Feb 2008
Posts: 2
I have the newest version 5.52 and the download still fails on some albums among others Rammstein - Reise Reise.
It says it finds one cover but fails to download it.

So is there any way to fix it on my end or is it a serverside problem?
Wonderland is offline   Reply With Quote
Old 5th February 2008, 22:06   #24
pipedreambomb
Junior Member
 
Join Date: Oct 2007
Posts: 8
No, it still only partially works for me too. It will say it finds, for example, 9 covers and 4 fail. But it's the same 4 that fail every time. In the meantime, I use albumart.org, very quick and easy search engine for album covers:

Right click where the album art should be in Winamp and click 'open folder'. Then you can copy the folder address (if you have folder addresses enabled in Windows), and paste that into dialog that chooses where to save the picture from albumart.org. Call the file folder.jpg and then click refresh on the blank picture in Winamp and it should load.
pipedreambomb is offline   Reply With Quote
Old 5th February 2008, 23:07   #25
Wonderland
Junior Member
 
Join Date: Feb 2008
Posts: 2
Quote:
Originally posted by pipedreambomb
No, it still only partially works for me too. It will say it finds, for example, 9 covers and 4 fail. But it's the same 4 that fail every time. In the meantime, I use albumart.org, very quick and easy search engine for album covers:

Right click where the album art should be in Winamp and click 'open folder'. Then you can copy the folder address (if you have folder addresses enabled in Windows), and paste that into dialog that chooses where to save the picture from albumart.org. Call the file folder.jpg and then click refresh on the blank picture in Winamp and it should load.
Yeah I know about it but I just think that sence they have a system in place to do it automatically I shouldn´t have to. But this problem has existed sence it was implemented so why hasn´t it been fixed?
Wonderland is offline   Reply With Quote
Old 7th February 2008, 04:56   #26
pipedreambomb
Junior Member
 
Join Date: Oct 2007
Posts: 8
Because life sucks
pipedreambomb is offline   Reply With Quote
Old 7th February 2008, 10:56   #27
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,824
If the 'Get Album art' feature fails to find any matches, even for well known commercial artists/albums, then:

1. Make sure aol.com isn't blocked in the hosts file or by some scriptblocker.
The service connects to coverart.music.aol.com, which in turn uses the AMG database from allmusic.com

2. Make sure none of aol.com or music.aol.com or coverart.music.aol.com are in the Restricted Sites zone in Internet Explorer settings

3. Confirm that you've got the Internet Zone level set to Default in IE options -> Security, or try adding music.aol.com to the Trusted Sites zone.


If it finds matches, but always says 'download failed', then this suggests a problem with the Internet Explorer cache. Try emptying Temporary Internet Files via IE options.


For manually loading album art, refer to the FAQ
http://forums.winamp.com/showthread....did=161361#art

(includes links to all the info you need regarding filename criteria, etc)


If the problem persists, please read this first:
http://forums.winamp.com/showthread....d=161361#specs
DJ Egg is offline   Reply With Quote
Old 7th February 2008, 16:10   #28
pipedreambomb
Junior Member
 
Join Date: Oct 2007
Posts: 8
Well for what it's worth, the problem has persisted even since I bought a new hard drive, clean installed windows xp and winamp and copied over my media files. Perhaps it's an issue with my router, my isp, or something of that nature?
pipedreambomb is offline   Reply With Quote
Old 7th February 2008, 18:29   #29
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,824
Hmm, yeah, lord knows.
All I can say is that it all works wonderfully fine here :-)
DJ Egg is offline   Reply With Quote
Old 13th February 2008, 17:52   #30
valenshek
Junior Member
 
Join Date: Feb 2008
Posts: 2
The album art downloads fine for most of my albums. But I've noticed that for all of the albums released within the past few years, images are found but the download fails. This never happens for older albums. Anyone else notice this?

Also, I've noticed with some tweaking to the album name I've been able to get a lot of album art to download that would previously say "no album art found". Winamp doesn't seem to like any punctuation in the album name (dashes, dots, apostraphes, question marks, and ampersands) when looking for album art. When I remove those characters from the album names of albums that it can't find any images for, it will usually find the art.

Also, try to use the Auto-Tag option (go into the file info by double clicking on the scrolling title, and click Auto Tag). This clears up a lot of errors in file naming, such as incorrect years, which will make it easier to find the album art.
valenshek is offline   Reply With Quote
Old 13th February 2008, 18:08   #31
pipedreambomb
Junior Member
 
Join Date: Oct 2007
Posts: 8
I think if anything, I have better luck with newer albums than old ones. But then I also listen to a lot more older albums than new ones (I think!), so maybe I'm looking up more old ones that go wrong. Cause and effect is confusing.
pipedreambomb is offline   Reply With Quote
Old 19th February 2008, 02:22   #32
Archonius
Junior Member
 
Join Date: Aug 2002
Posts: 16
not work

hello,

it only works on like half my albums

for example, linkin park minutes to midnight, it finds 5 but fails to download 5.

aladdin soundtrack, found 1, succeeded 1.

any ideas.
Archonius is offline   Reply With Quote
Old 19th February 2008, 15:34   #33
pipedreambomb
Junior Member
 
Join Date: Oct 2007
Posts: 8
Sorry, I don't think anyone knows why this happens, or how to fix it. As I said above, the weird thing is not that some pictures 'fail' when downloading, but that it's the exact same ones that 'fail' each time.

You can get 3/7 'fail' for instance, and that wouldn't be a problem if you could just run it again and hopefully get them the second time around. But it will be the exact same 3 pictures that 'fail' next time too.

Just as an aside on a similar topic, I've realised recently that when you get the '0 images found' message, if you rename the files using the Autotag function, it'll generally be able to find the album art, which saves having to download them manually.
pipedreambomb is offline   Reply With Quote
Old 17th May 2008, 00:41   #34
Ceebs19
Junior Member
 
Join Date: May 2008
Posts: 5
Any album from 2007 or later always fails, whereas most of the other albums i try work fine (including 2006).

What gives??
Ceebs19 is offline   Reply With Quote
Old 17th May 2008, 02:17   #35
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,824
It definitely fails on compilation albums (e.g. where the Album Artist = Various Artists)

For the ones it fails on, just go to any site like www.discogs.com or www.allmusic.com - find the album, and manually save the art as cover.jpg or folder.jpg in the same folder where the album's mp3 files are located.

Here's the FAQ link again
http://forums.winamp.com/showthread....did=161361#art

If there's more than one album in said folder, then you'd need to save it as %album%.jpg instead, where %album% = the exact album title. If there's any illegal filename characters then see the link I posted above for what characters to replace them with.


Basically, I think it's a limitation of the service provided to us by allmusic.com.
Maybe we should switch to some other service. Lord knows, heh.
DJ Egg is offline   Reply With Quote
Old 7th December 2010, 10:01   #36
liftarn
Junior Member
 
Join Date: Jun 2010
Location: Stockholm, Sweden
Posts: 4
Quote:
Originally Posted by muckster View Post
Any advice on how to improve the performance of the cover art downloader?
The problem is WinaAmp only looks at music.aol.com instead of using sites with more covers like Discogs and Last.fm. So far there seems to be no solution. I haven't found any plugin to fix it either. There are some stand-alone programs as well as a plugin for Musicbrainz Picard.
liftarn is offline   Reply With Quote
Old 7th December 2010, 20:26   #37
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,625
Send a message via AIM to MrSinatra
Quote:
Originally Posted by DJ Egg View Post
It definitely fails on compilation albums (e.g. where the Album Artist = Various Artists)

<snip>

Basically, I think it's a limitation of the service provided to us by allmusic.com.
Maybe we should switch to some other service. Lord knows, heh.
i always suspected that while you use gracenote for tags, you use AMG for art. glad to have that confirmed.

however, if they are limiting you, its either deliberately or carelessly, b/c AMG can, very successfuly, service art for pretty much any CD, including comps.

afaik, WMP also uses AMG to service art, and it gets the comps/VA ones np.

i think there is a basic, systemic issue in your paradigm. in others words, someone just needs to look over the process and figure out why only comp/VA albums ALWAYS fail, b/c i am 99% sure the problem is in the process.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump