Old 26th September 2013, 21:30   #1
Syracuse
Junior Member
 
Join Date: Sep 2013
Posts: 7
Milkdrop keeps freezing whenever I type in another window.

Pretty much what the title says, I've had this problem where milkdrop keeps freezing randomly for a while now, and have only just nailed down specifically when it happens. I tested with notepad, typed a few things and backspaced and stuff, and milkdrop automatically freezes. If I leave it running without using any other windows, it runs perfectly fine.

Does anybody have any clue how to fix this? I've tried messing around with the different settings in milkdrop, but have still had no luck. Maybe there's a setting I'm missing or something, that's probably the reason.

Specs:
Windows 7 64-bit
8GB DDR3 RAM
i7 multi-threaded processor
2GB Nvidia Geforce GT 740M Graphics

There's also an integrated intel graphics, purely for low processing applications, I don't think it should be affecting it, this had been happening on another laptop I had.

Any help would be much appreciated!
Syracuse is offline   Reply With Quote
Old 26th September 2013, 23:16   #2
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,569
Send a message via AIM to MrSinatra
what ver winamp?

have you tried safe mode? prob need to post your info tool results.

and btw, i'd guess its using the integrated graphics unless it indicates otherwise.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 26th September 2013, 23:28   #3
Syracuse
Junior Member
 
Join Date: Sep 2013
Posts: 7
Hi Sinatra, thank you for the fast response!

I'm using Winamp v5.7.3367. I'm not sure how to get the info tool results you're talking about, is that a windows utility, or is that within Winamp? Also, I checked via the nvidia settings, and winamp's global setting is the high performance nvidia card. I have not checked if safe mode would fix it, although I'm pretty sure it won't affect it. I will check anyways though, and post back soon.

Edit: Okay, so I attempted to test this issue in safemode, however, I should have realised that wouldn't work. Couldn't play any music, so the visualization wouldn't have been active anyways, and the directx driver was not loaded, so I couldn't even start milkdrop. What should I try next?

Edit 2: Sorry for second edit, but I tested it a bit more, and found out it's not just when I'm typing in another window, it happens after having another windows selected for 5 seconds or more. It's really strange.
Syracuse is offline   Reply With Quote
Old 26th September 2013, 23:57   #4
Syracuse
Junior Member
 
Join Date: Sep 2013
Posts: 7
My Info Tool Report

I just googled what that was, and downloaded the tool. I've added an extended report as a zip archive, I hope that's what you want. Here's hoping a path to a solution can be determined from it.
Attached Files
File Type: zip Winamp_Info_Report_26.09.2013.zip (4.2 KB, 218 views)
Syracuse is offline   Reply With Quote
Old 27th September 2013, 00:30   #5
DrO
 
Join Date: Sep 2003
Posts: 27,873
you'd be better trying things using v5.65 and not the massively outdated v5.7 beta you're using (it's unlikely it'll help but safe mode should be more reliable than what was in the earlier v5.7 beta builds as you're using and also v5.65 is supported unlike a beta from months back).

as such, my only other suggestion is to check what device is specified for Milkdrop to use and pick the alternative to what it's currently set to use.
DrO is offline   Reply With Quote
Old 27th September 2013, 00:43   #6
Syracuse
Junior Member
 
Join Date: Sep 2013
Posts: 7
I actually had the same problem in 5.65, that's why I switched to another version to see if it works. The version number doesn't seem to affect it :/ Just tried the integrated graphics instead of the dedicated card, no difference to be had. Thanks for the help though.
Syracuse is offline   Reply With Quote
Old 27th September 2013, 00:45   #7
DrO
 
Join Date: Sep 2003
Posts: 27,873
if it's the same irrespective of the device in use then it's most likely something about what you've got installed on your machines which is messing with Milkdrop - i don't know how / why but maybe something which does overlays or some other form of graphics output. the only solution really is to use a different vis plug-in (if that isn't also affected by the issue) or to try to find the cause of it by debugging what Milkdrop is doing (as the source code for the version you're using is freely available).
DrO is offline   Reply With Quote
Old 27th September 2013, 01:06   #8
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,569
Send a message via AIM to MrSinatra
just to be clear, I meant winamp's safe mode, not windows safe mode.

i'd also make sure all your drivers are up to date.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 27th September 2013, 03:14   #9
Syracuse
Junior Member
 
Join Date: Sep 2013
Posts: 7
Thank you for all your help. My drivers are well up to date, but I'm not experienced enough to debug the program as you described myself. I don't know enough to be able to do it. Might try and see if I can fix it with a different plugin though, and see if that helps.

Edit: I found the Winamp safe mode option, but the issue is I can't run the milkdrop plugin, as it does not get loaded. Just to be clear, Winamp itself does not freeze. I can stop and restart milkdrop in desktop mode and Winamp will keep pumping out the tunes with no problem. I will check back tomorrow, gotta sleep soon..
Syracuse is offline   Reply With Quote
Old 27th September 2013, 19:16   #10
Syracuse
Junior Member
 
Join Date: Sep 2013
Posts: 7
I've determined what is causing the issue.

Hi.

After some pretty thorough trial and error testing, I've determined that the theme I have installed is somehow causing the issue with milkdrop freezing. It doesn't matter what I have selected in the performance options for windows, that's the first thing I tried. I have the Placebo Ashtray theme found at deviantart installed, and that is the issue. When I select a windows aero default theme and try running milkdrop, it runs perfectly, but when I have the Ashtray theme selected, milkdrop freezes when I'm in another window. Hopefully this is a step in the right direction, and I'm kind of hoping there's some way to edit the theme files so that I can fix this problem but afaik this issue is unique. The only other option I have is to either not use milkdrop at all, or find a different theme that is similar to Ashtray, and see if that will work instead, unless one of you knowledgeable folks knows a way to find out what I need to edit in the themes files.
Syracuse is offline   Reply With Quote
Old 27th September 2013, 21:39   #11
MrSinatra
Forum King
 
MrSinatra's Avatar
 
Join Date: Dec 2004
Location: WKPS, State College
Posts: 5,569
Send a message via AIM to MrSinatra
its important to always test problems against a vanilla, default setup, to see if they persist. safe mode is helpful in that regard as well. I should have told you to try vs Bento.

Idk anything about skins/themes, hopefully someone can help you.

EDIT: duh on me again, I thought you meant winamp themes, not windows ones.

PENN STATE Radio or http://www.LION-Radio.org/
--
BUG #1 = Winamp skips short tracks
Wish #1 = Multiple Column Sorting
Wish #2 = Add TCMP/Compilation editing
MrSinatra is offline   Reply With Quote
Old 27th September 2013, 22:01   #12
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
Originally Posted by Syracuse View Post
I've determined that the theme I have installed is somehow causing the issue with milkdrop freezing.
seems that messing with OS themes causes more issues than is worth it at times as they often affect the functionality in the OS as i've seen random dialog failures in Winamp due to some OS themes. other than checking for an update / notifying the theme author, due to the nature of such things often trashing Windows installs (at least from what i've seen), i don't think anyone from this side of the fence is likely to look into (that and with Milkdrop now open sourced, it's not really getting any official support anymore unless it's critical to Winamp breakages).
DrO is offline   Reply With Quote
Old 29th September 2013, 16:53   #13
Syracuse
Junior Member
 
Join Date: Sep 2013
Posts: 7
Quote:
Originally Posted by DrO View Post
seems that messing with OS themes causes more issues than is worth it at times
True that, eh? Anyways, thanks for you and Mr. Sinatra's help, I'm just glad I was able to discover the problem. I've found a different theme that is similar enough to the one I had that has no issues, so that's all good. I was half afraid any theme I used would produce similar problems, but no, it's just the ashtray theme =P.

Again, thanks for your help!
Syracuse is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Tags
freeze, freezing, milkdrop, winamp

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump