Old 2nd July 2010, 10:35   #1
Chahine
Junior Member
 
Join Date: Jul 2010
Posts: 6
Local media is unable to load nde.dll

Hi all,

I'm working on a plugin for Winamp, which compiles and runs well using Visual C++ Debug mode. But when I switch to Release mode, the code still compiles but doesn't run anymore ; indeed, Winamp crashes at startup with the following error :

Local Media was unable to load library ("nde.dll") which is required.
Local Media cannot continue succesfully and will be turned off.

Note that as my code uses music tags, I had first to compile and link mlExplorer/nde from Winamp SDK, which makes a new nde.dll file in Winamp's directory ; so I also switched those two projects to Release mode.

I'm running under Windows 7 64 bits. Has anyone an idea on how to fix this ?
Thank you in advance !
Chahine is offline   Reply With Quote
Old 15th July 2010, 09:10   #2
Chahine
Junior Member
 
Join Date: Jul 2010
Posts: 6
No one has an idea ?
Chahine is offline   Reply With Quote
Old 23rd July 2010, 14:14   #3
DrO
 
Join Date: Sep 2003
Posts: 27,873
its most likely due to your nde.dll being from an older codebase which conflicts with the version the Winamp client and dlls expect (as it expects an mde.dll from that release typically).

you'd have to look at creating your nde.dll with a different name or just embedding it as a statically compiled library into your plug-in.

-daz
DrO is offline   Reply With Quote
Old 24th August 2010, 13:54   #4
Chahine
Junior Member
 
Join Date: Jul 2010
Posts: 6
I embedded it as a static library and it worked. Thank you !
Chahine is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Developer Center > Winamp Development

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump