Old 14th June 2017, 06:18   #1
umeca74
Junior Member
 
Join Date: Jan 2009
Posts: 21
version 3 backward compatibility

I am using nsis v2.51 with the once "modern" interface MUI.nsh and a few other plugins (FileFunc, StrFunc, x64 and some functions I wrote). I also have some super-plain installers with the ancient plain interface

lately I was plagued with AV false positives and I am considering updating to version 3.01. Will my existing v2.51 scripts work generating the same installer?
umeca74 is offline   Reply With Quote
Old 14th June 2017, 10:08   #2
JasonFriday13
Major Dude
 
JasonFriday13's Avatar
 
Join Date: May 2005
Location: New Zealand
Posts: 853
For the most part, NSIS 3 can compile any NSIS 2 script. The main difference is that NSIS 3 has unicode support.

FYI, FileFunc, StrFunc and x64 are code headers, not plugins.

"Only a MouseHelmet will save you from a MouseTrap" -Jason Ross (Me)
NSIS 3 POSIX Ninja
Wiki Profile
JasonFriday13 is offline   Reply With Quote
Old 15th June 2017, 04:23   #3
Anders
Moderator
 
Anders's Avatar
 
Join Date: Jun 2002
Location: ${NSISDIR}
Posts: 4,588
Upgrading is not going to help with the AV false positives, it is better to just report them to the AV vendor...

IntOp $PostCount $PostCount + 1
Anders is offline   Reply With Quote
Old 10th July 2017, 08:07   #4
umeca74
Junior Member
 
Join Date: Jan 2009
Posts: 21
thing is that MY executables inside the installer come clean, so the problem with the signatures must be coming from the NSIS components I use (system.dll etc), which will change with a new NSIS version. Of course that doesn't mean the new NSIS files will be considered clean either!
umeca74 is offline   Reply With Quote
Old 10th July 2017, 08:12   #5
umeca74
Junior Member
 
Join Date: Jan 2009
Posts: 21
PS of course I don't mean that the NSIS components are viruses, but they could appear in installers that are considered viruses/Trojans, and thus are used as marks of dodgyness
umeca74 is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Developer Center > NSIS Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump