Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Technical Support

Reply
Thread Tools Search this Thread Display Modes
Old 19th March 2012, 00:52   #1
mglushed
Junior Member
 
Join Date: Mar 2012
Posts: 1
[Tutorial] Desktop mode flicker fix (Win7 transparancy & MilkDrop)

Hi, I got this problem and didn't find a working solution after searching, so I'm guessing other people would like to know it too. I figured a way, here is step by step guide:

1. Right click Computer, choose Properties > Advanced system settings
2. Go to Advanced tab, click Settings (in Performance section)
3. Untick "Animate controls and elements inside windows"
4. Click OK twice and your good to go

Explaination:
I don't really know why it works, but I figured because I realize it only flickers when I put windows 7 aero skin on, it works fine if I put windows 7 basic skin on, so I tried a few times turning on/off features in that advanced settings thing, and found the one which causes it to flicker.
mglushed is offline   Reply With Quote
Old 21st March 2012, 05:20   #2
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,555
Hi mglushed,

Don't have that issue. What cpu and gpu are you using? Does the gpu have it's latest driver? How much RAM do you have?

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 3rd April 2012, 21:12   #3
brownie556
Junior Member
 
Join Date: Apr 2012
Posts: 1
Thanks man, i had that exact problem. Disabled that setting and desktop mode is back w/ no flicker.
brownie556 is offline   Reply With Quote
Old 2nd September 2012, 19:01   #4
gasketum
Junior Member
 
Join Date: Nov 2011
Posts: 1
OMG THANK YOU! This was driving me nuts!!!
gasketum is offline   Reply With Quote
Old 16th September 2013, 19:47   #5
blackwidow
Junior Member
 
Join Date: Nov 2000
Location: MPLS
Posts: 10
Thanks for the fix! Glad it still works in 2013.
blackwidow is offline   Reply With Quote
Old 3rd November 2013, 04:20   #6
MJAldridge6
Junior Member
 
Join Date: Apr 2007
Location: OK
Posts: 15
Send a message via AIM to MJAldridge6 Send a message via Yahoo to MJAldridge6
Fix for windows 8?

I have the same issue but on windows 8 (and 8.1) I tried the above fix for the hell of it but to no avail. Anyone know a fix for windows 8?
MJAldridge6 is offline   Reply With Quote
Old 27th November 2013, 00:24   #7
evil_pro
Junior Member
 
Join Date: Nov 2013
Posts: 13
Same here on Windows 8.1. I guess Microsoft reworked some rendering stuff again.
evil_pro is offline   Reply With Quote
Old 27th November 2013, 00:45   #8
DrO
 
Join Date: Sep 2003
Posts: 27,880
i think it's best to say you're out of luck (and technically i believe the mode was a dubious hack at best which is why it's gradually broken as Windows has moved on).

the part of Milkdrop responsible for that feature was never part of the code open sourced i believe so is likely something you'd need to ask the now maintainers of the plug-in if there's any solution (i suspect probably not or not every easily) as with everything else going on with Winamp, there's no 'official' Milkdrop updates coming anymore.
DrO is offline   Reply With Quote
Old 27th November 2013, 02:39   #9
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Chicago, IL
Posts: 4,555
Running Win 7 64-bit and I still don't have that problem in a window or full screen. I have set the visualization plug-in priority to above normal, maybe that is the reason. I'm also using the default settings, letting it run stuff at random.

Winamp Pro 5.666.3516 fully-patched - Komodo X Touchscreen by Victhor skin
Windows 10 Home 64-bit desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 10th August 2017, 14:00   #10
fbs
Junior Member
 
Join Date: Jun 2007
Posts: 7
Was this solved for Windows 10 x64 users?
I would love to use milkdrop as a "wallpaper"....
fbs is offline   Reply With Quote
Old 13th August 2017, 13:24   #11
PeterK.
Senior Member
 
Join Date: Sep 2016
Posts: 180
Quote:
Originally Posted by fbs View Post
... I would love to use milkdrop as a "wallpaper"....
You can.

All you have to do is find a program that captures desktop content while running Milkdrop "animations". Make a .mp4 file out of it. Afterwards get Wallpaper Engine and enjoy!

PeterK. is offline   Reply With Quote
Old 13th August 2017, 21:59   #12
fbs
Junior Member
 
Join Date: Jun 2007
Posts: 7
Quote:
Originally Posted by PeterK. View Post
You can.

All you have to do is find a program that captures desktop content while running Milkdrop "animations". Make a .mp4 file out of it. Afterwards get Wallpaper Engine and enjoy!

bad, bad idea.. :P

No one fixed milkdrop's desktop mode ? I imagine being open-source for so many years someone must have fixed this.. even if using with another player..
fbs is offline   Reply With Quote
Old 16th August 2017, 01:52   #13
fbs
Junior Member
 
Join Date: Jun 2007
Posts: 7
I managed to recompile milkdrop2 from source (with visual studio 2015) and eliminate this freaking flicker by disabling the access to icons or whatever while in desktop mode..
I can attach the .dll file if anyone still wants this.. my email: heiler.bemerguy AT gmail DOT com
fbs is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump