Old 9th November 2014, 10:58   #1
ShanghaiTimes
Junior Member
 
ShanghaiTimes's Avatar
 
Join Date: Nov 2014
Location: Suffolk, UK
Posts: 49
Can't find cacert.pem, yet it is in the directory

Here's the output of running ./setup.sh

code:
2014-11-09 10:52:36 WARN [MAIN] Cannot find `/Users/robert/ShoutcastDNAS/sc_serv/cacert.pem'
2014-11-09 10:52:36 WARN [MAIN] Without `cacert.pem' the DNAS may not be able to contact the Directory

2014-11-09 10:52:36 INFO *********************************************************************
2014-11-09 10:52:36 INFO ** SHOUTcast Distributed Network Audio Server (DNAS) **
2014-11-09 10:52:36 INFO ** Copyright (C) 2014 Radionomy SA, All Rights Reserved. **
2014-11-09 10:52:36 INFO *********************************************************************
2014-11-09 10:52:36 INFO [MAIN] SHOUTcast DNAS/mac v2.4.2.167 (Oct 30 2014)

ShanghaiTimes is offline   Reply With Quote
Old 9th November 2014, 11:14   #2
ShanghaiTimes
Junior Member
 
ShanghaiTimes's Avatar
 
Join Date: Nov 2014
Location: Suffolk, UK
Posts: 49
and what's more, when I do 127.0.0.1:8000/setup I get this...

There was an error finding the files required for running setup.
Check there is a 'setup' folder in the same folder as the server.

Click here to try loading the setup files again. If this message
remains, you will need to seek assistance via the help forum.
ShanghaiTimes is offline   Reply With Quote
Old 9th November 2014, 13:00   #3
DrO
 
Join Date: Sep 2003
Posts: 27,873
what version of OS X are you doing this on ?
DrO is offline   Reply With Quote
Old 9th November 2014, 14:13   #4
ShanghaiTimes
Junior Member
 
ShanghaiTimes's Avatar
 
Join Date: Nov 2014
Location: Suffolk, UK
Posts: 49
OSX Yosemite. 10.10

I'm using OS X Yosemite
ShanghaiTimes is offline   Reply With Quote
Old 10th November 2014, 08:31   #5
ravermeister
Senior Member
 
ravermeister's Avatar
 
Join Date: Feb 2009
Location: Cologne
Posts: 198
Send a message via ICQ to ravermeister
the cacert root certificates are available at their website anyway:
http://www.cacert.org/index.php?id=3

lastfm.rimkus.it - last.fm Youtube Radio (buy me)
www.rimkus.it - Contact Music & More
ravermeister is offline   Reply With Quote
Old 10th November 2014, 10:29   #6
ShanghaiTimes
Junior Member
 
ShanghaiTimes's Avatar
 
Join Date: Nov 2014
Location: Suffolk, UK
Posts: 49
not locating cacert.pem

Cannot find `/Users/robert/ShoutcastDNAS/sc_serv/cacert.pem'

In fact the caret.pem file is in /Users/robert/ShoutcastDNAS/

Or if you like, /Users/robert/ShoutcastDNAS/cacert.pem

It can't be in the first one, because sc_serv is actually the binary name of the program.

and ... running setup.html also fails, because it can't find the files.

SO.
Something is broken in the OS X build. Certainly for OS X Yosemite (10.10) anyway
ShanghaiTimes is offline   Reply With Quote
Old 10th November 2014, 14:11   #7
DrO
 
Join Date: Sep 2003
Posts: 27,873
have now had a chance to look and it's broken on all OS X versions that i can tell. though i see 2 others have been able to get listed using build 167, so either they just changed the location of cacert.pem to work or just couldn't be bothered to report the issue.

will look to get a patched mac build provided as soon as is reasonably possible.
DrO is offline   Reply With Quote
Old 10th November 2014, 14:49   #8
ShanghaiTimes
Junior Member
 
ShanghaiTimes's Avatar
 
Join Date: Nov 2014
Location: Suffolk, UK
Posts: 49
Thanks DrO, way cool. ... it's true, Winamp really whips the Lama's ass ... :-) so does Shoutcast.

It's not only lost caret.pem, but the startup files as well.. but I guess you know that now :-)

Quote:
There was an error finding the files required for running setup.
Check there is a 'setup' folder in the same folder as the server.

Click here to try loading the setup files again. If this message
remains, you will need to seek assistance via the help forum.
Looking forward to the fix. Can you email me soon as ... ?
Thanks
ShanghaiTimes is offline   Reply With Quote
Old 10th November 2014, 15:03   #9
DrO
 
Join Date: Sep 2003
Posts: 27,873
the issue is due to the same thing, hence why setup mode also fails. i'll just be posting here once it's done and setting the DNAS update flag (though that probably won't help in your case).
DrO is offline   Reply With Quote
Old 10th November 2014, 15:24   #10
ShanghaiTimes
Junior Member
 
ShanghaiTimes's Avatar
 
Join Date: Nov 2014
Location: Suffolk, UK
Posts: 49
Thanks DrO. Cool.
ShanghaiTimes is offline   Reply With Quote
Old 10th November 2014, 16:05   #11
DrO
 
Join Date: Sep 2003
Posts: 27,873
new Mac build (marked as build #168) uploaded which should fix the issue. the new download file size of this build should be 3,132,977 bytes (previous one was 3,133,171 bytes).
DrO is offline   Reply With Quote
Old 10th November 2014, 17:03   #12
ShanghaiTimes
Junior Member
 
ShanghaiTimes's Avatar
 
Join Date: Nov 2014
Location: Suffolk, UK
Posts: 49
Ok, thanks. Cool. Just one question - where do I download it from - I think I'm still looking at the old one? Link url?
Thanks
ShanghaiTimes is offline   Reply With Quote
Old 10th November 2014, 17:04   #13
DrO
 
Join Date: Sep 2003
Posts: 27,873
you get it via the download page.
DrO is offline   Reply With Quote
Old 10th November 2014, 17:23   #14
ShanghaiTimes
Junior Member
 
ShanghaiTimes's Avatar
 
Join Date: Nov 2014
Location: Suffolk, UK
Posts: 49
Yes, I figured that :-) ... but at the risk of looking totally stupid, where is the download page? What's it URL? Because the one I am looking at, sends me an email download link, that only downloads the previous 167 version.
ShanghaiTimes is offline   Reply With Quote
Old 10th November 2014, 17:26   #15
DrO
 
Join Date: Sep 2003
Posts: 27,873
then you've got the correct link. maybe the download is being cached for you with the old version, as i'd not downloaded it previously, i got the correct version (as per the file size note above). and none of the documentation refers to build 168 though you can also do ./sc_serv -v to see what the version of the DNAS is.
DrO is offline   Reply With Quote
Old 10th November 2014, 17:29   #16
ShanghaiTimes
Junior Member
 
ShanghaiTimes's Avatar
 
Join Date: Nov 2014
Location: Suffolk, UK
Posts: 49
ahhh. Very Tricky Batman. Ok, that's it.
robert$ ./sc_serv -v
SHOUTcast DNAS/mac v2.4.2.168 (Nov 10 2014) libcurl/7.38.0 OpenSSL/1.0.1j zlib/1.2.8 expat/2.1.0
... now onwards and upwards. Thanks for your help dude. Way cool.
ShanghaiTimes is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump