Old 18th November 2004, 05:46   #41
ctkatz8086
Senior Member
 
Join Date: Sep 2002
Location: louisville, ky home of the CARDINALS
Posts: 401
there's a latest version? as far as i was aware, there has only been one version, 0.41. if there is a newer version, where did you get it?

ctkatz8086 is offline   Reply With Quote
Old 18th November 2004, 09:32   #42
CraigF
Passionately Apathetic
Administrator
 
CraigF's Avatar
 
Join Date: May 2000
Location: Hell
Posts: 5,435
http://sourceforge.net/projects/inmplayer/ fairly sure this url has appeared more than once on these forums.

you can stop asking now.

CraigF is offline   Reply With Quote
Old 18th November 2004, 13:36   #43
elempoimen
Junior Member
 
Join Date: Nov 2004
Posts: 3
Well, if that's the only version that's been released, it would certainly make it the latest version, wouldn't it?
elempoimen is offline   Reply With Quote
Old 18th November 2004, 14:10   #44
ctkatz8086
Senior Member
 
Join Date: Sep 2002
Location: louisville, ky home of the CARDINALS
Posts: 401
@craig
i knew of the website. it looks like nothing has been done to it since the plugin was released. no documentation, no talk in the forums. nada. if there was another site where there was more discussion was going on i would like that, which is what i was asking.

@elempoimen
not the latest version, just the only version. in my opinion "latest" implies more than one version has been released. you can't get people's hopes up like that man!

ctkatz8086 is offline   Reply With Quote
Old 18th November 2004, 14:23   #45
CraigF
Passionately Apathetic
Administrator
 
CraigF's Avatar
 
Join Date: May 2000
Location: Hell
Posts: 5,435
its open source, hosted by sourceforge. Their might be a later version in the cvs you could checkout and compile.

CraigF is offline   Reply With Quote
Old 18th November 2004, 14:56   #46
elempoimen
Junior Member
 
Join Date: Nov 2004
Posts: 3
That's a good point
elempoimen is offline   Reply With Quote
Old 26th November 2004, 05:26   #47
sa1964
Member
 
Join Date: Apr 2001
Location: Kissimmee, Florida
Posts: 60
Send a message via Yahoo to sa1964
Excellent plugin. I'll test it out later tonight.

Power to those who love Internet Radio!
sa1964 is offline   Reply With Quote
Old 1st December 2004, 05:26   #48
deathtoyouall
Junior Member
 
Join Date: Mar 2004
Posts: 30
this is a wonderful plug in, but does any one have a suggestion for how to stop the last two seconds being cut off?
deathtoyouall is offline   Reply With Quote
Old 1st December 2004, 08:57   #49
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,824
That is more than likely DirectSound Output config related, and not an input plugin issue at all.


Prefs > Plugins > Output > out_ds > config:

Other tab:
If "remove silence" is enabled, decrease cut-off value ie. move it further to the right, eg. -40dB +-->

Fading tab
Disable/decrease "on start" and "on end" values (if enabled)

Buffering tab
Decrease "buffer ahead on track change" value.
DJ Egg is offline   Reply With Quote
Old 1st December 2004, 19:10   #50
Gonzotek
Gunslinger
 
Gonzotek's Avatar
 
Join Date: May 2000
Location: Terminus
Posts: 4,693
Quote:
Originally posted by CraigF
its open source, hosted by sourceforge. Their might be a later version in the cvs you could checkout and compile.
Unfortunately there's nothing in inmplayer's SF CVS. Only way to get the source is the original in_mplayer041_src.zip package from http://sourceforge.net/project/showf...roup_id=109300 or the mirror from the project's homepage, http://inmplayer.sourceforge.net/ .

It would be great if someone ambitious picked this up.

I was away for a while.
But I'm feeling much better now.
Gonzotek is offline   Reply With Quote
Old 4th January 2005, 13:00   #51
msp
Junior Member
 
Join Date: Nov 2004
Posts: 30
any idea how to get mplayer plugin to play a subtitle file along with the avi

i can't get .sub files to work with mplayer
msp is offline   Reply With Quote
Old 25th May 2005, 09:00   #52
jdlien
Junior Member
 
Join Date: May 2005
Posts: 4
IMPlayer vs Output Plugin

Quote:
That is more than likely DirectSound Output config related, and not an input plugin issue at all.
That appears to be true. Decreasing the buffer in the output plugin helps, as the time cut off at the end of video playback equals this buffer length. Is there some other workaround, or a bugfix that might apply to this?

I've got some videos that need to fit together seamlessly to work, and this is a real pain so far!
jdlien is offline   Reply With Quote
Old 1st June 2005, 03:02   #53
jetjam
Junior Member
 
Join Date: Jun 2005
Posts: 1
hey, i just downloaded the mplayer and i watched an AVI file, but it keeps on blinking. Can anyone help me???
jetjam is offline   Reply With Quote
Old 1st June 2005, 10:53   #54
gaekwad2
Foorum King
 
gaekwad2's Avatar
 
Join Date: Jul 2003
Location: bar2000
Posts: 11,424
Set postprocessing to 1 or higher.
gaekwad2 is offline   Reply With Quote
Old 29th June 2005, 15:36   #55
Wuestenfuchs
Junior Member
 
Join Date: Jun 2005
Posts: 1
Hi guys ...
I'm wondering, why the plugin is simply not workin with me. I copyed the dlls into the plugin directory, an configured in_mplayer with Winamp .. but when I type dvd://J, [and then the name of the DVD as it appears in My Computer] it simply doesn't work!

Anyone got an idea?
Wuestenfuchs is offline   Reply With Quote
Old 12th April 2006, 16:18   #56
ohtaryon
Junior Member
 
Join Date: Feb 2006
Posts: 3
I've been looking to make Winamp my centralized media player, so then I don't have to run stuff like WinDVD or Windows Media Player...

So, yeah, of course I went for this plug-in, and I got it put in the right folder and configured and all that. But now I can't seem to get the DVD to play correctly. Either: I try opening the actual VOB file using Open File>VTS_Title.vob in which case it does the flicker-thing [post-processing did nothing to stop this] or else I click Play Audio CD D: [d drive], and this opens up the full DVD menu [Program Start, Title Menu, Root Menu, Subpicture Menu, Chapter list, etc.]... And it will go to the Title Menu, and play audio, but I'm getting no video. And if I try to play anything other than the Title Menu, it automatically jumps to the end of the DVD playlist and stops.

... Thoughts?
ohtaryon is offline   Reply With Quote
Old 24th April 2006, 10:38   #57
martin.deimos
Android/UI Development
 
martin.deimos's Avatar
 
Join Date: Sep 2004
Location: Bavaria
Posts: 1,242
Send a message via ICQ to martin.deimos Send a message via AIM to martin.deimos Send a message via Yahoo to martin.deimos
install powerplayerplugin for winamp, that should work!

WebSite: www.skinconsortium.com - Community for Userinterface Design & Coding
Skins: Click Here
martin.deimos is offline   Reply With Quote
Old 19th May 2006, 23:34   #58
Ant718
Junior Member
 
Ant718's Avatar
 
Join Date: Feb 2006
Posts: 6
I followed the install read me & cant seem to get it to work. It just makes some cracking noises HELP
Ant718 is offline   Reply With Quote
Old 28th May 2006, 04:20   #59
Kiwegapa
Junior Member
 
Join Date: May 2006
Posts: 1
I have noticed a problem with in_mplayer v0.41. I had been having problems playing certain AVI files, always ones encoded by the same people. It turns out that if I uncheck 'override in_dshow's settings' they play just fine.

I'm not sure what the particular file issue is, but if anyone is having AVI files that play for only a few seconds and then quit, try unchecking that option.
Kiwegapa is offline   Reply With Quote
Old 28th May 2006, 12:28   #60
gaekwad2
Foorum King
 
gaekwad2's Avatar
 
Join Date: Jul 2003
Location: bar2000
Posts: 11,424
If you uncheck that option all file types listed in in_dshow's extensions list will be played by in_dshow.

So you basically disabled in_mplayer for avi.
gaekwad2 is offline   Reply With Quote
Old 21st September 2006, 21:20   #61
will
Nullsoft Newbie (Moderator)
 
will's Avatar
 
Join Date: Mar 2001
Location: Sheffield, England
Posts: 5,569
Mirror 1
Mirror 2

I've updated it a little bit with (kinda hacky) stream switching, reads length when adding files to the ML, and now uses MPlayer 1.0pre8.

DO NOT PM ME WITH TECH SUPPORT QUESTIONS
will is offline   Reply With Quote
Old 25th December 2006, 08:59   #62
chromium_74
Junior Member
 
Join Date: Nov 2005
Posts: 8
audio in some vob files not rendering correctly

hey guys- my ability to play vob files with winamp has stopped, so i tried the mplayer plugin. i could track down the root of the problem, but the nullsoft directshow module never let me move the progress bar when playing a vob, it'd always lockup winamp- so i'd like to try to stick with the mplayer plugin, which allows for moving the progress bar while watching a vob file. the only trouble is some of my vobs (they're song video vobs) dont play audio correctly, they only make a terrible hissing sound instead. the playback is fine in other players, for the record. can anyone advise me as to whats going on?
thanks in advance.
chromium_74 is offline   Reply With Quote
Old 25th December 2006, 21:13   #63
raducoc
Junior Member
 
Join Date: Feb 2004
Location: Dej
Posts: 8
Yes! Thankyou guys! I managed the Winamp to work with Mplayer!

There is three things that I dont likeyou.

1. The fact this dont work with the Winamp DSPs. Please can integrate this into the next release? Will be great to view and listen my movies using Enhancer 0.17 DSP!

http://garni.ch/Software/mplayer/

2. There is no support for MKV files! Please add support for this. MPlayer can handle werry well MKVs.

3. Subtitles. I cant manage to view the subtitles.
raducoc is offline   Reply With Quote
Old 26th December 2006, 00:25   #64
DrO
 
Join Date: Sep 2003
Posts: 27,873
you'll be waiting a long time since no one has worked on this plugin since it was released and the whole winamp plugin with gpl means it's risky to begin with.

for the mkv thing, see this

-daz
DrO is offline   Reply With Quote
Old 19th February 2007, 09:18   #65
Musky Melon
Junior Member
 
Join Date: Feb 2007
Posts: 4
Updated in_mplayer worked out my video viewing troubles. Interesting thing is that several of you mention the DVD menus but when I attempt to watch a DVD it skips everything and goes directly to the main movie.
Musky Melon is offline   Reply With Quote
Old 19th June 2007, 13:52   #66
skywalka
Member
 
Join Date: Feb 2002
Posts: 73
The links for will's uploaded hack are dead. Can anybody reupload the hack?

Thanx.

--==WishList==--
Disable the locking of files like WMP does.
Cascading, iconed context menu.
skywalka is offline   Reply With Quote
Old 19th June 2007, 13:59   #67
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,824
Quote:
Originally posted by will
Mirror 1
Mirror 2

I've updated it a little bit with (kinda hacky) stream switching, reads length when adding files to the ML, and now uses MPlayer 1.0pre8.
Both links are working fine for me.
DJ Egg is offline   Reply With Quote
Old 11th September 2007, 16:46   #68
mupet0000
Junior Member
 
Join Date: Sep 2006
Posts: 15
I cant get the download, first link just times out and "Page can not be displayed". Second link 404's.

Can someone re-upload please?
mupet0000 is offline   Reply With Quote
Old 27th September 2007, 16:08   #69
micklee
Junior Member
 
Join Date: Sep 2007
Location: london sw20
Posts: 4
i hope someone can be patient with me as most of the above went over my head. ok i'm thick!

i'm trying to play a dvd on my pc, it contains a REC file someone recorded for me on a toppy(?)

i understand it will play in winamp if i download an implayer & put it in the plugins folder. i downloaded in_mplayer041_src.zip & unzipped it to the plugins folder but the dvd/file still won't play. i've checked in the folder & found an RC file called inmplayer, also a inmplayer.dsp & inmplayer.dsw

there's obviously more i have to do or something i've done wrong.

i hope someone can advise without confusing me.

thanks

mick.
micklee is offline   Reply With Quote
Old 27th September 2007, 18:18   #70
J_Darnley
Forum King
 
J_Darnley's Avatar
 
Join Date: Apr 2004
Location: Belgium, Europe
Posts: 3,626
Send a message via ICQ to J_Darnley
The source code wont be much good to you unless you intend on compiling it but seeing as you didn't know that was the source I will assume that you aren't going to.

This time download the plugin not the source. You can find a working link in Will's reply above, the stashbox one.

Winamp ATF ReferenceMy cPro timer widgetMy port of AVS
Do NOT email me with general tech support questions.
J_Darnley is offline   Reply With Quote
Old 27th September 2007, 23:29   #71
micklee
Junior Member
 
Join Date: Sep 2007
Location: london sw20
Posts: 4
thanks. i downloaded it from will's 'mirror1' link (i couldn't see 'stashbox' anywhere) i extracted mplayer.dll & in_mplayer.dll to the plug ins folder plus the mplayer_src_difffiles.

the dvd still won't play, i just get white noise & no picture. do i have to put those files in specific folders within the plugins folder?

i don't get it. i'm nearly in tears!
micklee is offline   Reply With Quote
Old 28th September 2007, 00:14   #72
J_Darnley
Forum King
 
J_Darnley's Avatar
 
Join Date: Apr 2004
Location: Belgium, Europe
Posts: 3,626
Send a message via ICQ to J_Darnley
No, both those files need to go in the Winamp\Plugins folder. If I recall correctly others have has problems with poor video playback and that setting the post-processing to at least 1 corrected the problem.

On the other hand, I don't know if this hacked up version of mplayer has dvd decrypting. Perhaps someone can try and confirm whether you can play encrypted content with this. You are trying to play the vob files in the DVD's VIDEO_TS folder right?

Winamp ATF ReferenceMy cPro timer widgetMy port of AVS
Do NOT email me with general tech support questions.
J_Darnley is offline   Reply With Quote
Old 28th September 2007, 09:34   #73
micklee
Junior Member
 
Join Date: Sep 2007
Location: london sw20
Posts: 4
thanks again j

i've no idea how to adjust the post-processing, i looked right through the preferences but didn't see it. like i said, my dvd contains a REC file.

incidently, when i looked through the preferences, there was no sign of mplayer in the plugins section.

sigh.
micklee is offline   Reply With Quote
Old 28th September 2007, 14:30   #74
Rocker
Hiding in plain sight (mod)
 
Join Date: Jun 2000
Location: Melbourne, Australia
Posts: 9,910
then mplayer isn't in your winamp/plugins folder.

you have to have winamp closed while installing it.
Rocker is offline   Reply With Quote
Old 28th September 2007, 15:55   #75
micklee
Junior Member
 
Join Date: Sep 2007
Location: london sw20
Posts: 4
ok i've done that again with winamp closed, but the dvd still doesn't play. not even white noise this time. i looked in preferences\plug-ins but only found one in_mplayer file, which was
in_mplayer.dll in input.

i checked again in the plugins folder & there are 4 in_mplayer files plus a folder named mplayersrc, which contains conf, dll & Makefile also in there is a folder named libmpdemux which contains stream_file

hope you haven't all dozed off yet!
micklee is offline   Reply With Quote
Old 27th February 2008, 06:41   #76
Zero2FiftyIn4
Senior Member
 
Join Date: Sep 2007
Location: In my head....the voices there are nice
Posts: 170
Just aheads up to any one interested in this. The 2 mirror links don't work anymore.

"It is, in the end, whatever the Hell I want it to be,
And when I'm through with it, it's gonna blow a hole,
This wide, straight through the worlds own idea of itself.
They're throwing bottles at your house.
Come on, lets go break their arms."
Zero2FiftyIn4 is offline   Reply With Quote
Old 28th March 2008, 14:14   #77
mindspaceindia
Junior Member
 
Join Date: Mar 2008
Posts: 40
Correct me if I'm wrong, but mplayer doesn't allow the use of DSP plugins.
I'd love that to happen
mindspaceindia is offline   Reply With Quote
Old 21st September 2009, 16:55   #78
liquid64
Junior Member
 
Join Date: Sep 2009
Posts: 7
I know I am resurrecting an old thread, but does anyone have a mirror to the updated version (or even the source)of this plugin? I have the source, and am trying to compile the latest checkout of mplayer with the makefile from inmplayer, but it isn't working. If anyone has the update that Will made, I'd appreciate it.
liquid64 is offline   Reply With Quote
Old 21st September 2009, 18:17   #79
Zero2FiftyIn4
Senior Member
 
Join Date: Sep 2007
Location: In my head....the voices there are nice
Posts: 170
I think this is the version you are looking for http://sourceforge.net/projects/inmplayer/

"It is, in the end, whatever the Hell I want it to be,
And when I'm through with it, it's gonna blow a hole,
This wide, straight through the worlds own idea of itself.
They're throwing bottles at your house.
Come on, lets go break their arms."
Zero2FiftyIn4 is offline   Reply With Quote
Old 21st September 2009, 18:32   #80
liquid64
Junior Member
 
Join Date: Sep 2009
Posts: 7
Thanks for the response, but the one on the homepage is version .41, which is based on an old mplayer codebase. The user 'will' above was able to compile it against a new(er) mplayer codebase. There has been significant changes to the Makefile, so the one included with the sourcecode (in .41) no longer works.
liquid64 is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump