Old 17th July 2017, 18:52   #1
AusFreak
Junior Member
 
Join Date: Jul 2017
Posts: 8
Streaming for V2 not working

I've spent probably a full day trying to get my stream to work properly.
Im running a linux shoutcast DNAS server connecting to it from windows winamp DSP.
The DSP connects in legacy mode no problems, however when i switch to V2 it just closes the connection. The error in the log file for V2 is as follows:

2017-07-16 19:08:05 Connecting to... Server: xxx.xxx.xxx.xxx; Port: 8000; Mode: v2; Stream ID: 1; DJ / User ID: admin
2017-07-16 19:08:05 Cipher Response Received
2017-07-16 19:08:05 Disconnecting
2017-07-16 19:08:06 Not Connected

I tried with removing the username too and that was the same response.

On the linux side I turned on debugging mode and this is the error reported:

"Remote socket closed while waiting for data."

Any help would greatly be appreciated.
AusFreak is offline   Reply With Quote
Old 17th July 2017, 18:56   #2
djSpinnerCee
Forum King
 
djSpinnerCee's Avatar
 
Join Date: Aug 2004
Location: Hollis, Queens/The Bronx, NYC
Posts: 3,512
are you sure something is playing in winamp when you connect the dsp?
djSpinnerCee is offline   Reply With Quote
Old 17th July 2017, 19:07   #3
AusFreak
Junior Member
 
Join Date: Jul 2017
Posts: 8
hi dj,

yeah its playing, i switch to V1 and it works no worries
AusFreak is offline   Reply With Quote
Old 9th April 2018, 16:02   #4
sqgl
Senior Member
 
sqgl's Avatar
 
Join Date: Sep 2008
Location: Australia
Posts: 188
Quote:
Originally Posted by AusFreak View Post
hi dj,

yeah its playing, i switch to V1 and it works no worries
But it would be nice if v2 mode would work so that we could use station ID artwork.

Remixing listener requests of ambient tracks live http://RePlayScape.com
sqgl is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump