Old 18th July 2010, 11:00   #81
VIPer
Moderator
 
VIPer's Avatar
 
Join Date: Feb 2008
Location: Almaty, Kazakhstan
Posts: 301
Send a message via ICQ to VIPer
Hi Pawel!

You can include these icon libraries in your icon pack?
Btw, I don't see any bug with it also.
VIPer is offline   Reply With Quote
Old 18th July 2010, 11:33   #82
VIPer
Moderator
 
VIPer's Avatar
 
Join Date: Feb 2008
Location: Almaty, Kazakhstan
Posts: 301
Send a message via ICQ to VIPer
@Pawel,
Btw, I want to translate lang script installer of Winamp Icon Pack. You can send it?
VIPer is offline   Reply With Quote
Old 18th July 2010, 11:53   #83
Pawel
Moderator
 
Pawel's Avatar
 
Join Date: Aug 2004
Location: Poland
Posts: 534
Send a message via ICQ to Pawel
Hi, Icon pack created by me is closed project.
So, no translation, no nsis script available.
-Pawel
Pawel is offline   Reply With Quote
Old 18th July 2010, 12:19   #84
VIPer
Moderator
 
VIPer's Avatar
 
Join Date: Feb 2008
Location: Almaty, Kazakhstan
Posts: 301
Send a message via ICQ to VIPer
@Pawel,

I got it.

But you can include those libraries or not?

[edit]
I am not gonna touch any Icon Pack stuff anymore.
As I said, that means, no updates, no support etc...
Just create installer and submitt it to winamp.com Plugins Skins section.
-Pawel

[edit]
Excuse me. I thought that you meant that the project is not public, as the word "closed" has two meaning in Russian: closed and not public.
-VIPer
VIPer is offline   Reply With Quote
Old 19th July 2010, 09:24   #85
enigmas
Junior Member
 
Join Date: Jul 2010
Posts: 1
This version of WinAmp still doesn't support iPOD Shuffle 3rd gen, can we expect an improvement for pmp_ipod plugin on the next release that could support also the mentioned device?

Regards,
enigmas is offline   Reply With Quote
Old 20th July 2010, 16:47   #86
TheUniqueTiger
Senior Member
 
Join Date: Mar 2006
Location: India
Posts: 431
Reporting a replaygain scanner bug:

When I scan a MP3 file for replaygain, which is 116:38 (around 2 hours) in length 128kbps, the replaygain scanner progress shows a 10 digit % number which decreases. I suggest use a 'double' integer data type rather than 'long'.

You have only One Life... So before You are History, make sure you get into History books. - TheUniqueTiger
My personal website, HiFiBB ... Simply Hifi!, HiFiBB
TheUniqueTiger is offline   Reply With Quote
Old 21st July 2010, 11:17   #87
Jacob02
Banned
 
Join Date: Jul 2010
Posts: 95
Well this is a great news. I hope it will work well with Window7. And can anyone of you mention, what are future new features release planning by Winamp.
Jacob02 is offline   Reply With Quote
Old 21st July 2010, 12:29   #88
djpete
Major Dude
 
djpete's Avatar
 
Join Date: Apr 2004
Location: Melbourne, Australia
Posts: 940
highlight say 10 files in an ml playlist,
drag them into another playlist.
CRASH
Happens every time for me.
If I drag n drop one track no crash

Cheers, Pete

Anything & Everything Winamp - All In One Place...
Winamp Enthusiasts Group
djpete is offline   Reply With Quote
Old 21st July 2010, 13:16   #89
Juanus
Major Dude
 
Juanus's Avatar
 
Join Date: Oct 2004
Location: Santa Monica, CA
Posts: 734
Send a message via AIM to Juanus
Quote:
Originally Posted by Juanus View Post
I have an issue that I have never seen before and I don't know how to explain, so please work with me.

I have over 700 playlists. So I choose to right click on the playlist node in the left pane, choose import playlist from folder. And after my playlists are loaded I will choose sort playlists alphabetically.

When you expand the node, all of the playlists drop down as they should. However, here is the problem. When you try to scroll up and down the list on the left hand side. It doesn't scroll smoothly. The only way I can explain it is that normally when you left click the slider, hold the mouse down and scroll up and down the scroll bar will follow the mouse and work very quickly. But it does not seem to do this in the left pane. In the right pane, everything works great.

I have included a zip file with playlists. So hopefully you can recreate this.

Thanks
Quote:
Originally Posted by djpete1959 View Post
highlight say 10 files in a playlist,
drag them into another playlist.
CRASH
Happens every time for me.
If I drag n drop one track no crash

DJ Pete,

I can repro this in windows 7. I am able to drag one file from playlist to a different playlist. However, when I grab multiple items and try to drag them from one playlist to another, I get a crash also. I also have a problem with playlists that I have quoted above but no one has responded to as of yet. I wonder if there is something going on with the ml_playlists.
Juanus is offline   Reply With Quote
Old 21st July 2010, 13:25   #90
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
@djpete1959

Hmm, yes, I can reproduce that.
I either get a complete Winamp lockup, or a crash.

1. Create a new playlist in the ML, if more than one doesn't already exist
2. Go to a large-ish saved playlist in the ML
3. Select 20 or more entries from this playlist and drag them to the new/other playlist title in the ML tree
4. Winamp either freezes, or crashes.

winamp caused an Access Violation (0xc0000005)
in module ntdll.dll at 0023:774b28bf

Though there's no crash when just using: rt-click -> send to -> ml playlist

Thanks
DJ Egg is offline   Reply With Quote
Old 21st July 2010, 13:52   #91
djpete
Major Dude
 
djpete's Avatar
 
Join Date: Apr 2004
Location: Melbourne, Australia
Posts: 940
I don't know how long the bugs been there as I don't normally do what I did but anyway a little one to look out for. Sowwy!

Cheers, Pete

Anything & Everything Winamp - All In One Place...
Winamp Enthusiasts Group
djpete is offline   Reply With Quote
Old 21st July 2010, 14:17   #92
Juanus
Major Dude
 
Juanus's Avatar
 
Join Date: Oct 2004
Location: Santa Monica, CA
Posts: 734
Send a message via AIM to Juanus
Don't be sorry. That's what this forum is here for. I am just glad that someone else was having an issue. I was starting to feel like I was the only one because no one had commented. Maybe since your bug is easier to understand, fixing it will also fix my issue. One may have just been a symptom of the other.
Juanus is offline   Reply With Quote
Old 22nd July 2010, 02:11   #93
djpete
Major Dude
 
djpete's Avatar
 
Join Date: Apr 2004
Location: Melbourne, Australia
Posts: 940
I just feel a little for these poor buggers running around chasing bugs. I build websites and know how much time can be spent on small things. RESPECT to the team. :-)

Cheers, Pete

Anything & Everything Winamp - All In One Place...
Winamp Enthusiasts Group
djpete is offline   Reply With Quote
Old 22nd July 2010, 04:19   #94
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Fixed ml_playlists.dll v1.19 installer attached.

It fixes the reported drag+drop crash anyway, though not sure about Juanus' issue....

~~~~~~~~~~~~~~~~~
Attached Files
File Type: exe ml_playlists_update_v1.19.exe (150.5 KB, 1005 views)
DJ Egg is offline   Reply With Quote
Old 22nd July 2010, 04:34   #95
djpete
Major Dude
 
djpete's Avatar
 
Join Date: Apr 2004
Location: Melbourne, Australia
Posts: 940
"you're good, your'e good...no NO you're good"
From Analyse This
Lol
http://www.youtube.com/watch?v=iZtbASCE7ZY

Cheers, Pete

Anything & Everything Winamp - All In One Place...
Winamp Enthusiasts Group
djpete is offline   Reply With Quote
Old 22nd July 2010, 06:30   #96
Juanus
Major Dude
 
Juanus's Avatar
 
Join Date: Oct 2004
Location: Santa Monica, CA
Posts: 734
Send a message via AIM to Juanus
Quote:
Originally Posted by DJ Egg View Post
Fixed ml_playlists.dll v1.19 installer attached.

It fixes the reported drag+drop crash anyway, though not sure about Juanus' issue....

~~~~~~~~~~~~~~~~~
Unfortunately, I am on holiday so I cant test it immediately, but when I do get back, I will try it. Quick question... was I clear enough on what my original issue was? I know its hard to explain if nothing crashes. But I tried to give you repro steps and playlists to play with.
Juanus is offline   Reply With Quote
Old 25th July 2010, 03:05   #97
Juanus
Major Dude
 
Juanus's Avatar
 
Join Date: Oct 2004
Location: Santa Monica, CA
Posts: 734
Send a message via AIM to Juanus
O.K. I am back and I have to say that the fixed ml_playlist is a LOT better than it was. Something tells me that there is some new compatibility that is making it act weird and hence made the crashing that was fixed in this newest update.

Let me see if I can explain it this way... when you hold down the left mouse button and grab the scroll bar. You can go up and down as fast as you want and the scroll bar will stay on your mouse exactly where you placed it. However, now, on the left hand pane, while you have the playlist node expanded and try to scroll up and down, there is considerable lag and the scroll bar has to catch up to your mouse. On the right hand pane you can do the same thing and it all works as intended.

I know this sounds small, but it might be the symptom of something else wrong in the .dll that I haven't found yet.
Juanus is offline   Reply With Quote
Old 29th July 2010, 19:38   #98
Alpha2k6
Member
 
Join Date: Aug 2006
Location: Sweden
Posts: 67
I think ive found a unicode related bug.

this is my folder structure and files:

E:\-=Flac Pop-Dance=-\-=Pop=-\黑貓大樂團 - 雷射環繞音效7 ()

01. 黑貓大樂團 - 失落情.flac
02. 黑貓大樂團 - 傷心酒店.flac
03. 黑貓大樂團 - 疼惜阮的吻.flac
.....etc..
黑貓大樂團 - 雷射環繞音效7.m3u


I can save the playlist, while the songs are playing,
but next time I try to open it all I see is this below
and it does not play the songs.

01. ????? - ???
02. ????? - ????
03. ????? - ?????


Im using Winamp 5.581
Windows Vista x64 SP2

Edit: Ah never mind I found out the .m3u8 that supports unicode..
why not add unicode to the regular .m3u ? would it break something in older operating systems ?
Alpha2k6 is offline   Reply With Quote
Old 29th July 2010, 21:41   #99
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
Originally Posted by Alpha2k6 View Post
Ah never mind I found out the .m3u8 that supports unicode..
why not add unicode to the regular .m3u ? would it break something in older operating systems ?
you're on the right track in that it's down to compatibility as suddenly making Winamp save unicode compatible m3u playlists would break any other player (and older Winamp players) so it was decided to go the m3u8 route which encodes the paths in utf8 and is saved in a different file.

if only we all used just one language... heh

-daz
DrO is offline   Reply With Quote
Old 14th August 2010, 16:57   #100
Somf
Junior Member
 
Join Date: Aug 2010
Posts: 1
The Media Library behaviour of 5.581 seems to be many steps backwards from that of 5.572. First impressions:

- It refreshes every time an item in the library is rated. Apart from being annoying, this refresh creates a side-effect: if i rate a song in a certain album, the album panel which formerly showed a list of albums now shows only that album.

- Whenever I select an item in the library and choose to order the items in a different way the selection slips from the selected item to the item that is now in its place. To explain in a clearer way, an example:

after i select an album in an album list ordered alphabetically (select album X, 3rd place in the list), and order the same list according to release year; the selection slips from album X to some other album which now resides in the 3rd place of the list.
Somf is offline   Reply With Quote
Old 16th August 2010, 09:26   #101
kzuse
Senior Member
 
kzuse's Avatar
 
Join Date: Oct 2005
Location: (D)
Posts: 480
Send a message via ICQ to kzuse Send a message via Skype™ to kzuse
Since I don't use ratings [and I'm not exactly sure what you mean by refreshing] I cannot reproduce the first issue.

But I am able to reproduce the second one and must confirm that it is kind of an annoyance... I can't remember distinctly how older versions of Winamp handled this, but I think the selected album keeped selected and was only displayed in the new position, which is reasonable. The new behavior is somewhat senseless.
kzuse is offline   Reply With Quote
Old 16th August 2010, 09:36   #102
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
Originally Posted by Somf View Post
It refreshes every time an item in the library is rated. Apart from being annoying, this refresh creates a side-effect: if i rate a song in a certain album, the album panel which formerly showed a list of albums now shows only that album.
there's a few threads in the bug reports forum about this so it's at least known on the forums but nothing has been done so far about resolving it (it appears my attempts to resolve other issues with the ratings has just emphasised the poor cross-pane updating which goes on within the local media views).

Quote:
Originally Posted by Somf View Post
Whenever I select an item in the library and choose to order the items in a different way the selection slips from the selected item to the item that is now in its place.
this was reported directly to the devs about a month ago and nothing has been done as it is unfortunately down to the 'virtual' listview controls being used. and it appears it has always been like this so i wouldn't hold your breathe on getting a quick resolution to it (i'd tried to make a patch for ml_wire where i first really noticed the problem but that has since been lost / wasn't a decent fix so nothing more will be coming from me in getting it resolved).

-daz
DrO is offline   Reply With Quote
Old 19th August 2010, 05:41   #103
hussey
Junior Member
 
Join Date: Aug 2010
Posts: 1
If I click on "Add to Winamp's Bookmark List" in both of the menus and then click close, Winamp will crash.
I have tried it when I do not have the essentials pack installed and everything seems to work fine, but when I install the essentials pack and try it againwhat can i do sir
hussey is offline   Reply With Quote
Old 10th September 2010, 13:10   #104
DrO
 
Join Date: Sep 2003
Posts: 27,873
it's called "notifier" (though other plug-ins which do implement it for classic skins call it a toast).

-daz
DrO is offline   Reply With Quote
Old 10th September 2010, 13:40   #105
DrO
 
Join Date: Sep 2003
Posts: 27,873
not that i'm aware off as it is a sparodic issue that affects some people since v5.57 and was meant to have been fixed for v5.58 but the fix doesn't appear to have been a success for some people.

-daz
DrO is offline   Reply With Quote
Old 10th September 2010, 14:10   #106
Juanus
Major Dude
 
Juanus's Avatar
 
Join Date: Oct 2004
Location: Santa Monica, CA
Posts: 734
Send a message via AIM to Juanus
I have seen an issue where in windows 7, using the native windows 7 taskbar notification that the control buttons will sometimes be blank when it comes up. The outline of the buttons are there but the actual icons in the buttons are not there. But the buttons still work. I dont know how to recreate it, but I will keep trying. I am not sure if this is known or not and I didnt know if it was related to the notifier problem that you are talking about above.
Juanus is offline   Reply With Quote
Old 10th September 2010, 16:11   #107
TheUniqueTiger
Senior Member
 
Join Date: Mar 2006
Location: India
Posts: 431
Quote:
Originally Posted by Juanus View Post
I have seen an issue where in windows 7, using the native windows 7 taskbar notification that the control buttons will sometimes be blank when it comes up. The outline of the buttons are there but the actual icons in the buttons are not there. But the buttons still work. I dont know how to recreate it, but I will keep trying. I am not sure if this is known or not and I didnt know if it was related to the notifier problem that you are talking about above.
Do you mean my post #45 in this thread? (http://forums.winamp.com/showpost.ph...4&postcount=45)
Its been a long time I haven't seen this bug... These days it shows up properly.

You have only One Life... So before You are History, make sure you get into History books. - TheUniqueTiger
My personal website, HiFiBB ... Simply Hifi!, HiFiBB
TheUniqueTiger is offline   Reply With Quote
Old 10th September 2010, 17:19   #108
Juanus
Major Dude
 
Juanus's Avatar
 
Join Date: Oct 2004
Location: Santa Monica, CA
Posts: 734
Send a message via AIM to Juanus
Ummm oh yeah! That one. Thanks Unique Tiger... sorry to repeat post.
Juanus is offline   Reply With Quote
Old 11th September 2010, 10:29   #109
OlexijL
Senior Member
 
Join Date: Jan 2004
Location: Germany
Posts: 101
Send a message via AIM to OlexijL Send a message via Yahoo to OlexijL
installed fixed ml_playlists.dll .

Well. On my PC the Most Played/Recently Played view in Media Library does not work.
Recently Added/Never Played is working very well...

PS: Problem fixed. Damaged profile info. After removing profile and renewal (rescan library) everything works fine.

Last edited by OlexijL; 11th September 2010 at 11:29.
OlexijL is offline   Reply With Quote
Old 17th September 2010, 05:12   #110
jenniferlengvet
Junior Member
 
jenniferlengvet's Avatar
 
Join Date: Sep 2010
Posts: 12
This updated version is really nice. I like the video output quality of this version. thanx to winamp.
jenniferlengvet is offline   Reply With Quote
Old 27th September 2010, 02:49   #111
christopher79
Junior Member
 
christopher79's Avatar
 
Join Date: Sep 2010
Location: Bunbury, Western Australia
Posts: 2
New releases are great!

Thank you!

Chris
christopher79 is offline   Reply With Quote
Old 10th October 2010, 10:41   #112
lindam
Junior Member
 
Join Date: Oct 2010
Posts: 1
Re: Winamp 5.581 Released

Thats so cool dude,
especially the skins are dramatic and sober....
thanks for providing such a nice information...
lindam is offline   Reply With Quote
Old 12th October 2010, 11:45   #113
chris251984
Banned
 
Join Date: Oct 2010
Posts: 1
Very much loved the new version..
chris251984 is offline   Reply With Quote
Old 16th October 2010, 00:42   #114
stopasking
Banned
 
Join Date: Jun 2008
Posts: 446
any plans for releasing new version?
stopasking is offline   Reply With Quote
Old 16th October 2010, 11:52   #115
osmosis
Major Dude
 
osmosis's Avatar
 
Join Date: Jan 2006
Location: Cananada
Posts: 841
Yes.
osmosis is offline   Reply With Quote
Old 16th October 2010, 13:50   #116
stopasking
Banned
 
Join Date: Jun 2008
Posts: 446
soon?
stopasking is offline   Reply With Quote
Old 16th October 2010, 21:50   #117
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,341
When it's done.
Koopa is offline   Reply With Quote
Old 20th October 2010, 16:26   #118
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Unstickying this :-)

It's all about 5.59 beta now :-)
DJ Egg is offline   Reply With Quote
Old 25th February 2011, 12:56   #119
swn
Junior Member
 
Join Date: Dec 2003
Location: Portland, OR
Posts: 8
Do your dsp plug-ins don't work? Read this!!!!

Quote:
Originally Posted by JonnyMac View Post
@ evolution76 AND Robster400

Make sure you have the latest version of the One for Nunz plug-in or you could uninstall it. As mentioned by DrO (from the link) ver. 4.3.1 fixes an issue with the DSP options page.
I HAD my whole DSP plug-in box inoperative-the whole frame would be grayed out. After checking the versions of Active X, latest drivers etc. I was burning. I even downloaded some more DSP drivers to see if I could get them to work-nadda! That is was all solved by this: One for Nunz plug-in! It not only solved the configuration issues will ALL of the DSP plug-ins, but I was able to use it to clean up some other plug-in categories as well! One for Nunz plug-in ROCKS!

swn

WinAmp v5.601 Pro, Dell XPS 410, 2.40 G Intel Core 2 Duo, Win XP Pro Media Ed. SP 3, Creative Sound Blaster X-Fi™ Xtreme Music Dolby 5.1, 256MB ATI Radeon X1300 PRO, 1G NVIDIA GeForce 9400 GT
swn is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Tags
download, new version, winamp 5.581

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump