Old 26th December 2010, 03:49   #1
iamjohnnytrox
Junior Member
 
Join Date: Dec 2010
Posts: 6
Mp4 Video Twice as Fast

Hey guys, I bought a new computer and I can't get winamp to play mp4 videos. I know it doesn't support this native. I have followed the instructions, removing it from the Demuxer to the DirectShow Decoder v1.08. When it plays it back, it plays it twice as fast and it's all crackled and high pitch. I set it up exactly the same way on my old computer and it worked fine. Also, the videos work fine when I play them in Windows Media Player, so I know they're not corrupted. I also tried the Win7 Direct Show filter tweaker to make sure I have the right codecs. Here is some of my computer info...

Fujitsu TH700, i3-350m
Windows 7 64bit
K-lite Mega Codec Pack
Fresh install of Winamp 5.6

Thanks!
~Trox
iamjohnnytrox is offline   Reply With Quote
Old 26th December 2010, 03:56   #2
iamjohnnytrox
Junior Member
 
Join Date: Dec 2010
Posts: 6
Also, i have Winamp Standard, no plugins.
It says it's using...
ffdshow video decoder, and
Microsoft DTV-DVD audio decoder
iamjohnnytrox is offline   Reply With Quote
Old 28th October 2011, 03:12   #3
iamjohnnytrox
Junior Member
 
Join Date: Dec 2010
Posts: 6
Really?

Really? No one has any idea why Winamp is playing the files twice as fast? The audio is chipmunked and it plays back at about 90fps. I can't believe no one else has had this problem either.
iamjohnnytrox is offline   Reply With Quote
Old 28th October 2011, 03:14   #4
iamjohnnytrox
Junior Member
 
Join Date: Dec 2010
Posts: 6
Also, the FFDshow codec says I'm playing it back at 24fps. So there's obviously a winamp problem.
iamjohnnytrox is offline   Reply With Quote
Old 29th October 2011, 03:17   #5
zer0thr33
Junior Member
 
Join Date: Oct 2011
Posts: 2
Similar Problem

I've combed the forums for the past two days dated and after having no luck, decided to post here to see if iamjohnnytrox's and my problem could be solved together. I'm experiencing very similar issues on a different format (.avi) of video file.

Currently, I recently did a fresh install of Windows 7 Ultimate 32-bit with a fresh install of Winamp v5.621 Pro. The current file is an .avi with a WMV3 video, AAC audio encoding. When played in Winamp, the video plays twice as fast (Winamp's status bar in the video window displays FPS at around 75-80) and the audio is 'chipmunked'.

I saw a post back in the forums for an older version, 5.5x I believe, that suggested to remove in_avi.dll, in_flv.dll, in_mkv.dll and have in_dshow.dll to deal with the decoding by adding the file associations. I tried it, with no avail.

Other relevant information:
I have the Combined Community Codec Pack [07.30.2011] installed (which includes the basic codecs needed for playing the files I want). I've tried playing this on other players perfectly fine, Windows Media Player 12 and Media Player Classic Home Cinema, but obviously would rather use Winamp as my main media player.

Attached are the following to diagnose the problem:
System Information (DxDiag.txt)
MediaInfo of the file (MediaInfoAnalysis.txt)
List of Plug-ins -- This is a fresh install of Winamp 5.621 Pro

I've also used GSpot to analysis the video file as well to confirm MediaInfo:
Video:
- Codec: WMV4
- Codec Name: WMP v9 (VC-1 Simple/Main)
- Status: Codec(s) are Installed

Audio:
- Codec: 0x00ff (AAC)
- Info: 48000Hz 137 kb/s tot (2 chnls)
- Status: Codec(s) Installed

Finally, I did see a previous post about Creative's SB Audigy 2 giving problems to Winamp and I'm not sure if this is the route I should be going. Per the DxDiag.txt, you will see that this sound card is not the primary one in use. I also have tried playing these files on a different system, with no change.

I will be monitoring this thread in hopes of an answer soon. Thanks in advance, Winamp Community.
Attached Files
File Type: txt DxDiag.txt (64.3 KB, 249 views)
File Type: txt MediaInfoAnalysis.txt (1.9 KB, 227 views)
zer0thr33 is offline   Reply With Quote
Old 31st October 2011, 20:39   #6
iamjohnnytrox
Junior Member
 
Join Date: Dec 2010
Posts: 6
That's exactly what mine does for mp4's. It doesn't look good as to finding an answer for this. I really would like to use winamp. The interface is so much better, and I love all the features. I guess I'll have to live without.
iamjohnnytrox is offline   Reply With Quote
Old 21st November 2011, 01:00   #7
melloyellow
Junior Member
 
Join Date: Nov 2011
Posts: 2
I am having the same problem as iamjohnnytrox with mp4 playback using the free version of winamp. I have installed the CCCP codec pack that includes ffdshow. After doing this I get video playback on mp4 files, but it is extremely fast. Audio is extremely fast as well, sounds like chipmunks as stated earlier.

Has anyone solved this issue? I would just like to be able to play mp4's in the free winamp version. I can play them fine using VLC, Media Player Class, etc. Would like to use winamp
melloyellow is offline   Reply With Quote
Old 25th November 2011, 13:55   #8
CJ_Man
Senior Member
 
Join Date: Aug 2008
Location: Perth Australia
Posts: 171
Okay, here is my setup which plays MP4,M4V and MKV fine.

CCCP codecs (release 2010-10-10). - Under FFDShow Video Decoders both H264/AVC and DXVA/H264 are checked as are all the Audio codecs. On the second screen MP4 and MKV are both enabled. (Note: As this is not the most recent release of CCCP some of the options may have changed).

Win7DSFilterTweaker4.0 - H264 is checked and set to ffdshow (DXVA). AAC is set to ffdshow.

Winamp 5.622. - MP4 and M4V removed from the MP4 plugin and added to the Directshow list (along with MKV and AVI). in_avi is uninstalled.

File Info on a playing AVI with an AAC soundtrack lists:
AVI Splitter
ffdshow Audio Decoder
Mpeg4s Decoder DMO

and on an MP4 video just:
ffdshow Audio Decoder
ffdshow Video Decoder

I could have used the filter tweaker to promote ffdshow for Divx/Xvid as well but haven't had a problem with the default.
CJ_Man is offline   Reply With Quote
Old 28th November 2011, 20:24   #9
zer0thr33
Junior Member
 
Join Date: Oct 2011
Posts: 2
CJ_Man's solution has resolved my issue. I do believe the key piece to this is from the Win7DSFilterTweaker 4.0 in combination to the DXVA/H264 association with FFDShow. I've been patiently waiting for this answer and much appreciated for the help.

Hope this solution helps johnnytrox and melloyellow as it has helped me greatly! Live on, Winamp! I'll be checking the rest of my video files after having become excited from one file correctly playing. Thanks again CJ_Man and the rest of the Winamp community!
zer0thr33 is offline   Reply With Quote
Old 29th November 2011, 00:53   #10
DulceAndGabana
Junior Member
 
Join Date: Nov 2011
Posts: 1
Cj man we have the same setup. And I assure you guys this really works..
DulceAndGabana is offline   Reply With Quote
Old 2nd December 2011, 02:07   #11
melloyellow
Junior Member
 
Join Date: Nov 2011
Posts: 2
CJ_Man,
I have tried what you suggested and it worked for me as well! Thanks.
Took me a while to get it to finally work but I eventually ended up:
Uninstalling Winamp and CCCP.
Reinstalling CCCP
Used Win7SDFilterTweaker to set defaults
Reinstalled Winamp - configured MP4, M4V to use ffdshow
After doing this it worked. I am using the most recent CCCP 11-11-2011 I believe is the date on it. I did notice that by default, in the "second screen" when first configuring CCCP the splitter option for MP4 is NOT checked by default. I'm wondering if this was my problem all along (not checking this).

But again, thanks for the help
melloyellow is offline   Reply With Quote
Old 21st February 2012, 21:41   #12
MrSpeaker
Junior Member
 
Join Date: Feb 2012
Posts: 1
> Win7DSFilterTweaker

I had the same problem, and this step was the cure.

Thanks guys
MrSpeaker is offline   Reply With Quote
Old 14th January 2013, 18:20   #13
ryckman
Member
 
Join Date: Nov 2005
Posts: 79
I had the exact same problem, and apparently my version of K-lite codec pack was out of date. After installing the latest version (9.7 as of time of writing this reply), this issue was resolved!

When playing MP4 video files in winamp DirectShow file info says:
ffdshow Audio Decoder
LAV Video Decoder

So this is just for people who have this problem and want to continue using K-Lite codec pack instead of switching to CCCP.
You don't have to! Updating to the latest version of K-lite fixes this as well.

Of course you still have to follow the config instructions from this post:
Quote:
When done, open Winamp.

Go to: Winamp -> Prefs (Ctrl+P) -> Plugins -> Input:

Nullsoft MPEG-4 Audio Decoder (in_mp4.dll) -> config:

Remove MP4 from the Extension List, so it just leaves M4A there.

Nullsoft DirectShow Decoder (in_dshow.dll) -> config:

Add MP4 & M4V to the Extension List, so it now looks something like:
MPEG;MPG;M2V;AVI;MP4;M4V
ryckman is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Tags
double speed., mp4 video, too fast, win7 64

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump