Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Reply
Thread Tools Search this Thread Display Modes
Old 23rd May 2011, 15:28   #1
RickWakeman
Junior Member
 
Join Date: Aug 2004
Location: Rio, Brazil
Posts: 13
Share same media library for all computer users: won't work anymore. Need light.

Hello,

I was using Winamp 5.5.7.2810, and both users on the computer would see the same library. I could add filters etc., and when my wife logged on to her profile, she would see the changes, etc. Everything fine.

Then I installed something that caused Winamp to stop working, and I couldn't fix that.

So I then I downloaded Winamp 5.6.1.3133, removed the old Winamp and installed the new one. I had also copied the Media Library settings, which I copied in to the new installation.

But now, when my wife logs on and opens Winamp, no songs appear in the Library. So then I added them in Winamp (she logged in). But as soon as Winamp is closed and started again, there are no songs in the library again!

Strange, that only happens when she's logged in. Add musics. Re-start winamp. Library empty.

From her profile, I ran Winamp as my user name (admin privileges), and the Library loads and works fine.

So I tried removing the paths.ini file, so that Winamp would keep the settings in the program folder, but it made no difference.

Then I edited paths.ini and set it to:
code:

[Winamp]
inidir=%ProgramFiles%\Winamp
cwd=%ProgramFiles%\Winamp



But it still won't work when she runs Winamp.

Then I edited the folder settings of the Winamp folder, and gave her full access rights. But it didn't help either.

Everytime she runs it, the media library is empty. But the media folder is still there in the configurations.

Now something very strange: the gen_ml.ini file shows two sets of configurations (following the [gen_ml_config] tag: the first set has the original configurations, with all the intelligent filters I created. The second section show settings that are being created everytime Winamp is ran.

I edited the file manually, and removed the second set of configurations, to try and make Winamp show the filters etc. But as soon as anyone (admin or not) runs Winamp, a new set of configurations are appended to the gen_ml.ini file.

I've searched all around this forum and can't find a solution.

Can anyone shed some light on this? Using Windows XP Sp3.

Thanks a lot!
RickWakeman is offline   Reply With Quote
Old 23rd May 2011, 21:20   #2
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,862
Hi

On WinXP, you can just delete paths.ini and settings & database will be written to/read from %ProgramFiles%\Winamp for all users by default.

(Note, ref for other users on Vista/Win7, you would either need to edit admin rights for %ProgramFiles%\Winamp so all users have write/modify access, or set paths.ini to a shared folder with write permissions, eg. inidir=C:\Users\Public\Winamp and then copy all the config files over...)

If the problem persists, please attach your gen_ml.ini file.
I'm not sure if I understood what you meant about "two sets of configuration".
DJ Egg is offline   Reply With Quote
Old 24th May 2011, 01:32   #3
RickWakeman
Junior Member
 
Join Date: Aug 2004
Location: Rio, Brazil
Posts: 13
Media Library not adding files for one user. gen_ml.ini file attached.

DJ Egg,

The ini file starts with "[gen_ml_config]" on line 1. Then on line 167, there is "[gen_ml_config]" again, followed by configurations.

If I erase line 167 onwards, and keep only the first group of settings, as soon as I run Winamp it appends "[gen_ml_config]" and all the other settings again from line 167 onwards. If I run Winamp again, it doesn't add it again.

It's like it doesn't like the first part, so it creates a new group of settings.

See below.

Thanks a lot.

code:

[gen_ml_config]
reindex_534f=1
view_autoadd_pos=1
query1_name_utf8=Audio
query1_val_utf8=type = 0
query1_mode=199425
query1_meta=metB817.vmd
query1_image=101
query2_name_utf8=Clima 01
query2_val_utf8=comment HAS "tranquil" AND comment NOTHAS "boring" AND filename NOTHAS ".mid"
query2_mode=1
query2_meta=met7F89.vmd
query2_image=101
query3_name_utf8=Clima 02
query3_val_utf8=comment HAS "tranquil" OR comment HAS "moderate" AND comment NOTHAS "boring" AND filename NOTHAS ".mid"
query3_mode=1
query3_meta=metA0DF.vmd
query3_image=101
query4_name_utf8=Clima 03
query4_val_utf8=comment HAS "moderate" AND comment NOTHAS "boring" AND filename NOTHAS ".mid"
query4_mode=1
query4_meta=met1EE3.vmd
query4_image=101
query5_name_utf8=Clima 04
query5_val_utf8=comment HAS "moderate" OR comment NOTHAS "boring" AND filename NOTHAS ".mid" AND comment HAS "fast"
query5_mode=1
query5_meta=met7963.vmd
query5_image=101
query6_name_utf8=Clima 05
query6_val_utf8=comment HAS "fast" AND comment NOTHAS "boring" AND filename NOTHAS ".mid"
query6_mode=1
query6_meta=metE528.vmd
query6_image=101
query7_name_utf8=Clima 06
query7_val_utf8=comment HAS "fast" or comment HAS "heavy" AND comment NOTHAS "boring" AND filename NOTHAS ".mid"
query7_mode=1
query7_meta=met55AF.vmd
query7_image=101
query_num=22
visible=1
lastprefp=1
bgrescan_do=1
tvrating=7
tvpp=0
recent_limitnd=30
last_view=Local Media/Romanticas
ldivpos=235
mlv10_01=Local Media,0,1
mlv10_02=Playlists,0,2
mlv10_03=Bookmarks,0,3
mlv10_04=History,0,4
mlv10_05=nowplaying_svc_101,0,5
mlv10_06=podcast_svc_720,0,6
mlv10_07=addons_svc_102,0,7
mlv10_08=om_svc_777,0,8
mlv10_09=ml_devices_root,0,9
mlv10_10=_ml_disc_D,0,10
mlv10_11=_ml_disc_D,0,11
mlv10_count=10
mw_xpos=179
mw_ypos=176
mw_width=978
mw_height=760
attachlbolt=1
scandirlist_utf8=C:\MEDIA\Musica
addinbg=0
lastcdprefp=0
extractpath=C:\MEDIA\Musica
extractfmt2="<Artist>\<Album>\<Trackartist> - ## - <Title>"
tagcomment="Ripped by Winamp"
trackoffs=1
extract4cc=541144141
upd_tagz=1
recent_limitlt=1306058701
recent_col_lp=111
recent_col_count=70
recent_col_title=238
recent_col_len=42
recent_col_filename=285
recent_lastquery=
extractplfmt2="<Artist> - <Album>\<Artist> - <Album>"
bm_col_title=400
bm_col_filename=240
query8_name_utf8=Clima 07
query8_val_utf8=comment HAS "heavy" AND comment NOTHAS "boring" AND filename NOTHAS ".mid"
query8_mode=1
query8_meta=met1239.vmd
query8_image=101
query9_name_utf8=Romanticas
query9_val_utf8=type = "0" AND comment HAS "romantic"
mlv10_12=_ml_disc_D,0,12
query9_mode=1
query9_meta=met2597.vmd
query9_image=101
query10_name_utf8=Cristãs
query10_val_utf8=comment has "Christian"
query10_mode=1
query10_meta=metC5C5.vmd
query10_image=101
show_albumgain=0
trackplays_wait_secs_lim=5
trackplays_wait_percent_lim=50
autoaddplays=1
query11_name_utf8=Cristãs Lentas
query11_val_utf8=type = "0" AND comment HAS "christian" AND comment HAS "tranquil"
query11_mode=1
query11_meta=met27B5.vmd
query11_image=101
query12_name_utf8=Legal MP3
query12_val_utf8=type = "0" AND filename ENDS "mp3" AND comment HAS "legal"
query12_mode=1
query12_meta=met7060.vmd
query12_image=101
query13_name_utf8=NOT legal MP3
query13_val_utf8=type = "0" AND comment NOTHAS "legal" AND filename ENDS "mp3"
query13_mode=1
query13_meta=metB7FD.vmd
query13_image=101
query14_name_utf8=Recently Added
query14_val_utf8=lastupd > [4 days ago]
query14_mode=1
query14_meta=metB827.vmd
query14_image=104
query15_name_utf8=All MP3 (- voice)
query15_val_utf8=filename ENDS "mp3" AND comment NOTHAS "voice"
query15_mode=1
query15_meta=metD471.vmd
query15_image=1
query16_name_utf8=MIDI Files
query16_val_utf8=filename ENDS ".mid"
query16_mode=0
query16_meta=met199D.vmd
query16_image=101
query17_name_utf8=Video
query17_val_utf8=type = 1
query17_mode=0
query17_meta=metC7E9.vmd
query17_image=102
query18_name_utf8=Most Played
query18_val_utf8=playcount > 0
query18_mode=0
query18_meta=metD7BB.vmd
query18_image=103
query19_name_utf8=Recently Played
query19_val_utf8=lastplay > [2 weeks ago]
query19_mode=0
query19_meta=metC7F9.vmd
query19_image=105
query20_name_utf8=Never Played
query20_val_utf8=playcount = 0 | playcount isempty
query20_mode=0
query20_meta=metB836.vmd
query20_image=106
query21_name_utf8=Top Rated
query21_val_utf8=rating >= 3
query22_name_utf8=Album
query22_val_utf8=type = 0
reindex_561=1
query21_mode=0
query21_meta=metC808.vmd
query21_image=107
query22_mode=262
query22_meta=met31B3.vmd
query22_image=101
querydelay=250
noshowadddlg=1
[gen_ml_config]
reindex_561=1
view_autoadd_pos=1
query1_name_utf8=Audio
query1_val_utf8=type = 0
query1_mode=1
query1_meta=met1B48.vmd
query1_image=101
query2_name_utf8=Video
query2_val_utf8=type = 1
query2_mode=0
query2_meta=met2B1A.vmd
query2_image=102
query3_name_utf8=Most Played
query3_val_utf8=playcount > 0
query3_mode=0
query3_meta=met1B57.vmd
query3_image=103
query4_name_utf8=Recently Added
query4_val_utf8=lastupd > [3 days ago]
query4_mode=0
query4_meta=met1B67.vmd
query4_image=104
query5_name_utf8=Recently Played
query5_val_utf8=lastplay > [2 weeks ago]
query5_mode=0
query5_meta=met1B77.vmd
query5_image=105
query6_name_utf8=Never Played
query6_val_utf8=playcount = 0 | playcount isempty
query6_mode=0
query6_meta=met1B86.vmd
query6_image=106
query7_name_utf8=Top Rated
query7_val_utf8=rating >= 3
query7_mode=0
query7_meta=met1B96.vmd
query7_image=107
query_num=7
visible=1
last_view=Local Media
ldivpos=135
mlv10_01=nowplaying_svc_101,0,1
mlv10_02=Local Media,0,2
mlv10_03=Playlists,0,3
mlv10_04=addons_svc_102,0,4
mlv10_05=om_svc_777,0,5
mlv10_06=podcast_svc_720,0,6
mlv10_07=ml_devices_root,0,7
mlv10_08=Bookmarks,0,8
mlv10_09=History,0,9
mlv10_10=_ml_disc_D,0,10
mlv10_count=10
mw_xpos=301
mw_ypos=29
mw_width=978
mw_height=760

RickWakeman is offline   Reply With Quote
Old 24th May 2011, 03:45   #4
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,862
Hmm, weird.

Your wife's profile definitely has write/modify access to "C:\Program Files\Winamp"?

Did you delete paths.ini yet? And if yes, does the problem still persist if you start with your original gen_ml.ini again?

Your gen_ml.ini is referencing two different sets of .vmd files.

query1_meta=metB817.vmd
query1_meta=met1B48.vmd

Do both these files exist in the "C:\Program Files\Winamp\Plugins\ml" folder?

I can probably provide a fixed-up gen_ml.ini for you once I know which is the right set of .vmd files to link to...

The problem might be happening because I don't think you can/should use %ProgramFiles% in paths.ini
It would need to be C:\Program Files\Winamp, or wherever winamp.exe resides (which is the default path anyway if paths.ini doesn't exist).
DJ Egg is offline   Reply With Quote
Old 26th May 2011, 01:03   #5
RickWakeman
Junior Member
 
Join Date: Aug 2004
Location: Rio, Brazil
Posts: 13
Yes, the VMD file are there, but...

DJ Egg,

Answering your questions:

Quote:
Your wife's profile definitely has write/modify access to "C:\Program Files\Winamp"?
Well, yes and no: I had given her full control of the Winamp folder and sub-folders. But now, as I tried opening all the folders as her, it stopped at the ML folder and at some of the other plugin folders. Strange, because I has set it recursively. I did it manually on the Plugin folders, and now she has access. And as soon as I opened Winamp, the library was there.

But the Intelligent Filters I had setup (and appear in GEN_ML.INI) aren't listed. And the GEN_ML.INI file was again appended with the second section.

Quote:
Did you delete paths.ini yet? And if yes, does the problem still persist if you start with your original gen_ml.ini again?
Yes, I deleted it again now. Still symptoms as above: Library now there, but filters not, and GEN_ML.INI getting second section appended (I had deleted it once again before erasing PATHS.INI)

Quote:
Your gen_ml.ini is referencing two different sets of .vmd files

query1_meta=metB817.vmd
query1_meta=met1B48.vmd

Do both these files exist in the "C:\Program Files\Winamp\Plugins\ml" folder?
Yes, they're both there. In fact, there are 78 MET*.VMD files in the folder (!), plus another two .VMD files. What are the VMD files? They seem to be a replication of the GEN_ML.INI files

The ones you mention above are listed below. Notice that one is 0Kb length. I imagine that has to do with her not having access to the folder and the file not being written to

code:
C:\Arquivos de programas\Winamp\Plugins\ml\met1B48.vmd
C:\Arquivos de programas\Winamp\Plugins\ml\metB817.vmd



And finally,

Quote:
It would need to be C:\Program Files\Winamp, or wherever winamp.exe resides
I had tried that earlier on. But it didn't work.

Let me get the INI file you sent me and test.

And, before I finish, I would like to publicly thank the authors of HxD Hex editor: I had lost the text I typed in this form, but HxD allowed me to open the browser process in RAM and copy all the text I lost.
RickWakeman is offline   Reply With Quote
Old 24th May 2011, 04:08   #6
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,862
Here's your gen_ml.ini using the original set of .vmd files (assuming they definitely exist).

Extract it from the zip to the "C:\Program Files\Winamp\Plugins" folder.

______________________________
Attached Files
File Type: zip gen_ml.zip (1.5 KB, 249 views)
DJ Egg is offline   Reply With Quote
Old 26th May 2011, 01:06   #7
RickWakeman
Junior Member
 
Join Date: Aug 2004
Location: Rio, Brazil
Posts: 13
Quote:
Originally Posted by DJ Egg View Post
Here's your gen_ml.ini using the original set of .vmd files (assuming they definitely exist).

Extract it from the zip to the "C:\Program Files\Winamp\Plugins" folder.

______________________________
IT WORKED!

THAAAAANNNKKKSS!

Can you explain exactly what was the problem?
RickWakeman is offline   Reply With Quote
Old 26th May 2011, 01:24   #8
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,862
Ahh, ok. Glad to hear it worked.

So... inidir=C:\Arquivos de programas\Winamp (if using paths.ini)

.vmd files are just media library view config files which store data for column sizes/positions etc.

As for the cause of the problem, I'm not 100% sure, but it sounds like one or all of a permissions issue, a bad paths.ini config, or a corrupt gen_ml.ini

Main thing is that it's now fixed. Yay!
DJ Egg is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Tags
config, gen_ml.ini, media library, paths, users

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump