Old 8th December 2005, 06:59   #1
snorri
Junior Member
 
Join Date: May 2004
Posts: 19
How do I turn off the pause between CD tracks?

Hi!

I use Winamp almost each day at work, most of the time playing CDs. There is one thing that annoys me, and I can't find out how to get rid of the problem:

There is a pause of about 1 second after one track ist finished and the next one should start. For most albums, this isn't a problem, but there are some where there should not be a pause. For example, I'm listening to "Tubular Bells" right now, which is essentially one big piece, only technically divided into 17 tracks to facilitate jumping forward and backward.

Sometimes I get the impression that winamp reads the whole track file into its memory before playing it, so the CD drive stops spinning during playing of the track. So, when the next track should begin, the CD drive first has to restart ist motor for winamp to read the track. Maybe that is the root of the problem.

Any ideas on how to fix this?

-- snorri
snorri is offline   Reply With Quote
Old 8th December 2005, 11:36   #2
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,862
From the FAQ

Gapless Playback
http://forums.winamp.com/showthread.php?threadid=158316


Basically, you need to uncheck "use sonic engine" (but keep Use Digital Audio Extraction enabled) under: Prefs > Plugins > Input > CD plugin (in_cdda) > config.

Then, depending on what your Windows OS is (I can't give exact instructions without knowing this), you might need to place wnaspi32.dll (aspi manager) in your Winamp dir (Win2k/XP/2003 only), though it might also work by using the native WinNT SCSI Library (SPTI) in which case you don't need aspi, or if it's Win9x/ME then you might need to upgrade the entire aspi layer... more info.

Then (re)open Winamp and simply apply some value to "buffer ahead on track change" slider in: Prefs > Plugins > Output > DirectSound Output (Win2k/XP/2003) or WaveOut Output (Win9x/ME), eg. 777ms, and you should get almost perfect gapless cd playback.

Note: changes to in_cdda config require a Winamp restart to take effect.

Also note that yes, you're kinda right in your assumption... the sonic engine re-reads the TOC at the start of each track, which is the root of the problem. A fix for this will hopefully come... eventually...
DJ Egg is offline   Reply With Quote
Old 8th December 2005, 13:43   #3
snorri
Junior Member
 
Join Date: May 2004
Posts: 19
Thanks DJ Egg!

Turning off sonic engine and increasing the buffer reduced the gap to a fraction of a second, and replacing the .dll made it even shorter. It's still there, but I can live with it now.

-- snorri
snorri is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump