Old 19th May 2013, 03:18   #1
DarknessSky
Junior Member
 
Join Date: May 2013
Posts: 2
SC Trans no sound?

Hello! So I'm trying to get a ShoutCast server work on my VPS and I want to use the Trans as "auto dj" but the problem is that there are no sound. If I connect and start streaming through Mixxx or any other program it works like a charm but not the Trans.

sc_serv.conf:
code:

;DNAS configuration file
;Made with the SHOUTcast 2 Configuration Builder

password=broadcast
adminpassword=mypasswordwasherebeforeiremovesit
requirestreamconfigs=1
logfile=sc_serv.log
w3clog=sc_w3c.log
banfile=sc_serv.ban
ripfile=sc_serv.rip
maxuser=100

streamid_1=1
streammaxuser_1=50
streampassword_1=broadcast
streamadminpassword_1=mypasswordwasherebeforeiremovesit

streamid_2=2
streammaxuser_2=50
streampassword_2=mypasswordwasherebeforeiremovesit
streamadminpassword_2=mypasswordwasherebeforeiremovesit
streamauthhash_1=ayOGBSHsjOOsokwhoCff



sc_trans_basic.conf
code:
; NOTE: for any relative paths specified are relative to
; sc_trans and not to where the conf file is being stored


; here we will setup where the log and other related files
; will be stored. make sure that these folders exist else
; sc_trans will throw an error and will close itself down.
logfile=logs/sc_trans.log


; for the purpose of this test then we will not take into
; account the use of a calendar.xml file and so disable it
calendarrewrite=0


; for testing we will only setup a single encoder though it
; is easy to add in additional encoder configurations and
; we are using an aac plus encoder as the default due to
; the licensing requirements for mp3 encoding as detailed
; in sc_trans.txt - section 2.5).
;encoder_1=aacp
;bitrate_1=56000


; this is where we define the details required for sc_trans
; to connect to the sc_serv instance being used where the
; details must match those specified in sc_serv_basic.conf
outprotocol_1=3
serverip_1=127.0.0.1
; default is 8000, if not change to sc_serv's 'portbase'
serverport_1=8000
; this is the same as 'password' in sc_serv_basic.conf
password_1=mypasswordwasherebeforeiremovesit
; this is the same as 'streamid' in sc_serv_basic.conf for
; the stream we are acting as the source for
streamid_1=1
; this is a name for the source we're creating and is used
; with the AJAX control api or can be left blank to get a
; generic name created in the form of 'endpointX' where 'X'
; is the index of the created source from sc_trans lists.
endpointname_1=/Bob


; here you would provide any information to fill in details
; provided to clients about the stream. it us upto you what
; is entered though do not do anything which will annoy, etc
streamtitle=Bass Breaker Radio
streamurl=http://www.bassbreakerradio.com
genre=House
xfade=10
channels_1=3
channels_2=3

; here we specify a playlist to use as the master list from
; which to play files from.
playlistfile=main.lst


; these options will allow you access the admin interfaces
; of sc_trans though also allows the 'testui' example to be
; accessed. remember to change the password, etc as needed
adminport=7999
adminuser=admin
adminpassword=mypasswordwasherebeforeiremovesit


; if we want to have an intro file for when the client gets
; the stream or a backup file incase of our connection to
; the server failing then we can set these. this is needed
; as we are using 'outprotocol=3' which supports this (and
; is needed in place of the sc_serv defined values to work)
;serverintrofile=<specify_intro_filepath>
;serverbackupfile=<specify_backup_filepath>




There are no errors because it can connect and play music without problem just that I can't hear it. I have tried VLC to listen and it streams in "audio/aacp"
DarknessSky is offline   Reply With Quote
Old 19th May 2013, 05:28   #2
jaromanda
Forum King
 
Join Date: Jun 2007
Location: Under the bridge
Posts: 2,289
look in sc_trans.log for clues

"If you don't like DNAS, write your own damn system"

So I did
jaromanda is offline   Reply With Quote
Old 19th May 2013, 11:16   #3
DarknessSky
Junior Member
 
Join Date: May 2013
Posts: 2
Quote:
Originally Posted by jaromanda View Post
look in sc_trans.log for clues
This is my sc_trans.log
code:
2013-05-19 06:13:09 I msg:<***> Logger startup
2013-05-19 06:13:09 D msg:<***>
2013-05-19 06:13:09 I msg:***************************************************************
2013-05-19 06:13:09 I msg:** TRANScast Distributed Network Audio Content Provider
2013-05-19 06:13:09 I msg:** Copyright (C) 2000-2011 Nullsoft, Inc. All Rights Reserved.
2013-05-19 06:13:09 I msg:** Use "sc_trans filename.conf" to specify a config file.
2013-05-19 06:13:09 I msg:***************************************************************
2013-05-19 06:13:09 I msg:[MAIN] TRANSCast/posix(linux x64) v2.0.0.54 (Oct 7 2011) starting...
2013-05-19 06:13:09 I msg:[MAIN] PID: 1192
2013-05-19 06:13:09 I msg:[MAIN] Loaded config from sc_trans_basic.conf
2013-05-19 06:13:09 I msg:[MAIN] TimeMultiplier = 1, TimeShift = 0
2013-05-19 06:13:09 I msg:[VUPUSH] 101 VU images loaded for left channel
2013-05-19 06:13:09 I msg:[VUPUSH] 101 VU images loaded for right channel
2013-05-19 06:13:09 I msg:[PLAYLISTMGR] Playlist load from file main.lst
2013-05-19 06:13:09 W msg:[PLAYLISTMGR] The playlist entry /root/music/Swedish House Mafia vs. Nari & Milani - AtOne (Mario Jay Bee Mash-Up Edit) $
2013-05-19 06:13:09 W msg:[PLAYLISTMGR] The playlist entry /root/music/Morgan Page (ft. Lissie) - The Longest Road (Deadmau5 Remix) [Official Musi$
2013-05-19 06:13:09 I msg:[PLAYLISTMGR] Caching playlist main.lst
2013-05-19 06:13:09 I msg:[PLAYLISTMGR] Load complete
2013-05-19 06:13:09 I msg:[MAIN] Streaming thread starting
2013-05-19 06:13:09 I msg:[RESAMPLER] Resampling 44100/2 == 44100/3
2013-05-19 06:13:09 I msg:[SOURCEANDENDPOINTMANAGER] Encoder thread 1 starting
2013-05-19 06:13:09 I msg:[SOURCEANDENDPOINTMANAGER] Broadcast thread 1 starting
2013-05-19 06:13:09 I msg:[MAIN] Playlist decoder thread starting
2013-05-19 06:13:09 I msg:[SOURCERELAY] Thread starting
2013-05-19 06:13:09 I msg:[UVOX2] 2115104468 Giving replay gain calculator a head start
2013-05-19 06:13:09 I msg:[RGCALC] Thread running
2013-05-19 06:13:09 I msg:[UVOX2] 2115104468 Running
2013-05-19 06:13:09 I msg:[UVOX2] 2115104468 Creating stream socket
2013-05-19 06:13:09 I msg:[UVOX2] 2115104468 Connecting to stream host
2013-05-19 06:13:09 I msg:[DECODE] Giving replay gain calculator a head start
2013-05-19 06:13:09 I msg:[DECODE] Begin decoding
2013-05-19 06:13:09 I msg:[DECODE] Next file is /root/music/Stonebridge - Put 'Em High (LYRICS).mp3
2013-05-19 06:13:09 I msg:[UVOX2] 2115104468 Sending Ultravox 2.1 authentication
2013-05-19 06:13:09 I msg:[UVOX2] 2115104468 Mime type
2013-05-19 06:13:09 I msg:[AAC] AAC setup complete
2013-05-19 06:13:09 I msg:[UVOX2] 2115104468 Broadcast setup
2013-05-19 06:13:09 I msg:[UVOX2] 2115104468 Negotiating buffer sizes
2013-05-19 06:13:09 I msg:[UVOX2] 2115104468 Negotiated buffer size is 240KB
2013-05-19 06:13:09 I msg:[UVOX2] 2115104468 Negotiating payload sizes
2013-05-19 06:13:09 I msg:[UVOX2] 2115104468 Negotiated payload size is 16377
2013-05-19 06:13:09 I msg:[UVOX2] 2115104468 Configuring ICY-NAME [Bass Breaker Radio]
2013-05-19 06:13:09 I msg:[UVOX2] 2115104468 Configuring ICY-GENRE [House]
2013-05-19 06:13:09 I msg:[UVOX2] 2115104468 Configuring ICY-URL [http://www.bassbreakerradio.com]
2013-05-19 06:13:09 I msg:[UVOX2] 2115104468 Configuring ICY-PUB [0]
2013-05-19 06:13:09 I msg:[UVOX2] 2115104468 Flush metadata
2013-05-19 06:13:09 I msg:[UVOX2] 2115104468 Standby
2013-05-19 06:13:09 I msg:[UVOX2] 2115104468 Streaming
2013-05-19 06:13:09 I msg:[RESAMPLER] Resampling 48000/2 == 44100/3
2013-05-19 06:13:09 I msg:[UVOX2] 2115104468 Sending metadata 3902 [490 bytes] content=
<?xml version="1.0" encoding="UTF-8" ?>
<metadata>
<TIT2>Stonebridge - Put &apos;Em High (LYRICS)</TIT2>
<extension>
<title seq="1">Stonebridge - Put &apos;Em High (LYRICS)</title>
<title seq="2">Michael Calfan - Resurrection (Axwell&apos;s Recut Club Version)</title>
<title seq="3">Swedish House Mafia - One - Original Mix</title>
<title seq="4">Hard Rock Sofa - Rasputin</title>

DarknessSky is offline   Reply With Quote
Old 20th May 2013, 18:55   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
never post your authhash publically! i've deleted it from the system so you'll have to generate a new one (even though it showed no sign of having been used).

sc_trans is running ok according to above. you'd need to check what the DNAS server is reporting and if it detects the stream in it's admin pages.

also ensure that you're streaming in a format compatible with the unknown player you're testing the stream with (as you're making an AAC+ stream with sc_trans which if trying to play in a flash player will generally not work).
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump