Old 12th December 2011, 15:38   #1
cuddles71
Senior Member
 
Join Date: Oct 2008
Posts: 104
sc_trans Skipping Tracks?

Ok, so today's playlist looks like this:

Quote:
/mnt/music/8/80 Drums Around the World/80 Drums Around the World - Caravan.mp3
/mnt/music/G/Guild, The/Guild, The - Game On (A Bollywood Themed Gamer's Anthem).mp3
/mnt/music/B/Big Sean/Big Sean - My Last.mp3
/mnt/vault/Holiday Music/Christmas/Lord Nelson/Lord Nelson - A Party for Santa Claus.mp3
/mnt/music/A/Adele/Adele - Take It All.mp3
/mnt/music/K/Katy Perry/Katy Perry - The One That Got Away.mp3
/mnt/vault/Holiday Music/Christmas/Bob Rivers/Bob Rivers - Police Stopped My Car.mp3
/mnt/vault/Holiday Music/Christmas/Wild Man Fischer/Wild Man Fischer - I'm a Christmas Tree.mp3
/mnt/music/N/Nicki Minaj/Nicki Minaj - Roman's Revenge.mp3
/mnt/music/W/Wale/Wale - Lotus Flower Bomb.mp3
/mnt/vault/Holiday Music/Christmas/Vanessa Renee Williams/Vanessa Renee Williams - Oh Holy Night.mp3
A mix of the usual day-to-day tracks (located in /mnt/music), and Christmas music (located in /mnt/vault).

The trouble is, sc_trans is ignoring EVERY track that's in /mnt/vault for some reason! Yes, that mountpoint is fully accessible. If I FORCE it to play a track from there (using a priority playlist) it plays fine. But any track in the main playlist that isn't in /mnt/music is just treated as if it's not there. No error messages, just not played.

sc_trans version is drop 6 version 2 revision 39 (latest one that works for our system).

What's causing this?
cuddles71 is offline   Reply With Quote
Old 12th December 2011, 15:59   #2
DrO
 
Join Date: Sep 2003
Posts: 27,873
there's not much i can / do suggest as the build you're using pre-dates everything i've worked on and it could be anything from a bug in the version of sc_trans being used to a permissions issue from the playlist being used or random characters in the playlist.

i guess you could try enabling some of the debug logging options to see if that gives more detail about the issue. otherwise i really cannot remember why you're using such an old version and there's not much on my side which can be done against that build, sorry.

-daz
DrO is offline   Reply With Quote
Old 12th December 2011, 16:21   #3
cuddles71
Senior Member
 
Join Date: Oct 2008
Posts: 104
Ok, trying the new build (54) to see if that will fix anything....

Moments later:

Quote:
2011-12-12 11:16:52 W msg:[PLAYLISTMGR] The playlist entry /mnt/vault/Holiday Music/Christmas/Owl City/Owl City - The Christmas Song.mp3 generated no entries
2011-12-12 11:16:52 W msg:[PLAYLISTMGR] The playlist entry /mnt/vault/Holiday Music/Christmas/Fats Domino/Fats Domino - Jingle Bells.mp3 generated no entries
2011-12-12 11:16:52 W msg:[PLAYLISTMGR] The playlist entry /mnt/vault/Holiday Music/Christmas/Atom/Atom - Christmastime Is Sequenced.mp3 generated no entries
2011-12-12 11:16:52 W msg:[PLAYLISTMGR] The playlist entry /mnt/vault/Holiday Music/Christmas/Low/Low - Just Like Christmas.mp3 generated no entries
Still skipping any music in /mnt/vault. Anything I can do to get a more verbose log?
cuddles71 is offline   Reply With Quote
Old 12th December 2011, 16:42   #4
DrO
 
Join Date: Sep 2003
Posts: 27,873
firstly i'd make sure there's no whitespace on the end of the playlist entries and also the same for the actual files themselves (have seen that happen about a month back). as for more verbose output, there's the debug logging options which can be enabled.

-daz
DrO is offline   Reply With Quote
Old 12th December 2011, 16:52   #5
cuddles71
Senior Member
 
Join Date: Oct 2008
Posts: 104
That got it! Added a sed to remove leading and trailing whitespace, and it works!

Thanks for all the help! Now I just need to figure out where that whitespace is coming from....
cuddles71 is offline   Reply With Quote
Old 12th December 2011, 17:03   #6
DrO
 
Join Date: Sep 2003
Posts: 27,873
guess it is useful the random things i remember at times hopefully you'll quickly work out the cause of the issue.

-daz
DrO is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Discussions

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump