Old 19th July 2016, 04:35   #1
Lupus
Junior Member
 
Join Date: Jul 2016
Posts: 3
Metadata Issues w/ Shoutcast DSP Plugin v2.3.5

Hello! So I am using Winamp v5.666 (patched) along with the Shoutcast DSP Plugin v2.3.5.

I have successfully managed to setup the DNAS server (v2.0 protocol) on a computer and setup Winamp to stream to it. Everything in terms of the stream is working fine.

I seem to be having a problem with metadata though. Every couple of songs I'll get a few songs that don't send their metadata. I have title updates enabled as well as artwork (in-stream and default artwork).

So for example, maybe I'll play the first two tracks and I'll get all their metadata (artist, album, etc). Then I'll get a song that only sends <tit2> and <url>.


I am not really sure why or how to fix this. I'll be more than happy to post whatever information will help. All I know is I need to do one of three things: Get metadata working 100% of the time, make the messed up <tit2> node read "%artist% - %album% - %title%" so I can do my own parsing, or I need to develop a plugin that will get the metadata from Winamp and update the site manually (I actually already started making a plugin, but I am having a hard time understanding the API so I don't know how to get those values).



EDIT: I forgot to mention some additional information. I am streaming MP3 files using MP3 encoding. All of the files have the ID tags stripped except for v2.3 utf-16.

Also regarding the messed up metadata. Let's say I have a song called "X". X might send me funky metadata the first time, but next time it comes around in rotation it will send me good metadata.
Lupus is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Winamp > Winamp Technical Support

Tags
metadata, shoutcast dsp, winamp

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump