Old 31st March 2007, 09:39   #1
TomyLobo
Major Dude
 
TomyLobo's Avatar
 
Join Date: Feb 2004
Location: Germany
Posts: 580
OGG Title display

when i activate advanced title formatting, ogg vorbis files (with proper tagging) have titles according to my format although winamp doesnt seem to be able to read their metadata

they only consist of the filename in my case

how do i
a) make winamp read ogg metadata properly
or
b) make winamp not try to do advanced title formatting for ogg

If you can't say something nice, say something surrealistic.
TomyLobo is offline   Reply With Quote
Old 31st March 2007, 09:44   #2
Sawg
Forum King
 
Join Date: Jun 2000
Location: Phoenix, AZ
Posts: 7,456
Send a message via ICQ to Sawg Send a message via AIM to Sawg Send a message via Yahoo to Sawg
Winamp does read Ogg metadata properly, but advanced Title Formatting cannot be shut off, so just use that instead.

| Brought to you by ^V ^C | The one... the original... no seriously!
Sawg is offline   Reply With Quote
Old 31st March 2007, 09:53   #3
TomyLobo
Major Dude
 
TomyLobo's Avatar
 
Join Date: Feb 2004
Location: Germany
Posts: 580
is there a test to see if winamp reads metadata of something properly?
maybe an example file that is known to work (mine dont, apparently) or something like that?

If you can't say something nice, say something surrealistic.
TomyLobo is offline   Reply With Quote
Old 31st March 2007, 10:32   #4
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Hmm, I'm not sure if I understand what you mean.
Please explain the problem more clearly.

You could upload a sample file to sendspace.com or mediafire.com
and post the link here.

What is your current ATF string? (Winamp > Prefs > Titles)
Copy+paste it here please.

Please also confirm the Winamp version (eg. 5.33 Full, or 5.34 beta 1195, etc)
and the version of Nullsoft in_vorbis.dll (Prefs > Plugins > Input), eg. v1.49

Are the ogg files stored in your Media Library database?
Does the metadata (artist, album, title, year, genre, etc) show correctly in there?
DJ Egg is offline   Reply With Quote
Old 31st March 2007, 14:33   #5
TomyLobo
Major Dude
 
TomyLobo's Avatar
 
Join Date: Feb 2004
Location: Germany
Posts: 580
Quote:
Originally posted by DJ Egg
Hmm, I'm not sure if I understand what you mean.
Please explain the problem more clearly.

You could upload a sample file to sendspace.com or mediafire.com
and post the link here.

What is your current ATF string? (Winamp > Prefs > Titles)
Copy+paste it here please.
my ATF string is pretty complex and contains cases for pretty much everything
also, the default ATF string doesnt show more than the filename either
but here it is:
code:
$if2($if(%album%,$pad([%tracknumber%. ],4)$IfStrEqual2($cut(%album%,5),VA - ,%album% - %artist%,
[%artist% ]'('%album%')'), %artist%) - %title%, $filepart(%filename%))[ %comment%][ %url%]


Quote:
Originally posted by DJ Egg
Please also confirm the Winamp version (eg. 5.33 Full, or 5.34 beta 1195, etc)
and the version of Nullsoft in_vorbis.dll (Prefs > Plugins > Input), eg. v1.49
my winamp version is 5.32 and my in_vorbis.dll is 1.47 and i've been having this problem ever since winamp got ogg vorbis support
Quote:
Originally posted by DJ Egg
Are the ogg files stored in your Media Library database?
Does the metadata (artist, album, title, year, genre, etc) show correctly in there?
nope, the only thing that is shown is the filename in the title field

If you can't say something nice, say something surrealistic.

Last edited by TomyLobo; 31st March 2007 at 15:15.
TomyLobo is offline   Reply With Quote
Old 31st March 2007, 15:13   #6
TomyLobo
Major Dude
 
TomyLobo's Avatar
 
Join Date: Feb 2004
Location: Germany
Posts: 580
strange, if i just change the tags somehow and click update, the name is read properly by winamp
here is a sample .ogg file which winamp doesnt read properly (but the ogg vorbis plugin's tag editor does)
Attached Files
File Type: rar thrditty.rar (77.8 KB, 197 views)

If you can't say something nice, say something surrealistic.
TomyLobo is offline   Reply With Quote
Old 31st March 2007, 21:14   #7
DJ Egg
Techorator
Winamp & SHOUTcast Team
 
Join Date: Jun 2000
Posts: 35,821
Hmm, it works fine here.

So... the ogg files aren't in the library then?
But if you DO add them to the library, then it only shows the filename as title, and all other fields are blank?

ie. in the same way as when you add an .ogg file (which isn't in the library) to the playlist, then the playlist just shows the filename only?

Or.... were the .ogg files already in the library (eg. added to the local media library ages ago)?


If the latter, then type:
?filename ends .ogg
into the Local Media > Audio search field
Select all results in the Tracks pane (Ctrl+A)
Right-click one entry, and select "read metadata on selected items"

That should refresh all the new metadata

(maybe you'd used some external tag editor to edit the info)?


If the former, then I can't remember what version of Winamp/in_vorbis it was where in_vorbis still had its own internal title formatting option (it's been removed in the latest version).

So maybe go to: Prefs > Plugins > Input > in_vorbis > config
and disable the title formatting option in there,
or just upgrade to the latest version of Winamp (where said option is removed).
DJ Egg is offline   Reply With Quote
Old 31st March 2007, 21:26   #8
TomyLobo
Major Dude
 
TomyLobo's Avatar
 
Join Date: Feb 2004
Location: Germany
Posts: 580
thanks, that worked. i wonder why it didnt read the meta data back when i added those .oggs

If you can't say something nice, say something surrealistic.
TomyLobo is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump