Old 4th October 2008, 02:04   #1
jossie
Junior Member
 
Join Date: Oct 2008
Posts: 4
Welcome/Finish pages not displaying in Windows Vista

I was running my installer under Windows XP and it was running fine. Under Vista however, the Welcome and Finish pages don't display. I thought it could be due to the custom modern.exe I was running so then I compiled the following sample script, and it still didn't display the welcome/finish pages in Vista. Does anyone have any ideas?

Quote:
;NSIS Modern User Interface
;Welcome/Finish Page Example Script
;Written by Joost Verburg

;--------------------------------
;Include Modern UI

!include "MUI2.nsh"

;--------------------------------
;General

;Name and file
Name "Modern UI Test"
OutFile "WelcomeFinish.exe"

;Default installation folder
InstallDir "$LOCALAPPDATA\Modern UI Test"

;Get installation folder from registry if available
InstallDirRegKey HKCU "Software\Modern UI Test" ""

;Request application privileges for Windows Vista
RequestExecutionLevel user

;--------------------------------
;Interface Settings

!define MUI_ABORTWARNING

;--------------------------------
;Pages

!insertmacro MUI_PAGE_WELCOME
!insertmacro MUI_PAGE_LICENSE "${NSISDIR}\Docs\Modern UI\License.txt"
!insertmacro MUI_PAGE_COMPONENTS
!insertmacro MUI_PAGE_DIRECTORY
!insertmacro MUI_PAGE_INSTFILES
!insertmacro MUI_PAGE_FINISH

!insertmacro MUI_UNPAGE_WELCOME
!insertmacro MUI_UNPAGE_CONFIRM
!insertmacro MUI_UNPAGE_INSTFILES
!insertmacro MUI_UNPAGE_FINISH

;--------------------------------
;Languages

!insertmacro MUI_LANGUAGE "English"

;--------------------------------
;Installer Sections

Section "Dummy Section" SecDummy

SetOutPath "$INSTDIR"

;ADD YOUR OWN FILES HERE...

;Store installation folder
WriteRegStr HKCU "Software\Modern UI Test" "" $INSTDIR

;Create uninstaller
WriteUninstaller "$INSTDIR\Uninstall.exe"

SectionEnd

;--------------------------------
;Descriptions

;Language strings
LangString DESC_SecDummy ${LANG_ENGLISH} "A test section."

;Assign language strings to sections
!insertmacro MUI_FUNCTION_DESCRIPTION_BEGIN
!insertmacro MUI_DESCRIPTION_TEXT ${SecDummy} $(DESC_SecDummy)
!insertmacro MUI_FUNCTION_DESCRIPTION_END

;--------------------------------
;Uninstaller Section

Section "Uninstall"

;ADD YOUR OWN FILES HERE...

Delete "$INSTDIR\Uninstall.exe"

RMDir "$INSTDIR"

DeleteRegKey /ifempty HKCU "Software\Modern UI Test"

SectionEnd
jossie is offline   Reply With Quote
Old 4th October 2008, 09:50   #2
kichik
M.I.A.
[NSIS Dev, Mod]
 
kichik's Avatar
 
Join Date: Oct 2001
Location: Israel
Posts: 11,343
That works fine for me on both XP and Vista. Any different programs installed on the Vista machine that might make the difference?

NSIS FAQ | NSIS Home Page | Donate $
"I hear and I forget. I see and I remember. I do and I understand." -- Confucius
kichik is offline   Reply With Quote
Old 6th October 2008, 23:02   #3
jossie
Junior Member
 
Join Date: Oct 2008
Posts: 4
Its a pretty clean install of Vista Enterprise Edition SP1. The only other software installed on the machine is McAfee VirusScan Enterprise and McAfee AntiSpyware Enterprise.
jossie is offline   Reply With Quote
Old 7th October 2008, 06:09   #4
kichik
M.I.A.
[NSIS Dev, Mod]
 
kichik's Avatar
 
Join Date: Oct 2001
Location: Israel
Posts: 11,343
Try disabling both.

NSIS FAQ | NSIS Home Page | Donate $
"I hear and I forget. I see and I remember. I do and I understand." -- Confucius
kichik is offline   Reply With Quote
Old 8th October 2008, 23:32   #5
jossie
Junior Member
 
Join Date: Oct 2008
Posts: 4
Ok so the problem was definitely McAfee VirusScan Enterprise.

With it running no NSIS based installers (including the installer for NSIS) would should the welcome/finish pages.

I uninstalled the VirusScan application, and the Welcome/Finish pages started showing up again. (the antispyware application is still running).
jossie is offline   Reply With Quote
Old 9th October 2008, 00:56   #6
Animaether
Major Dude
 
Join Date: Jun 2001
Posts: 1,173
I'm clueless on this, but... are you saying that the -other- pages do display? I.e. it essentially skips the welcome page and goes straight to whatever the next page in line is?

Or are you saying that the installer refuses to run -if- you have a welcome and/or finish page?
Animaether is offline   Reply With Quote
Old 9th October 2008, 06:04   #7
kichik
M.I.A.
[NSIS Dev, Mod]
 
kichik's Avatar
 
Join Date: Oct 2001
Location: Israel
Posts: 11,343
I guess it's a false positive on nsDialogs.dll. Try scanning nsDialogs.dll manually and see what it says.

NSIS FAQ | NSIS Home Page | Donate $
"I hear and I forget. I see and I remember. I do and I understand." -- Confucius
kichik is offline   Reply With Quote
Old 9th October 2008, 10:46   #8
Joost Verburg
NSIS MUI Dev
 
Join Date: Nov 2001
Posts: 3,717
I don't have any problems with this virus scanner. Did you update your DAT files?
Joost Verburg is offline   Reply With Quote
Old 10th October 2008, 22:46   #9
jossie
Junior Member
 
Join Date: Oct 2008
Posts: 4
Specifically the welcome/finish pages didn't display, but the rest of the installer did.

I had to convince the IT department to let me uninstall the virus scanner since they wouldn't let me disable it (since that would mean they would have to provide me the password for it). After uninstalling mcafee the issue went away (as I said earlier). Now the interesting bit is I reinstalled the installer and updated the DAT files, and the installer was still working fine.

The only theory I can come up with is that this machine was an upgrade from XP to Vista. Somehow during the upgrade process Mcafee got messed up?

Thanks for everyone's help.
jossie is offline   Reply With Quote
Old 11th October 2008, 11:59   #10
Joost Verburg
NSIS MUI Dev
 
Join Date: Nov 2001
Posts: 3,717
The previous DAT files probably contained an error causing a false virus detection in an NSIS plug-in. The update of the DAT files has resolved this issue.
Joost Verburg is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Developer Center > NSIS Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump