Old 20th February 2019, 14:44   #1
helios399
Junior Member
 
Join Date: Jan 2011
Posts: 34
<audio> tag Safari v10 HTTP/0.9 failed

HI all,

A freelance developper have developped for us a tiny player with the <audio> tag

It's works with the most browser except on Safari v10 for Mac OS >= 10.12
The Apple report security update => https://support.apple.com/en-us/HT207157

We use 8000 to 8098 ports for our radios

I found this post about this issue in this forum
http://forums.shoutcast.com/showthre...39#post3074439

I use sc_serv v2.2 for 5 years and I'm wondering if a newer version can solve this problem. I'm not sure...
Does a newer version of sc_serv use an other version of HTTP, not HTTP/0.9 ?

If you have an experience, or ideas to solve this problem, you're welcome

Thanks

P
helios399 is offline   Reply With Quote
Old 21st February 2019, 19:28   #2
neralex
Major Dude
 
Join Date: Mar 2011
Posts: 576
I'm working with DNAS 2.5.5.733 (sc_serv2_linux_10_10_17) on a linux box and it works fine with the audio-tag in Safari on the latest High Sierra build. You can find it here.

BUT using the audio-tag as stand-alone solution is not really the best choice with SHOUTcast servers because you get other issues along this way. I'm using since some years an very well supported/coded jQuery player called 'NATIVE HTML5 RADIO PLAYER', which you can find here. Keep an eye on it.
neralex is offline   Reply With Quote
Old 22nd February 2019, 16:44   #3
helios399
Junior Member
 
Join Date: Jan 2011
Posts: 34
Thanks
Good news !

I work with sc_trans for many years and it seems that is not supported with newer version of Shoutcast server. All my radios system works with it.
How do you encode your radio on a linux system ?
I can imagine that I should find many posts in this forum talking about this subject.

I bought this player some weeks ago, but the developper told me that he can't customize the player with only one button Play/Stop...I don't known why !

P
helios399 is offline   Reply With Quote
Old 25th February 2019, 15:39   #4
neralex
Major Dude
 
Join Date: Mar 2011
Posts: 576
Quote:
Originally Posted by helios399 View Post
How do you encode your radio on a linux system ?
With liquidsoap.
neralex is offline   Reply With Quote
Old 1st March 2019, 08:09   #5
helios399
Junior Member
 
Join Date: Jan 2011
Posts: 34
Sorry for my late reply
THANKS
P
helios399 is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump