Old 10th March 2020, 19:34   #1
HGA
Junior Member
 
Join Date: Feb 2020
Posts: 9
Multi Connections

I hav used the following configuration based on
Shoutcast Server Configuration (Advanced)

adminpassword=***
maxuser=100
password=***
streamid_1=1
streamadminpassword_1=***
streammaxuser_1=50
streampassword_1=***
streamadminpassword_2=***
streampath_1=stream
serverport_1=8000
portbase_1=8000
serverip_1=www.xyz.eu
streamid_2=2
streampassword_2=***
streammaxuser_2=10
streampath_2=private
serverip_2=www.xyz.eu
publicserver=never
serverport_2=8444
portbase_2=8444

I got the following warning:

2020-03-10 17:38:58 WARN [CONFIG] Invalid item on line 11 of C:\Program Files\Shoutcast\sc_serv.conf -> `serverport'
2020-03-10 17:38:58 WARN [CONFIG] Invalid item on line 13 of C:\Program Files\Shoutcast\sc_serv.conf -> `serverip'
2020-03-10 17:38:58 WARN [CONFIG] Invalid item on line 18 of C:\Program Files\Shoutcast\sc_serv.conf -> `serverip'
2020-03-10 17:38:58 WARN [CONFIG] Invalid item on line 20 of C:\Program Files\Shoutcast\sc_serv.conf -> `serverport'

I have no idea why serverport and serverip does not work. I got it from the recommended configuration.
Hope somebody can help me
HGA is offline   Reply With Quote
Old 10th March 2020, 19:38   #2
LStratmann
Senior Member
 
LStratmann's Avatar
 
Join Date: Dec 2019
Location: Germany
Posts: 351
Which version do you use?

Greetings.
LStratmann is offline   Reply With Quote
Old 10th March 2020, 19:41   #3
HGA
Junior Member
 
Join Date: Feb 2020
Posts: 9
v2.6.0.753/win64
HGA is offline   Reply With Quote
Old 10th March 2020, 19:43   #4
LStratmann
Senior Member
 
LStratmann's Avatar
 
Join Date: Dec 2019
Location: Germany
Posts: 351
Try this, please:
destip=IPADRESS

You link a domain like this:
destip=stream.myserver.com (example; i.e. specify officially linked DNS)
publicip=stream.myserver.com
LStratmann is offline   Reply With Quote
Old 10th March 2020, 20:01   #5
HGA
Junior Member
 
Join Date: Feb 2020
Posts: 9
I replaced serverip_1 and serverip_2 with the corresponding destip_x
The problem with the serip is gone but I cannot connect to shoutcast server and the serverport problem is still there.
Befor I was able to connect the stream with
code:
www.xyz.eu:8000/stream
but now there is no stream up
HGA is offline   Reply With Quote
Old 10th March 2020, 20:06   #6
HGA
Junior Member
 
Join Date: Feb 2020
Posts: 9
Correction:
There is stream and I can also connedct to the server.
But only the stream to the first port can connect (8000) the second one (8444) can not connect.
HGA is offline   Reply With Quote
Old 10th March 2020, 20:11   #7
HGA
Junior Member
 
Join Date: Feb 2020
Posts: 9
The information about the second stream on port 8444 seams to be ignored. If I send the second stream also to 8000 it will accepted but also sende on 8000 with the streampath_2.
HGA is offline   Reply With Quote
Old 10th March 2020, 20:12   #8
LStratmann
Senior Member
 
LStratmann's Avatar
 
Join Date: Dec 2019
Location: Germany
Posts: 351
You cannot use two ports for two different Moundpoints. You must set up SHOUTcast again for this.
LStratmann is offline   Reply With Quote
Old 10th March 2020, 20:34   #9
HGA
Junior Member
 
Join Date: Feb 2020
Posts: 9
Thanks, but the documentations suggest something different.
HGA is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Tags
configuration, dnas 2, multi connections

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump