Old 6th February 2007, 18:15   #1
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,823
Winamp 5.33 Beta Preview

Winamp 5.33 Beta, Build 1079

Winamp 5.33 Beta Full
Winamp 5.33 Beta Pro (asks for key during install)
Winamp 5.33 Beta Standard (same as Full but no ML or viz)
Winamp 5.33 Beta Lite


IMPORTANT

If you upgrade on top of an already existing version then, unless you backup the media library database first, you cannot go back to 5.32 or earlier. This is because the media library database in 5.33 is now saved in a unicode compatible format.



What's New

* Improved: [gen_ml] unicode tree item title support
* Improved: [NDE] speed optimizations
* Improved: [ml_history] localized dates
* Improved: [ml_local] Unicode media library support
* Improved: [ml_playlists] now uses m3u8 to retain unicode file info
* Improved: [ml_playlists] playlists in send-to submenu
* Improved: [ml_pmp] playback-from-device of unicode filenames
* Improved: [ml_wire] moved discover page to main page
* Improved: [pmp_p4s] auto-detection of supported file formats
* Fixed: playlist directory loading fix (again)
* Fixed: recursive playlist loading
* Fixed: video lockup when switching video display settings
* Fixed: HTML playlist generation
* Fixed: temp file cleanup after burning
* Fixed: Alt+L from video window
* Fixed: fullscreen video display drawing glitch
* Fixed: recursive shortcut loading
* Fixed ASX Loader not reading local relative paths correctly
* Fixed: [gen_ml] & needs expanding to && for any menu entries showing filenames
* Fixed: [in_flac] not saving genres.txt in multiuser directory
* Fixed: [in_mp3] create id3v2 tag when writing album artist
* Fixed: [in_mp3] workaround for id3v2.4 tags with badly formatted frame sizes
* Fixed: [in_vorbis] writing blank metadata instead of erasing
* Fixed: [in_wave] sometimes not remembering custom extensions
* Fixed: [in_wm] stack overflow on hi-def multichannel audio with replaygain enabled
* Fixed: [in_wm] File Info editor album artist not saving
* Fixed: [ml_local] Modern skin pledit winshade 'Manage Playlist' button bug
* Fixed: [ml_local] ignoring files with ellipsis (...)
* Fixed: [ml_local] editing disc via 'edit selected items'
* Fixed: [ml_local] sorting fix
* Fixed: [ml_local] ratings menu
* Fixed: [ml_local] crash when sorting by replaygain
* Fixed: [ml_local] deadlock when retrieving title to guess metadata
* Fixed: [ml_local] no longer causes unicode files in playlist to display ?????
* Fixed: [ml_playlists] time column and 'status' in statusbar
* Fixed: [ml_pmp] <trackartist>
* Fixed: [ml_rg] multi-channel files being calculated incorrectly
* Fixed: [ml_transcode] bad/missing metadata on transcoded files
* Fixed: [ml_transcode] error on overly long filenames ("can't open destination file")
* Fixed: [ml_wire] podcasts that change titles not updating properly
* Updated: Coding Technologies aacPlus encoder 8.0.3
* Updated: [enc_flac] Flake SVN r114
* Updated: [gen_ff] Freetype 2.3.1
* Updated: [gen_jumpex] Jump To File Extra v0.97.11 (build 109)


Notes:

Please report any issues with the beta in this thread only.
Make sure your report is complete, according to the stickys in Bug Reports
(clean install, no 3rd-party plugins, full method of reproduction, etc).

Particular areas which need testing are the local media library, Watch Folders scan, unicode characters in the media library, etc.

Note that only new ml playlists are now saved to .m3u8, i.e. it doesn't convert already-existing ml playlists from .m3u (ansi) to .m3u8 (unicode).


Known Bugs/Issues

-id3v2 genre tag truncated (25 chars) in mp3 editor *

-crash on exit after cd playback/rip *

-crash when clearing media library while background scan running *

-unicode search in local media 'simple' view broken *

-empty files when transcoding from mp4/m4a with 24bit playback enabled *

-sending a playlist to another playlist not working *

-iPod showing 0 & -1 for track# and disc# *

-copy to local media from portables broken *

-dashboard crash when showing tracks from media library *

-some ext's associated with in_dshow show up under Audio in ML instead of Video *

-some m4a files no longer play (updated in_mp4 available separately) *

-milkdrop multi-user issues are known *

-winamp agent multi-user issues are known *

-mass storage devices showing up twice under Vista (most notably the ipod) *


* = fixed internally
DJ Egg is offline  
Old 6th February 2007, 19:44   #2
Hanschke
Senior Member
 
Join Date: Mar 2003
Location: germany
Posts: 128
very nice

can u please tell me which plugin on custom install is for the volume settings?

[edit]

a bug? try to custom winamp installation and cannot disable the media libary. if i uncheck this i got a check in portal media support. old build works fine
Hanschke is offline  
Old 6th February 2007, 20:11   #3
Trent187
Junior Member
 
Join Date: Jan 2004
Posts: 44
In the install setup, choosing "Full" as the install type does NOT select "USB Devices Support" and "ActiveSync Support" under the "Portable Media Player Support" section.
Trent187 is offline  
Old 6th February 2007, 20:16   #4
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,823
@ Hanschke

Volume settings? You mean the ReplayGain Analyzer (under Media Library components)?

I couldn't reproduce the installer bug, but yeah, it is a bit funky. You've gotta expand "Winamp Library" then uncheck it, then uncheck "Winamp Media Library" underneath. Note that if you checkmark any of the media library plugins underneath then the media library itself (gen_ml.dll) must be installed otherwise no ml_*.dll plugins can work.


@ Trent187

Reproduced. Thanks.
Edit: Apparently, it is by design... heh.
DJ Egg is offline  
Old 6th February 2007, 20:41   #5
Omega X
Forum King
 
Omega X's Avatar
 
Join Date: Feb 2003
Location: A Parallel Dimension
Posts: 2,252
Send a message via AIM to Omega X Send a message via Yahoo to Omega X
Damn, Benski and family has been busy. Though I'm still patiently waiting for the Nullsoft in_mpc plugin.
Omega X is offline  
Old 6th February 2007, 20:42   #6
niktheguru
Senior Member
 
Join Date: May 2003
Location: London, UK
Posts: 120
a new build!! Good stuff guys, loving it.

Nikhil
niktheguru is offline  
Old 6th February 2007, 21:36   #7
Serpher
Senior Member
 
Serpher's Avatar
 
Join Date: Jun 2006
Location: Poland
Posts: 146
Adlast!
I though that will be no newer vesions and there a suprise

Keep it up
-------------
EDIT

OK. The first issue.
Why in polish installer I don't have for ex. Dashboard or Replay Gain to choose?

Sorry for my bad English
=====================
MB: Gigabyte P35C-DS3R || CPU: Intel Core 2 Duo E8400 (3.00 GHz) || RAM: 8 GB Kingston DDR3 1333MHz || Audio card: ASUS Xonar D2X || Video card: GeForce 460 GTX || OS: Windows 7 SP1 || DirectX: 9.0c (latest) || Winamp version: latest || Winamp skin: Modern

Last edited by Serpher; 6th February 2007 at 21:54.
Serpher is offline  
Old 6th February 2007, 21:53   #8
ByTor201
Junior Member
 
Join Date: Oct 2005
Posts: 31
Great to see development continuing!

(I wonder if there's a new Essentials pack on the way too. )
ByTor201 is offline  
Old 6th February 2007, 21:58   #9
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,823
Essentials Pack will probably be updated for 5.33 Final
DJ Egg is offline  
Old 7th February 2007, 00:47   #10
billyvnilly
Forum King, M.D.
 
billyvnilly's Avatar
 
Join Date: Mar 2004
Location: Detroit burbs
Posts: 3,379
Send a message via ICQ to billyvnilly Send a message via AIM to billyvnilly
woot! its been so long!

So this version isn't expected to break any ML plugins? ( I saw Benski's sticky in Dev regarding 5.34)
billyvnilly is offline  
Old 7th February 2007, 00:52   #11
DrO
 
Join Date: Sep 2003
Posts: 27,873
anything not using COM based stuff should be fine ie my plugins for a change (mumble mumble grumble about past changes) and generally most plugins will be unaffected. it's only really stuff that relates to use of the webbrowser control (eg predixis) that would need to be updated with the change that's mentioned in the dev forum thread.

-daz
DrO is offline  
Old 7th February 2007, 01:01   #12
Benski
Ben Allison
Former Winamp Developer
 
Benski's Avatar
 
Join Date: Jan 2005
Location: Brooklyn, NY
Posts: 1,057
Quote:
Originally posted by billyvnilly
woot! its been so long!

So this version isn't expected to break any ML plugins? ( I saw Benski's sticky in Dev regarding 5.34)
Nope. Nothing was broken on purpose in this release
Benski is offline  
Old 7th February 2007, 01:02   #13
billyvnilly
Forum King, M.D.
 
billyvnilly's Avatar
 
Join Date: Mar 2004
Location: Detroit burbs
Posts: 3,379
Send a message via ICQ to billyvnilly Send a message via AIM to billyvnilly
OH NOES!11!! predixis wouldn't work in 5.34

can anyone reproduce this:
in ML Rclick 'portables' and select hide if no portables attached. It doesnt hide & just is nonresponsive (when selected you get blank main window)


//Rebuild titles on selection! if it was there before, i just noticed it! anyway to make this apply to entire playlist without selecting all?

Last edited by billyvnilly; 7th February 2007 at 01:28.
billyvnilly is offline  
Old 7th February 2007, 06:59   #14
Juanus
Major Dude
 
Juanus's Avatar
 
Join Date: Oct 2004
Location: Santa Monica, CA
Posts: 734
Send a message via AIM to Juanus
Thanks for the cool new release.
Unicode looks good so far. Is the media library using SQL Lite now? It sure does seem a lot faster that it was. Hopfuilly we will be able to alphebetize playlists with the new database.

So far very few bugs for a beta.
Juanus is offline  
Old 7th February 2007, 07:02   #15
Pawel
Moderator
 
Pawel's Avatar
 
Join Date: Aug 2004
Location: Poland
Posts: 535
Send a message via ICQ to Pawel
Hi.

I must agree with Serpher. There is something wrong with installer, with polish language.

First of all, the "Core Media Library Components" is not translated (should be "Główne Składniki Biblioteki Mediów"). It also can not be expanded... so we can't check/uncheck this plugins (Local Media, Playlists....etc)
Second, there are no Dashboard and ReplayGain plugins to choose.
Also, "Transcoding Tool" is not translated - it should be "Transkoder".

To Benski.
I sent you Polish texts for installer. I think that in older beta version everything was ok, with polish installer... Please check this.
If you have some untranslated word in this file, let me know, I will send you back polish translation for that.


Ps: It is great that there will be new Winamp version!
Best regards!
Pawel is offline  
Old 7th February 2007, 07:55   #16
Hanschke
Senior Member
 
Join Date: Mar 2003
Location: germany
Posts: 128
btw: is there no german betatester which can u german text files? do u need a translator?

@dj egg

i mean this:



the setup "bug" i cannot reproduce today. very strange. sorry
Hanschke is offline  
Old 7th February 2007, 08:16   #17
foxyshadis
Member
 
Join Date: May 2002
Location: The deserts of California
Posts: 60
Send a message via AIM to foxyshadis Send a message via Yahoo to foxyshadis
So far I've had a few crashes (caused by new dsp plugins I'm testing at the same time - not expecting support for the crashes themselves), and when it happens a crash dump/cleanup message pops up, but it says it failed to gather the info and just exits. The dump tool is nice, but it doesn't seem to be working.

Also the (linear) spectrum analyser bug reported in this thread is still present. Is it hard to switch back to a normal logarithmic spectrum?
foxyshadis is offline  
Old 7th February 2007, 09:18   #18
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
Originally posted by Juanus
Is the media library using SQL Lite now? It sure does seem a lot faster that it was.
nope, is still the original NDE based format hence the * Improved: [NDE] speed optimizations line in the change log (probably doesn't make sense if you don't know what NDE is )

Hanschke: one is already being done i believe

Quote:
It is great that there will be new Winamp version!
people doubted there wouldn't be a new one despite talk of a new version coming before this thread, for shame on them

-daz
DrO is offline  
Old 7th February 2007, 12:20   #19
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,341
Quote:
Originally posted by Hanschke
btw: is there no german betatester which can u german text files? do u need a translator?
There is one, the German translation is mostly finished, but he just got DSL and must clean some things on his system.
Koopa is offline  
Old 7th February 2007, 12:31   #20
Hanschke
Senior Member
 
Join Date: Mar 2003
Location: germany
Posts: 128
nice to know that there will be a german translation in the near future
Hanschke is offline  
Old 7th February 2007, 12:34   #21
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,341
But just for beta versions of the installer, though
Koopa is offline  
Old 7th February 2007, 12:39   #22
Hanschke
Senior Member
 
Join Date: Mar 2003
Location: germany
Posts: 128
why not for the final? can u tell me the reason? will be nice to have a few languages inside the setup. maybe the 5 most important ones?

[edit]

can u tell me how to install the german.ini from your sig?

[edit2]

my crash files after closing the beta.

http://rapidshare.com/files/15338334/_crash.log

dmp is 0 kb
Hanschke is offline  
Old 7th February 2007, 12:43   #23
DrO
 
Join Date: Sep 2003
Posts: 27,873
it's only for beta at the moment since that's what's been decided on (i remember a reason being mentioned but can't remember what it is off hand). the aim i believe is to eventually have the installer running with the translations in final release builds but really it's the devs decision on the matter as to what and how things are released.

-daz
DrO is offline  
Old 7th February 2007, 12:52   #24
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,341
Quote:
why not for the final? can u tell me the reason? will be nice to have a few languages inside the setup. maybe the 5 most important ones?
There was some discussion, that users are maybe confused, because the installer is translated but Winamp is still English.
Koopa is offline  
Old 7th February 2007, 13:04   #25
Cianca
Senior Member
 
Join Date: Mar 2002
Posts: 336
2 questions:

1) Why the new ML is not built with SQL?

2) With new web-based objects in 5.34 ml_online can be personalized? or is possible make a plugin to show in web page the song played in winamp?

The universal god of light, love, wisdom and rok n rol
Cianca is offline  
Old 7th February 2007, 13:12   #26
DrO
 
Join Date: Sep 2003
Posts: 27,873
Quote:
1) Why the new ML is not built with SQL?
because it's not, heh

Quote:
2) With new web-based objects in 5.34 ml_online can be personalized?
not sure where that's come from since i've not heard of any talk of such changes with ml_online - though i thought it can already be altered to display customs views or something like that (the whole online stuff just doesn't appeal to me so i'm not too sure on it)

-daz
DrO is offline  
Old 7th February 2007, 14:26   #27
denilson3
Junior Member
 
Join Date: May 2000
Posts: 42
Send a message via AIM to denilson3 Send a message via Yahoo to denilson3
video quality is still poor in vista with this build.

does not appear to be a codec or video card problem as video in other media players is much better.
denilson3 is offline  
Old 7th February 2007, 15:46   #28
SpaceBanana
Junior Member
 
Join Date: Jan 2006
Location: Here, there, everywhere
Posts: 9
Yay a new build

Using Vista Business 32bit atm and Winamp couldn't be running smoother. Only slight bug I've run into is whenever I plug my iPod (5g) in, it shows up twice in the media library, once as an iPod and once as a removable drive (see attached screenshot).

Anywho, apart from that, keep up the good work!
Attached Images
File Type: png medialib.png (40.4 KB, 653 views)
SpaceBanana is offline  
Old 7th February 2007, 16:34   #29
gaekwad2
Foorum King
 
gaekwad2's Avatar
 
Join Date: Jul 2003
Location: bar2000
Posts: 11,424
Wow, I didn't know there are 500GB iPods.
gaekwad2 is offline  
Old 7th February 2007, 17:14   #30
will
Nullsoft Newbie (Moderator)
 
will's Avatar
 
Join Date: Mar 2001
Location: Sheffield, England
Posts: 5,569
Quote:
Originally posted by Cianca
Why the new ML is not built with SQL?
What features from SQL would you like the ML to have?

DO NOT PM ME WITH TECH SUPPORT QUESTIONS
will is offline  
Old 7th February 2007, 17:42   #31
Juanus
Major Dude
 
Juanus's Avatar
 
Join Date: Oct 2004
Location: Santa Monica, CA
Posts: 734
Send a message via AIM to Juanus
Quote:
Originally posted by will
What features from SQL would you like the ML to have?
First let me say, I am sorry that I mentioned it.
I remember a previous post somewhere saying that the ML might be switching over to a new format so I wondered if this was it. And I figured that when that switch happened that the alphebetising of the Playlist would happen. (I assume correctly or incorrectly that this is a limitation with the current database and that is my one and only pet peeve that I have left.)

Thanks for all of the great work that you do. I think that this new version is great and I am never one to look a gift Llama in the mouth.
Juanus is offline  
Old 7th February 2007, 18:20   #32
will
Nullsoft Newbie (Moderator)
 
will's Avatar
 
Join Date: Mar 2001
Location: Sheffield, England
Posts: 5,569
No, I was serious.

I was talking with benski about what features I'd like the ml database engine to have. So, if you have any ideas please say so.

DO NOT PM ME WITH TECH SUPPORT QUESTIONS
will is offline  
Old 7th February 2007, 21:14   #33
Juanus
Major Dude
 
Juanus's Avatar
 
Join Date: Oct 2004
Location: Santa Monica, CA
Posts: 734
Send a message via AIM to Juanus
Oh cool!
I love the way that the ML works now.
I just would like the playlist section to be more functional. Alphebetizing and being able to click the Playlist Title header and make things sort (or any of the headers for that matter) That part is huge for me because of the way I have things organized in folders on my HD and when looking through winamp, It is hard to find certain things.

I hope that people post cool suggestions for the ML. I would love to hear them also.
Juanus is offline  
Old 7th February 2007, 21:52   #34
Hanschke
Senior Member
 
Join Date: Mar 2003
Location: germany
Posts: 128
maybe we can put a german.lng file for the rest inside too
Hanschke is offline  
Old 7th February 2007, 23:15   #35
Koopa
16-Bit Moderator
 
Koopa's Avatar
 
Join Date: Apr 2004
Posts: 4,341
For which rest? Just the installer is translated.
Winamp's translation support needs some more love, so that we're able to translate anything, otherwise bundled language files makes no sense.

So you've to wait, until the language file support has been improved.
Koopa is offline  
Old 8th February 2007, 10:53   #36
J_Darnley
Forum King
 
J_Darnley's Avatar
 
Join Date: Apr 2004
Location: Belgium, Europe
Posts: 3,626
Send a message via ICQ to J_Darnley
The unicode features are great. I've now got my few files with unicode characters displaying them instead of ____.

Can I ask if anyone else is having problems with the playlist shuffle? I toggle shuffle on but it just always go on to the next track down the playlist. It's probably just a conflict with one of my many 3rd-party plugins. I'll do a little more investigating this evening.

One other thing, does the transcoder apply replay gain before encoding? Do I have to turn off 24 bit output? I guess I'll try that as well tonight.

Winamp ATF ReferenceMy cPro timer widgetMy port of AVS
Do NOT email me with general tech support questions.
J_Darnley is offline  
Old 8th February 2007, 12:02   #37
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,823
Quote:
Originally posted by J_Darnley
Can I ask if anyone else is having problems with the playlist shuffle?
No. Shuffle is working ok for me.
Note that bug reports are only valid if there's no 3rd-party plugins present.
Quote:
does the transcoder apply replay gain before encoding?
No, alas it doesn't. You'll have to do it manually.
(note, there's an option in prefs for auto applying rg for cd ripping, but not one for transcoder)
Quote:
Do I have to turn off 24 bit output?
No. Though there's a bug in the current public beta where transcoding mp4/m4a creates empty files if 24bit playback is enabled (bug is fixed in latest internal build).
DJ Egg is offline  
Old 8th February 2007, 17:20   #38
IAmLordMavis
Junior Member
 
Join Date: Feb 2007
Posts: 3
Hebrew in the song titles still does not work.
All the letters are displayed as question marks in the playlist and in the currently playing title if Media Library is installed.
I use English WinXP with Russian MUI on top of it.

PS I appreciate Russian in the Installer but there still is a lot of grammatical errors.
IAmLordMavis is offline  
Old 8th February 2007, 17:24   #39
Benski
Ben Allison
Former Winamp Developer
 
Benski's Avatar
 
Join Date: Jan 2005
Location: Brooklyn, NY
Posts: 1,057
Quote:
Originally posted by IAmLordMavis
Hebrew in the song titles still does not work.
All the letters are displayed as question marks in the playlist and in the currently playing title if Media Library is installed.
I use English WinXP with Russian MUI on top of it.

PS I appreciate Russian in the Installer but there still is a lot of grammatical errors.
Find those songs in the media library, select them, right click and choose 'Read metadata on selected items'
Benski is offline  
Old 8th February 2007, 19:35   #40
osmosis
Major Dude
 
osmosis's Avatar
 
Join Date: Jan 2006
Location: Cananada
Posts: 841
i'm not sure if it's an ML engine thing or not but i'd like secondary (and possibly tertiary) column sorting with the ML views please. keep up the great work.

Request: A little SmartView Query Language love.
osmosis is offline  
Closed Thread
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump