Old 5th May 2016, 06:59   #1
Otviss
Junior Member
 
Join Date: May 2016
Posts: 2
Some tracks when streaming are playing really fast

Hey there everyone. Not sure If i should post this on winamp or shoutcast.

The subject has been touched on here:

http://forums.winamp.com/showthread....t=playing+fast

But why go back to a 2011 thread if there wasn't any help anyway.

So I have my radio station set up via a "myradiostream" server, using the shoutcast plugin.

As the user on the thread I linked to mentioned. It is only on certain songs/albums which makes me think that they have a different sample-rate? Sorry I know nothing about audio technology

But the encoder within winamp and the plugin should sort that out shouldn't it? Cause obviously you're going to play from a media library with many different formats or types of audio rather. Theyre all mp3.

So the issue:

Some songs on the stream play really really fast, chipmunk fast and sound very distorted but within winamp it sounds fine. And I can play the files normally in like VLC etc.

What could be the issue of this?

Update: Huh.. Wanted to show you the difference in info between a file that played normally and the file that didnt. Double clicked on the "File that was wrong or what ever". Winamp crashed..or "stopped working".... hm..

Update 2: "Stopped working" on more files than just one

Update 3: Updated my sound driver. That made things even worse. Back at standard now. (Turns out I have the latest drivers already)

Update 4: Did a clean install of winamp v5.666 Build 3516 (x86) removed all plugins. Then downloaded the shoutcast DSP plugin v2.3.5. Stream is fine and all that but when playing certain songs it does the chipmunk thing again. I'm using "myradiostream.com" as my host for the server and it has a stream limit of 128kbps for a free account. So that's what I set my encoder to. Almost all songs I have in the library are 320kpbs. I think all are actually. So below I've included the info of two songs. First song works. Second doesn't.

Works:



Does not:



This is of course only an example. There are many other songs that do not work.

Last edited by Otviss; 5th May 2016 at 09:45.
Otviss is offline   Reply With Quote
Old 5th May 2016, 18:09   #2
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,766
Hi Otviss,

Your issue may be caused by the sampling rate some of your songs were encoded with. The example for the working file shows 44100 Hz which is the standard rate for mp3s. The other example shows 48000 Hz which is a valid rate, but may it not work correctly with the shoutcast DSP plug-in.

I suggest you try the resampling feature in the BogProg X-Fade plug-in. It can automatically resample your songs before they are passed to the shoutcast DSP plug-in. I have not heard any loss of sound quality using this plug-in with my mp3s.

First be sure you are using the latest patched version of Winamp v5.666 Build 3516. You can download it from here (http://forums.winamp.com/showthread.php?t=373755) and install it over your current version.

Then download the current version (2.1.4.17) of the BogProg X-Fade plug-in from post #26 in this thread (http://forums.winamp.com/showthread.php?t=379988). After installing the plug-in, open the Winamp Preferences window (press Ctrl + P), scroll down on the left side, and select "Plug-ins - Input". On the right side, select "BogProg x-Fade v2.1.4.17" and click the "Configure" button at the bottom. On the right side of the configuration window that opens select "Enable" under "Resample". Then make sure the "Sample Rate" is set to "44100", the "Bits Per Sample" is set to "16", the "Number Of Channels" is set to "2", and the "Quality" is set to "HighQuality".

The options on the left side are for the plug-in's crossfading feature. If you don't want to use it, set the crossfade time to 0.

Click the "Done" button at the bottom of the configuration window and the "Close" button at the bottom of the Winamp Preferences window. Try playing some of the songs that were playing too fast to see if this 'fixes' the problem.

Winamp Pro v5.666.3516 fully-patched - Quinto Black CT v3.1 skin
Windows 10 Home 64-bit v20H2 desktop - Logitech Z906 5.1 speaker system

Last edited by Aminifu; 5th May 2016 at 19:18.
Aminifu is offline   Reply With Quote
Old 5th May 2016, 18:56   #3
Otviss
Junior Member
 
Join Date: May 2016
Posts: 2
Quote:
Originally Posted by Aminifu View Post
Your issue may be caused by the sampling rate some of your songs were encoded with. The example for the working file shows 44100 Hz which is the standard rate for mp3s. The other example shows 48000 Hz which is a valid rate, but may it not work correctly with the shoutcast DSP plug-in.

I suggest you try the resampling feature in the BogProg X-Fade plug-in.
Well look at that! It worked! Installed the plugin and followed your instructions. All tracks on all albums play normally now. Thank you ever so much!

-O
Otviss is offline   Reply With Quote
Old 5th May 2016, 19:22   #4
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,766
That's great! I thought I had read somewhere that the shoutcast DSP was picky about sampling rates. X-Fade should work with other file formats, but I've only tried it with mp3s.

Winamp Pro v5.666.3516 fully-patched - Quinto Black CT v3.1 skin
Windows 10 Home 64-bit v20H2 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 16th September 2020, 15:57   #5
Majicc66
Junior Member
 
Join Date: Sep 2020
Posts: 1
My Solution to Distortion on Winamp

Any song that plays distorted on my station, I re-record through Virtual DJ and that works fine for me.
Majicc66 is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump