Old 12th September 2016, 20:57   #1
SoLoRiZe
Member
 
Join Date: Jul 2002
Location: UK
Posts: 83
Shoutcast DSP constantly crashing

Hi,

Just to give you a bit of background.

I have been happily streaming for years using:

WinAMP version: 5.623
Shoutcast DSP version: 2.2.3
Shoutcast DNAS version: 1.9.8
OS: Windows XP (with Service Pack 3)

I have also been playing the same large playlist, so no new songs have been added.

But a couple of weeks ago I noticed that the DSP had started disconnecting the stream
on a regular basis. FYI. I have not updated any programs or installed new software on the
Laptop so can rule that out.

So as I could not work out the reason why and had a bit of spare time last weekend I
decided to update WinAMP, Shoutcast DSP and Shoutcast DNAS, to the following versions
to see if that would get it working again.

WinAMP version: 5.666 (Build 3516)
Shoutcast DSP version: 2.3.5.222
Shoutcast DNAS version: 2.5
OS: Windows XP (with Service Pack 3)

But now with the latest versions installed, configured and running it now crashed all the time!

I get the following error (snippet from the _crash.log file)

code:
Winamp client version: 5.666 Build 3516
winamp caused an Access Violation (0xc0000005)
in module MSVCR90.dll at 001b:7855b9f0.

Exception handler called in Winamp.
Error occurred at 9/12/2016 19:00:44.
C:\Program Files\Winamp\winamp.exe, run by Mark.
Operating system: Windows XP (5.1.2600).
1 processor(s), type 586.
55% memory in use.
1024 MBytes physical memory.
460 MBytes physical memory free.
2464 MBytes paging file.
1851 MBytes paging file free.
2048 MBytes user address space.
1935 MBytes user address space free.
Read from location 04177000 caused an access violation.

Context:
EDI: 0x00000010 ESI: 0x00c38be0 EAX: 0x78fefcf8
EBX: 0x00000000 ECX: 0x04177000 EDX: 0x6b84f523
EIP: 0x7855b9f0 EBP: 0x00c38bb4 SegCs: 0x0000001b
EFlags: 0x00210246 ESP: 0x00c38ba8 SegSs: 0x00000023



Also, I have included the report.zip file if it helps: report.zip

Does anyone know what the error means and how fix it as it's driving me mad.


I did see another post from another user who had a similar problem, but I could
not see a post that specified how to fix it.
http://forums.winamp.com/showthread....37#post3011737

If anyone can help me it would be much appreciated as currently I have had
to stop my shoutcast broadcast as its keeps crashing.

Thanks in advance.
SoLoRiZe is offline   Reply With Quote
Old 14th September 2016, 12:34   #2
PedgeJameson
Member
 
PedgeJameson's Avatar
 
Join Date: Feb 2004
Posts: 60
10 bucks says no matter what Dr.No denies its shoutcast and it's something you're doing wrong.

http://socialcrime.com
The Social Crime Radio Network
We're what's wrong with America...
24/7 Standup and a live show Thursdays.
PedgeJameson is offline   Reply With Quote
Old 15th September 2016, 16:17   #3
KingKoz
Junior Member
 
Join Date: Feb 2003
Location: Central NY
Posts: 30
Shoutcast shutting down

I too have been running a shoutcast server (2nd machine running server) for almost 20yrs and recently noticed that the server was shutting down. Actually, in my case, the server isn't shutting down, Winamp is stopping. I started trying to figure out why and noticed my HD (older Maxtor 120gb) is reporting is is about to die and I should backup immediately. I replaced the HD, reinstalled Windows and all the programs I needed. Seems the spare HD I had was also reporting imminent death. So, I find another HD and this one seems fine. I also replaced the PC's power supply. However, the machine only has 2GB ram. Running winamp still causes random shutdown. I tried running the server on the same machine but am using Winamp from another networked PC (mine and it ran for hours with no problems) Since I need my pc for other things, I decided to run Winamp for a different networked PC pointing it at the server PC and it appears to work fine. This morning, I noticed I am getting an Error that says "[Avert sid=1] Advert map retrieval failed with code: 7 [Failed to connect to Ads.shoutcast.com port 443: Timed Out]" Which I am assuming is showing me an issue with the ads server anyone else with these issues. Can someone from shoutcast verify they aren't having issues withteh ads server?

As a side note; I think the issue is ram. I ran a test on mine and it reported no issues. I think the new shoutcast/winamp software doesn't like a small amount of memory and crashes. Unfortunately, I don't have any spare ram (can't afford to buy at this time). When I ran the server and DSP from my machine with 16GB of ram it ran fine for over 12hrs with no issues. So, what you say shoutcast? Does shoutcas/winamp/DSP need more than 2 GB to run properly?
KingKoz is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > SHOUTcast > SHOUTcast Technical Support

Tags
crash, dsp, error, winamp

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump