Old 27th February 2006, 15:34   #1
losbear
Junior Member
 
Join Date: Feb 2006
Posts: 4
Looping Buffer during Internet Streaming

I'm a software developer working on Windows XP Pro. My latest project is a .net web application (framework v1.1), so to circumvent all the corp BS of setting up a dev box, I'm hosting it all locally (IIS6.0)

Problem only seems to be when I compile the project in vs.net 2k3 and refresh the localhost page. Then it happens....

Winamp (v5.2) just stops playing and it says "buffering 20%, 40%, etc. up to 80%, then plays about 1.5 seconds of music and goes back into buffering. Keeps doing it until I hit play, which then it resumes normal play until the next recompile.

All stations from Shoutcast seem to do it.

Only seems to happen with the web projects.. non-web projects don't do it. Could be IIS is interfering with Winamp's ports...

Other than that, thanks and keep up the good work
losbear
losbear is offline   Reply With Quote
Old 27th February 2006, 16:00   #2
losbear
Junior Member
 
Join Date: Feb 2006
Posts: 4
Screenshot

Try not to laugh to hard at me for listening to smoothjazz. Here's a screenshot of what it looks like (in case it helps) for this issue.
Attached Images
File Type: gif winamp.gif (20.1 KB, 234 views)
losbear is offline   Reply With Quote
Old 27th February 2006, 17:12   #3
CrimmyC
Junior Member
 
Join Date: Feb 2006
Location: Tupelo, MS
Posts: 11
Send a message via AIM to CrimmyC
I have 5.2 here at work and it does it to me sometimes... though I'm not any sort of coder or compiling anything. It will just, out of nowhwere, start buffering, play for a second and then buffer more. If I press stop and then play it will play normally for awhile. At first I thought it was the stations connection sucking but it does it on all stations.
CrimmyC is offline   Reply With Quote
Old 27th February 2006, 19:11   #4
losbear
Junior Member
 
Join Date: Feb 2006
Posts: 4
Yep, exactly! Although, I just hit play and it takes off. Not a programmer...hmm, maybe it's just when bandwidth conditions are less than favorable it throws into a loop...
losbear is offline   Reply With Quote
Old 28th February 2006, 18:12   #5
Drunkpunk082
Junior Member
 
Join Date: Feb 2006
Posts: 3
Same thing just started happening to me. I just installed SHOUTcast last night. I am streaming it over a LAN so bandwidth isnt an issue. I am running IIS on the PC hosting both the server and streaming the music. It was working last night flawlessly. I didnt even restart my PC's!! I simply went to bed, got up today and now it does exactly as described. Plays for a few min, then starts buffering plays another 1.5 sec or so, and buffers again. This repeats till either I restart the server or stop and start my winamp.

If anyone has any insight let me know please!!


After looking at the server logs it seems to play smooth for around 30-45 seconds before it starts skipping (buffering).
Drunkpunk082 is offline   Reply With Quote
Old 28th February 2006, 18:45   #6
losbear
Junior Member
 
Join Date: Feb 2006
Posts: 4
Do the winamp folks ever check these forums? heh
losbear is offline   Reply With Quote
Old 1st March 2006, 00:36   #7
Drunkpunk082
Junior Member
 
Join Date: Feb 2006
Posts: 3
I hope so. Cant seem to resolve this issue myself.
Drunkpunk082 is offline   Reply With Quote
Old 1st March 2006, 04:38   #8
Drunkpunk082
Junior Member
 
Join Date: Feb 2006
Posts: 3
It also seems to happen at a fixxed interval of 47 or 48 seconds after the "listener" connects. Again, it was working just last night perfectly fine. Now, even after a reinstall of all SHOUTcast products I still get the buffering after 47 seconds, and it doesnt stop till I reconnect.
Drunkpunk082 is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Bug Reports

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump