Old 12th June 2017, 07:22   #1
juanamores
Junior Member
 
Join Date: Jun 2015
Posts: 19
[MICROSERVER] Flash policy file server not enabled

Estimados, les comento mi problema ...

Actualmente estoy usando DNAS/Linux v1.9.8 con TRANSCast/posix(linux x64) v2.0.0.54 (Oct 7 2011).
Todo me funciona perfectamente!

Pero hoy intenté hacer un update a la última verión de SHOUTcast DNAS 2.5.1 Latest release - Updated 28/01/2017 - Build 724 Linux 64, descargada de la página oficial.

De acuerdo a lo que leí para realizar el update basta con sobrescribir el archivo sc_serv de 134KB por el nuevo de 6838KB y agregar el archivo cacert.pem.

Esta nueva versión no me arranca el servidor, y cuando voy a mirar el log de errores sale:

Quote:
2017-06-12 06:59:34 INFO [MICROSERVER] Flash policy file server not enabled
2017-06-12 06:59:44 ERROR [DST 127.0.0.1:56660 sid=1] HTTP client connection rejected. Stream not available as there is no source connected. Agent: `Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/52.0.2743.116 Safari/537.36'
Les comento lo que he realizado para solucionar ese error sin éxitos:

1) al comienzo no especifiqué nada del crossdomain.xml en las configuraciones de sc_serv.conf y sc_trans.conf porque no sabía que existía esa configuración.

2) Como me salía el error comentado anteriormente, comencé a leer y encontré las configuraciones para ese archivo y se las agregué a ambos archivos de configuración.

Tampoco funcionó!

Les comento que el crossdomain está bien configurado porque fue una exigencia para obtener la conexión segura en mi web HTTPS (candado verde de página segura), pero por las dudas se los copio al final.

Mis configuraciones son:

sc_serv.conf
code:

Logfile=sc_serv.log
ShowLastSongs=10
PublicServer=default
ScreenLog=0
Yport=80
NameLookups=0
AutoDumpUsers=0
autodumptime=30
AllowRelay=Yes
AllowPublicRelay=Yes
MetaInterval=8192
MaxUser=100
portbase=9920
password=*****
adminpassword=*****
SrcIP=149.202.34.48
DestIP=ANY
flashpolicyfile=/home/juanamores/radio/autodj/crossdomain.xml



sc_trans.conf
code:
encoder=mp3
bitrate=128000
samplerate=44100
channels=2
outprotocol=4
serverip=149.202.34.48
serverport=9920
password=*****
logfile=autodj.log
unlockkeyname=Juan Amores
unlockkeycode=*****-*****-*****-*****


screenlog=0
streamtitle=CHzRadio
streamurl=http://www.chathizpano.com
genre=Misc
playlistfile=/home/juanamores/radio/autodj/archive/auto380.lst
xfade=4
xfadethreshold=20
playlists=playlists
archive=archive
capture=0
applyreplaygain=0
calculatereplaygain=0
calendarrewrite=1
calendarfile=/home/juanamores/radio/autodj/calendar/dj_calendar.xml

autodumpsourcetime=30
djport=8000

flashpolicyfile=/home/juanamores/radio/autodj/crossdomain.xml
flashpolicyserverport=843

djlogin_1=dj1
djpassword_1=*****
djpriority_1=100
djlogin_2=dj2
djpassword_2=*****
djpriority_2=100



crossdomain.xml
code:
<?xml version="1.0"?>
<!DOCTYPE cross-domain-policy SYSTEM "http://www.macromedia.com/xml/dtds/cross-domain-policy.dtd">
<cross-domain-policy>
<site-control permitted-cross-domain-policies="all"/>
<allow-http-request-headers-from domain="*" headers="*" secure="false" />
<allow-access-from domain="*" secure="false" />
</cross-domain-policy>



NOTA: por razones obvias, puse con *** los datos privados, como contraseñas y licencias de mp3.

Uso VPS CentOS Linux release 7.3.1611 64bits.

Muy agradecido por la ayuda que me puedan brindar.

Saludos
juanamores is offline   Reply With Quote
Old 19th June 2017, 23:00   #2
juanamores
Junior Member
 
Join Date: Jun 2015
Posts: 19
Estimados Moderadores, no se porque motivo yo no puedo editar ni borrar mis propios post (deben ser las reglas).

Puede algún Moderador editar este post, y eliminar los datos de todas las configuraciones?
Ya he reportado este post en 2 oportunidades y no lo editan.

La solución fue abrir el puerto 843 que estaba cerrado en mi servidor.

Muchas gracias!

--------------------

Dear Moderators, I do not know why I can not edit or delete my own posts (they should be the rules).

[B] Can some Moderator edit this post, and delete the data of all configurations? [/ B]
I have already reported this post in 2 opportunities and do not edit it.

The solution was to open port 843 which was closed on my server.

Thank you very much!
juanamores is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > International Connection > International Connection

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump