Old 3rd October 2005, 00:37   #41
guest1928
Guest
 
Posts: n/a
Hi,
I have several .nsh files !include'd, and happened to press Alt-C while editing one of them. Naturally the build failed and an error line popped up in Problems View.
And it's stuck, it does not go away, even if I compile the main .nsi successfully. How do I get rid of such dangling entries in Problems View? Is this view not cleared before every compile?
  Reply With Quote
Old 3rd October 2005, 00:57   #42
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Good question. Let me check and see.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 3rd October 2005, 01:15   #43
Jamyn
Junior Member
 
Join Date: Aug 2002
Location: Texas
Posts: 36
edit: now that I've spent a few more minutes thinking about it, there are plenty of situations where you would want the EclipseNSIS script generator to create an uninstall section, even for sections that are purely function-based. And I think it would take many thousands of more minutes to code logic for this issue than it would to just manually edit the generated template... and that time could better be spent on pretty much anything else that would be much more worthwhile. So I withdraw my post.

I'd also like to add a huge thank you to all that are involved in the eclipseNSIS project, as well as everyone who has spent any time working on and improving NSIS, the WIKI, the documentation, the examples, the included contributions, etc. It is very much appreciated by many, including myself.

Quote:
One thing I noticed was that (maybe I'm wrong) when building a new install file from a template, EclipseNSIS does not allow me to create a section that does not install any files. By this I mean, I have a section or two that just does file manipulations. Download updates, perform version checks, etc etc etc. But I have to insert a dummy file for each section so that EclipseNSIS lets me continue with the template.

Optimally, I'd prefer to somehow mark that section as "performs function operations", so I didn't have to tell it to install the dummy file. That, and if a section only performed functions, to not have it generate an uninstaller section for those particular sections.

It's very a minor thing, but I thought I'd bring it up anyway.
Jamyn is offline   Reply With Quote
Old 3rd October 2005, 04:21   #44
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
guest1928:
Unfortunately there is no easy way to clear the markers from your nsh file. What you can do is clear all the markers for the project it belongs to. To do this, navigate to:
<Workspace>\.metadata\.plugins\org.eclipse.core.resources\.projects\<your project> and delete the .markers file.
The next release will be fixed so that compile/test menus and shortcuts will ONLY be enabled for nsi files- not nsh files.

Jamyn:
I understand what you are saying- however, creating sections which are not going to actually install something are beyond the scope of the Wizard- and frankly it would be kind of pointless as well. All you would really gain is avoiding having to type two lines ("Section" and "SectionEnd"). You should use the wizard to generate the base script and then customize it with all the bells and whistles you need.
Perhaps you could use the code templates to be able to quickly insert sections instead?
Also, thanks for the kind words. EclipseNSIS is something I created as much for myself as for the Eclipse/NSIS community. it was a personal itch I just had to scratch :-).

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 8th October 2005, 16:57   #45
Comm@nder21
Major Dude
 
Join Date: Jul 2003
Location: germany, b-w
Posts: 734
Send a message via ICQ to Comm@nder21
i noticed that EclipseNSIS isnt recognizing my self built MakeNSIS.exe (built with visualstudio toolkit and platformsdk from cvs source - 8th oct. 05).
it wants me to choose an other path ...
Comm@nder21 is offline   Reply With Quote
Old 9th October 2005, 09:16   #46
Joost Verburg
NSIS MUI Dev
 
Join Date: Nov 2001
Posts: 3,717
I upgraded to the latest EclipseNSIS, but it also fails to detect a plain nightly build of NSIS and displays that NSIS 2.0 or later is required.
Joost Verburg is offline   Reply With Quote
Old 9th October 2005, 13:09   #47
Comm@nder21
Major Dude
 
Join Date: Jul 2003
Location: germany, b-w
Posts: 734
Send a message via ICQ to Comm@nder21
this is exactly what i mean, joost.
i think, the version detection of eclipse nsis can't handle the cvs version string.
Comm@nder21 is offline   Reply With Quote
Old 9th October 2005, 23:05   #48
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Do you have EclipseNSIS 0.9.3 installed?
I also use the CVS build version and it is recognized without a problem.
How does your CVS build report its version?
Mine says v07-Oct-2005.cvs

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 10th October 2005, 04:31   #49
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
I just downloaded the latest nightly build and tried that as well. This also works.
Support for non-release builds (i.e., CVS builds and nightly builds) was added in EclipseNSIS 0.9.1 and I have tested it on Windows XP, Windows 2000, Windows NT, Windows ME and Windows 98 without any problems.
What do you get when you type makensis /version?

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 10th October 2005, 09:45   #50
Joost Verburg
NSIS MUI Dev
 
Join Date: Nov 2001
Posts: 3,717
If I just download a nighly build (makensis /version works as expected) and try to set it as NSIS Home it shows me 'Invalid NSIS Home, MakeNSIS 2.0 required'. This is a new issue after upgrading to EclipseNSIS 0.9.3. Version 0.9.2 worked fine.
Joost Verburg is offline   Reply With Quote
Old 10th October 2005, 11:33   #51
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Strange. There is no significant difference in the version validation code between 0.9.3 and 0.9.2.
Can you check in the .log file if any error is being recorded?
If not, I may create a special debug build for you to use (and generate a log).
[edit]Has anything else changed on your end? Java VM, MakeNSIS path, MakeNSIS exe name, etc.?[/edit]

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 10th October 2005, 12:06   #52
kichik
M.I.A.
[NSIS Dev, Mod]
 
kichik's Avatar
 
Join Date: Oct 2001
Location: Israel
Posts: 11,343
The log file is also available from the menus at Window > Show View > Error Log. No need to dig into your workspace.

iceman_k, I usually add this view as a fast view to my perspective, especially in development versions. It's very unobtrusive, but still very useful.

NSIS FAQ | NSIS Home Page | Donate $
"I hear and I forget. I see and I remember. I do and I understand." -- Confucius
kichik is offline   Reply With Quote
Old 10th October 2005, 12:28   #53
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
I keep it docked with my other views. You can also configure the view to automatically activate upon new entries- also a useful feature.
The problem with this view, however, is that if your log has been rotated, you may miss some information. So while I use it, I prefer to dig into my workspace .metadata on occasion.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 10th October 2005, 12:58   #54
kichik
M.I.A.
[NSIS Dev, Mod]
 
kichik's Avatar
 
Join Date: Oct 2001
Location: Israel
Posts: 11,343
I was actually talking about the perspective you define for EclipseNSIS in plugin.xml, though in this case you'd need a perspectiveExtension. It's easier to get the information from the users this way.

NSIS FAQ | NSIS Home Page | Donate $
"I hear and I forget. I see and I remember. I do and I understand." -- Confucius
kichik is offline   Reply With Quote
Old 10th October 2005, 13:25   #55
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Since you are monitoring this thread, are you seeing the same issue as Joost & Comm@nder21? Specifically- EclipseNSIS 0.9.3 does not accept CVS builds for the NSIS home.
Like I said, I have tried it on several OS's without a problem. The only possible thing I can think of is that it has something to do with the localization settings on the user's PC- though I feel that I have accounted for that as well.
Perhaps I will create a fragment build which logs the actions performed during version validation and distribute via this forum. The other option is remote debugging- but the performance on that is poor even with 2 computers right next to each other in the network- let alone on different continents!

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 10th October 2005, 13:30   #56
kichik
M.I.A.
[NSIS Dev, Mod]
 
kichik's Avatar
 
Join Date: Oct 2001
Location: Israel
Posts: 11,343
I'm only monitoring this thread because it's interesting. I don't have enough free space to install Java

NSIS FAQ | NSIS Home Page | Donate $
"I hear and I forget. I see and I remember. I do and I understand." -- Confucius
kichik is offline   Reply With Quote
Old 10th October 2005, 13:56   #57
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
OK.
Then is anyone else out there experiencing this problem with EclipseNSIS 0.9.3?
Anyone in North America?
(Maybe it's a European thing).

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 10th October 2005, 14:10   #58
Comm@nder21
Major Dude
 
Join Date: Jul 2003
Location: germany, b-w
Posts: 734
Send a message via ICQ to Comm@nder21
the error log gives the following (interesting) information:
Quote:
java.text.ParseException: Unparseable date: "07-Oct-2005"
at java.text.DateFormat.parse(Unknown Source)
at net.sf.eclipsensis.util.NSISValidator.getNSISVersion(NSISValidator.java:132)
at net.sf.eclipsensis.util.NSISValidator.findNSISExe(NSISValidator.java:68)
at net.sf.eclipsensis.util.NSISValidator.validateNSISHome(NSISValidator.java:108)
at net.sf.eclipsensis.dialogs.NSISPreferencePage$4.widgetSelected(NSISPreferencePage.java:167)
at org.eclipse.swt.widgets.TypedListener.handleEvent(TypedListener.java:90)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:843)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3080)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2713)
at org.eclipse.jface.window.Window.runEventLoop(Window.java:809)
at org.eclipse.jface.window.Window.open(Window.java:787)
at net.sf.eclipsensis.dialogs.NSISPreferencePage.show(NSISPreferencePage.java:54)
at net.sf.eclipsensis.actions.NSISPreferencesAction.run(NSISPreferencesAction.java:23)
at org.eclipse.ui.actions.ActionDelegate.runWithEvent(ActionDelegate.java:70)
at org.eclipse.ui.internal.PluginAction.runWithEvent(PluginAction.java:236)
at org.eclipse.jface.action.ActionContributionItem.handleWidgetSelection(ActionContributionItem.java:538)
at org.eclipse.jface.action.ActionContributionItem.access$2(ActionContributionItem.java:488)
at org.eclipse.jface.action.ActionContributionItem$5.handleEvent(ActionContributionItem.java:400)
at org.eclipse.swt.widgets.EventTable.sendEvent(EventTable.java:66)
at org.eclipse.swt.widgets.Widget.sendEvent(Widget.java:843)
at org.eclipse.swt.widgets.Display.runDeferredEvents(Display.java:3080)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2713)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:1699)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1663)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:367)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:143)
at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:103)
at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:226)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:376)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:163)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334)
at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
at org.eclipse.core.launcher.Main.run(Main.java:973)
at org.eclipse.core.launcher.Main.main(Main.java:948)
i think this should give you an idea how to fix it
Comm@nder21 is offline   Reply With Quote
Old 10th October 2005, 14:12   #59
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Perfect. This is what I needed.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 10th October 2005, 14:38   #60
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
OK, I was able to reproduce this problem. As I suspected, it was because of a localization issue. I will issue a patch fragment which will fix this problem.
What mystifies me is that this apparently worked in 0.9.1 and 0.9.2- even though the validation code has essentially not changed (the only difference was to log errors to the log file instead of the console).
Update: When Scons builds MakeNSIS.exe, it sets the version thus:
code:

cvs_version = strftime('%d-%b-%Y.cvs', gmtime())



i.e., it uses the localized version of the month name. However, if you download the nightly build from the NSIS web site, the month name is in english- which may not match your locale. This causes the EclipseNSIS date parsing to fail- since it expects a localized version number.
Hence, I will modify the code to account for english as well as localized version numbers. In the meantime, if you rebuild MakeNSIS.exe on your local PC, EclipseNSIS should accept it.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki

Last edited by iceman_k; 10th October 2005 at 15:15.
iceman_k is offline   Reply With Quote
Old 10th October 2005, 19:00   #61
Comm@nder21
Major Dude
 
Join Date: Jul 2003
Location: germany, b-w
Posts: 734
Send a message via ICQ to Comm@nder21
hurry with the fix, eclipsensis is my main developing platform for nsis script files
Comm@nder21 is offline   Reply With Quote
Old 10th October 2005, 19:02   #62
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
I do have a fix ready. However it is too big (about 1.6 MB) to upload to this forum or to the Sourceforge Patch tracker.
I can email it to you or upload to an FTP site, if you wish.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 10th October 2005, 22:39   #63
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
The EclipseNSIS 0.9.3 hotfix can be downloaded from here.


Instructions[list=1][*]Quit Eclipse.[*]Backup eclipse\plugins\net.sf.eclipsensis_0.9.3.jar[*]Download file from URL above.[*]Unzip into eclipse\plugins folder, overwriting net.sf.eclipsensis_0.9.3.jar[*]Restart Eclipse.[/list=1]

Let me know if this doesn't work for you.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 11th October 2005, 07:37   #64
Joost Verburg
NSIS MUI Dev
 
Join Date: Nov 2001
Posts: 3,717
Looks like that download link requires a password.
Joost Verburg is offline   Reply With Quote
Old 11th October 2005, 13:05   #65
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Oops. The password:

EclipseNSIS

(case sensitive)

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 11th October 2005, 13:16   #66
Comm@nder21
Major Dude
 
Join Date: Jul 2003
Location: germany, b-w
Posts: 734
Send a message via ICQ to Comm@nder21
works, thanx!
Comm@nder21 is offline   Reply With Quote
Old 28th November 2005, 17:02   #67
o_owd
Senior Member
 
o_owd's Avatar
 
Join Date: Feb 2003
Location: TGM, Romania
Posts: 176
Send a message via ICQ to o_owd Send a message via Yahoo to o_owd
hello,

is there a way to 'fold on open' in eclipse ?
i searched for this option but could not find it.

thanks,
OJi.
o_owd is offline   Reply With Quote
Old 28th November 2005, 17:38   #68
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
What do you mean by "fold on open"? Do you mean that all foldable code sections should be folded by default?

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 28th November 2005, 18:13   #69
o_owd
Senior Member
 
o_owd's Avatar
 
Join Date: Feb 2003
Location: TGM, Romania
Posts: 176
Send a message via ICQ to o_owd Send a message via Yahoo to o_owd
yes, thats what i mean.
sorry for my english.

OJi.
o_owd is offline   Reply With Quote
Old 28th November 2005, 18:48   #70
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Sorry, that is not currently supported by EclipseNSIS.
You can make a feature request if you like.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 28th November 2005, 18:57   #71
o_owd
Senior Member
 
o_owd's Avatar
 
Join Date: Feb 2003
Location: TGM, Romania
Posts: 176
Send a message via ICQ to o_owd Send a message via Yahoo to o_owd
thanks for helping, i will
o_owd is offline   Reply With Quote
Old 29th November 2005, 02:23   #72
ibsolution
Junior Member
 
Join Date: Nov 2005
Location: Indonesia,Jakarta
Posts: 6
Iceman_K,
Thanks for your plugins.

How to show EclipseNSIS InstallOptions Editor ?, because when i right click Open With There no EclipseNSIS Editor. So i Can not see InstallOptions Editor. I Still use TextEditor. and when i take a look on icon. That icon using "ini configuration"

i can compile nsi file from eclipse .

TIA,

andy susanto
ibsolution is offline   Reply With Quote
Old 29th November 2005, 02:48   #73
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Quote:
Originally posted by o_owd

is there a way to 'fold on open' in eclipse ?
i searched for this option but could not find it.
Just following up on this- the functionality you desire is not currently available in Eclipse 3.1.
It will be available when Eclipse 3.2 is released- probably Q2 2006.
At that time EclipseNSIS will support it as well.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 29th November 2005, 02:50   #74
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Quote:
Originally posted by ibsolution
How to show EclipseNSIS InstallOptions Editor ?, because when i right click Open With There no EclipseNSIS Editor. So i Can not see InstallOptions Editor. I Still use TextEditor. and when i take a look on icon. That icon using "ini configuration"
You need to install GEF.
It should be available through the Eclipse Updates utility.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 30th November 2005, 03:25   #75
ibsolution
Junior Member
 
Join Date: Nov 2005
Location: Indonesia,Jakarta
Posts: 6
Iceman_K,

i try to update my GEF 3.1.1 and my eclipse 3.1
but i still can not use InstallOptions Editor. what would be happen ?
ibsolution is offline   Reply With Quote
Old 30th November 2005, 04:20   #76
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Check the error log and see if there are any error messages.
You can view the error log by opening Window->Show View->Error Log
The .ini file extension should be automatically associated with the InstallOptions editor- i.e., double-clicking on an ini file should open it using the InstallOptions editor.
Another thing to check would be the feature status.
Help->Software Updates->Manage Configuration
Select EclipseNSIS InstallOptions Editor 0.9.3 and click on the Show Properties hyperlink. This will bring up a dialog where you can check the feature status.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 26th January 2006, 18:18   #77
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
EclipseNSIS 0.9.4 and EclipseNSIS InstallOptions Editor 0.9.4 released

EclipseNSIS 0.9.4 and EclipseNSIS InstallOptions Editor 0.9.4 are both available for download now.
See the EclipseNSIS home page for details.

Changes:

EclipseNSIS
  • Java 6.0 (Mustang) can be used as the runtime environment- however it will not be officially supported until it is released.
  • Refactored EclipseNSIS console to use standard Eclipse console functionality.
  • Added support for NSIS scripts as External Tool launch configurations.
  • Added support for NSIS scripts as external builders.
  • Added NSIS update functionality - manual as well as automated.
  • EclipseNSIS editor scroll tip now moves with scroll bar.
  • SubSection/SubSectionEnd supported even when deprecated (NSIS 2.05 and above).
  • Clicking on a NSIS file link in EclipseNSIS help or NSIS Users Manual view now opens the file in Eclipse instead of an external editor.
  • Added support for nightly CVS builds.
  • Added support for SHCTX registry root key in EclipseNSIS Script Wizard.
  • Added error markers and tooltips in EclipseNSIS Script Wizard Contents page.
  • Added new command to clear problem markers.
  • Enhanced F3 hover help- now provides more detail as well as hyperlinks.
  • Fixed usage of template editor dialog.
  • Added functions to import registry keys/files into NSIS script.
  • Bug fixes:
    o 1387272
  • Feature Requests:
    o 1358177
    o 1358185
    o 1374835
    o 1380236
  • Other minor bug fixes.

EclipseNSIS InstallOptions Editor
  • Fixed GroupBox transparency.
  • Preview can now also handle external files.
  • Improved clipboard handling.
  • ComboBox/Droplist now shows the dropdown only when it is the primary selection.
  • Fixed improper handling of spaces in lists separated by '|', e.g. in Flags and ListItems fields.
  • Better management of Dialog sizes.
  • Other minor bug fixes.

Notes:
The EclipseNSIS console has been refactored to use the standard Eclipse console. This has resulted in a significant performance boost while compiling.
The new NSIS update feature enables you to check for, download and install the latest NSIS software from within EclipseNSIS, either on demand or on a scheduled basis.
You can now configure NSIS scripts as launch configurations. What this means is that a set of compilation options for a NSIS script can be saved as an External Tool launch configuration with Eclipse. This way multiple configurations can be saved for the same script and can be accessed easily through the External Tools menu or toolbar item. Additionally, NSIS script can be saved as project builders, and can be configured to run when the project is built.

As always, I am looking for any and all bugs you may find. These may be entered in the EclipseNSIS project SourceForge Bug tracker. Feature requests may also be entered.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 6th March 2006, 13:46   #78
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
EclipseNSIS 0.9.4 HOTFIX

EclipseNSIS 0.9.4 HOTFIX
========================
For whatever reasons, the way in which NSIS reports its version number was changed in NSIS 2.15.
This prevents EclipseNSIS from detecting that a valid version of NSIS is installed.
As a workaround, a hotfix JAR file is being provided on an interim basis. The hotfix can be downloaded from http://prdownloads.sourceforge.net/e...x.zip?download .
Please note that that the hotfix DOES NOT support new syntactical elements in NSIS 2.15- specifically the new !if command and the modification to the !define command.
Other than that, it should work just fine.

Installation Instructions:
==========================
1. Close any running instances of Eclipse.
2. In Windows Explorer, navigate to the Eclipse plugins folder.
3. Backup the net.sf.eclipsensis_0.9.4.jar file.
4. Copy the net.sf.eclipsensis_0.9.4.jar file in the hotfix to the Eclipse plugins folder, overwriting the old version.
5. Restart Eclipse. The new version of NSIS should now be accepted.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Old 6th March 2006, 14:04   #79
kichik
M.I.A.
[NSIS Dev, Mod]
 
kichik's Avatar
 
Join Date: Oct 2001
Location: Israel
Posts: 11,343
Re: EclipseNSIS 0.9.4 HOTFIX

Quote:
Originally posted by iceman_k
For whatever reasons, the way in which NSIS reports its version number was changed in NSIS 2.15.
The "v" prefix was accidentally removed. It'll be back for 2.16.

NSIS FAQ | NSIS Home Page | Donate $
"I hear and I forget. I see and I remember. I do and I understand." -- Confucius
kichik is offline   Reply With Quote
Old 6th March 2006, 14:32   #80
iceman_k
NSIS Dev
 
iceman_k's Avatar
 
Join Date: Feb 2003
Location: Boston, MA, U.S.A.
Posts: 455
Well, from now on EclipseNSIS will support with or without the "v" prefix.

Cheers,
Iceman_K

EclipseNSIS - An NSIS IDE for the Eclipse Platform | My contributions to the wiki
iceman_k is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > Developer Center > NSIS Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump