Old 8th February 2017, 13:44   #1
sqgl
Senior Member
 
sqgl's Avatar
 
Join Date: Sep 2008
Location: Australia
Posts: 128
Javascript Player Bug

In some browsers, when I click to play many of the stations (eg mine which is called RePlayScape) a popup screen indicates "jPlayer_error" and a huge diagnostic text dump. And no sound plays of course. This has been for at least a month now.

FAILS in...
Firefox 43.0.1
Opera 42.0

WORKS (kind of) in...
Chrome 56.0

When I say "kind of" works I mean that it plays but does not show up as as a listener on my admin page (not even in the listener count). Also if I click stop I cannot click play to restart it (unless I play another station first to apparently reset things).

PS Using Windows 7

Remixing listener requests of ambient tracks live http://RePlayScape.com
sqgl is offline   Reply With Quote
Old 10th February 2017, 11:27   #2
sqgl
Senior Member
 
sqgl's Avatar
 
Join Date: Sep 2008
Location: Australia
Posts: 128
Might be related to a similar problem that happens in iOS.

Remixing listener requests of ambient tracks live http://RePlayScape.com
sqgl is offline   Reply With Quote
Old 20th February 2017, 02:33   #3
jaromanda
Forum King
 
Join Date: Jun 2007
Location: Under the bridge
Posts: 2,257
by the way, you're using a firefox that is almost a year old

Is it just me or are shoutcast users getting dumber?
jaromanda is offline   Reply With Quote
Old 20th February 2017, 14:49   #4
STEVEN 2017
Junior Member
 
Join Date: Feb 2017
Posts: 2
I recently had a winamp crash and all of my media was removed from winamp. I reloaded all media but now all of my dropdowns beside the "winamp" logo on the top left (file, options, etc.) are gone ..... this prevents me from adding any new media without the "file" dropdown ! Does anybody know how to get these dropdowns back ?
STEVEN 2017 is offline   Reply With Quote
Old 21st February 2017, 09:39   #5
sqgl
Senior Member
 
sqgl's Avatar
 
Join Date: Sep 2008
Location: Australia
Posts: 128
STEVEN 2017, this is the shoutcast section of the forums. Try the Winamp section.

Remixing listener requests of ambient tracks live http://RePlayScape.com
sqgl is offline   Reply With Quote
Old 23rd February 2017, 01:39   #6
sqgl
Senior Member
 
sqgl's Avatar
 
Join Date: Sep 2008
Location: Australia
Posts: 128
I think it is because my streams are via DNAS 1.9.8. Tunein.com claim HTML5 requires DNAS v2.

Remixing listener requests of ambient tracks live http://RePlayScape.com
sqgl is offline   Reply With Quote
Old 19th March 2017, 16:41   #7
sqgl
Senior Member
 
sqgl's Avatar
 
Join Date: Sep 2008
Location: Australia
Posts: 128
The Tunein.com web page still plays DNAS v1 stations despite their bulletin they emailed out. Shoutcast.com OTOH has just removed v1 stations from their listing//directory/yp (without telling anyone).

Remixing listener requests of ambient tracks live http://RePlayScape.com
sqgl is offline   Reply With Quote
Old 27th March 2017, 14:55   #8
neralex
Senior Member
 
Join Date: Mar 2011
Posts: 463
@sqgl: Hold on, you are bringing different things together. The info of tunein was related to an update of Chrome some weeks ago, which was fixed by the devs some weeks later.

http://forums.winamp.com/showthread.php?t=398988

Quote:
Originally Posted by tunein
With one of Google Chrome's recent updates, streams hosted on Shoutcast v1 servers are no longer compatible with HTML 5 web players.
You can be listed on tunein without having an authhash for YP. These are different lists. For tunein you need only a stream-url for YP you need the authhash.
neralex is online now   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > SHOUTcast > SHOUTcast Site Design

Tags
bug, javascript, jplayer, player, popup

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump