Old 20th June 2017, 21:00   #1
Dayta
Junior Member
 
Join Date: Jun 2017
Posts: 4
Plus "+" signs

Hello all,
I was wondering if anyone has or are experiencing seeing plus "+" signs in song titles and if so, is there a way to get rid of them. As long as I'm on the 24 hour server, everything is fine. However, when I broadcast live "encoding", in the song titles are plus "+" signs.
(i.e. David+Sanborn+All+I+Need+Is+You). How do I get rid of them? Any suggestion is deeply appreciated.

Thanks
Dayta
Dayta is offline   Reply With Quote
Old 21st June 2017, 01:07   #2
djSpinnerCee
Forum King
 
djSpinnerCee's Avatar
 
Join Date: Aug 2004
Location: Hollis, Queens/The Bronx, NYC
Posts: 3,401
Send a message via ICQ to djSpinnerCee Send a message via AIM to djSpinnerCee
why? i don't really know -- maybe your source app is encoding spaces as + when it updates the dnas (it sends the title in the query-string of a GET) --- you can possibly fix this by using %20 in your titles instead of spaces...

not sure if this has anything to do with the 2.x dnas using xml so much? it's definitely a url-encoding issue.

Last edited by djSpinnerCee; 21st June 2017 at 01:09. Reason: typos
djSpinnerCee is offline   Reply With Quote
Old 24th June 2017, 00:57   #3
Dayta
Junior Member
 
Join Date: Jun 2017
Posts: 4
Ok DJ,
I'll look into that. Thanks so much for responding.


Dayta
Dayta is offline   Reply With Quote
Old 26th June 2017, 07:49   #4
DJ-Garybaldy
Senior Member
 
DJ-Garybaldy's Avatar
 
Join Date: Sep 2003
Location: Manchester UK
Posts: 390
Are you using SAM Broadcaster 2017.5? There's a problem (again) been reported that the stream titles are garbled



Proud user of RadioDJ FREE shoutcast automation software

Online: Twitter - Facebook - Mixcloud
DJ-Garybaldy is online now   Reply With Quote
Old 8th July 2017, 06:36   #5
DJJayMac
Junior Member
 
Join Date: Jul 2017
Posts: 2
I've just noticed this tonight also. Using a shoutcast v1 stream was showing plus signs. Tested with a free shoutcast v2 and was showing normal. This is the first time I have ever had this issue.
DJJayMac is offline   Reply With Quote
Old 8th July 2017, 06:37   #6
DJJayMac
Junior Member
 
Join Date: Jul 2017
Posts: 2
Forgot to add, I'm also using 2017.5.
DJJayMac is offline   Reply With Quote
Old 8th July 2017, 13:56   #7
djSpinnerCee
Forum King
 
djSpinnerCee's Avatar
 
Join Date: Aug 2004
Location: Hollis, Queens/The Bronx, NYC
Posts: 3,401
Send a message via ICQ to djSpinnerCee Send a message via AIM to djSpinnerCee
when you used the v2 dnas, did you notice if the v2 recognized your source as a v2 source as well?

it's possible that your source has been updated to support title updating via the v2 method in terms of formatting the title in the http title update request that it sends to the v2 dnas such that it is no longer properly formatted for a v1 server.
djSpinnerCee is offline   Reply With Quote
Old 17th July 2017, 04:37   #8
dopelabs
Senior Member
 
dopelabs's Avatar
 
Join Date: Oct 2006
Location: Silicon Valley
Posts: 487
Send a message via AIM to dopelabs
the v1 and v2 http methods of updating the title info is basically the same...

you prob want to look into urlencoding any metadata strings made via http post or get requests.

&song=some artist - some track remix(vip)

&song=some%20artist%20-%20some%20track%20remix%28vip%29

https://www.urlencoder.org
dopelabs is online now   Reply With Quote
Old 17th July 2017, 11:27   #9
DJ-Garybaldy
Senior Member
 
DJ-Garybaldy's Avatar
 
Join Date: Sep 2003
Location: Manchester UK
Posts: 390
Quote:
Originally Posted by DJ-Garybaldy View Post
Are you using SAM Broadcaster 2017.5? There's a problem (again) been reported that the stream titles are garbled
If you'd read my post it was a problem with SAM Broadcaster 2017.5 sending the metadata out with + signs in between

I think its supposed to be fixed in 2017.6 (But i could be wrong)

Why people still use SAM Baffles me....



Proud user of RadioDJ FREE shoutcast automation software

Online: Twitter - Facebook - Mixcloud
DJ-Garybaldy is online now   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > SHOUTcast > SHOUTcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump