Old 28th May 2018, 13:07   #1
AxisNL
Junior Member
 
Join Date: Apr 2018
Posts: 3
shoutcast.com listing inconsistency

I'm a sysadmin managing some audio streaming services. A client told me his listing on the shoutcast.com listings isn't working, and I'm trying to debug it.

This client was migrated from one server to another, and the old server has been decommissioned.

The problem is that the download (pls/m3u) link contains a link to the new server, but the 'play' button, contains a link to the old server, which doesn't work.

It's been like this for weeks. I see his sc_serv is succesfully posting to the YP, and the number of listeners and stuff like that is correct.

> 2018-04-23 17:08:44 DEBUG [YP] getAddUpdateBody key=1
> <?xml version="1.0" encoding="utf-8"?><yp version="2"><cmd op="update"
> seq="1"><tstamp>1524496124</tstamp><url><port>8908</port><path>/stream</path><sid>1</sid><alt></alt></url><bitrate>192000</bitrate><samplerate>44100</samplerate><vbr>0</vbr><mimetype>audio/mpeg</mimetype><id>1831369</id><sa>0</sa><pa>0</pa><peak>0</peak><maxclients>150</maxclients><authhash>*****</authhash><dj></dj><source>RadioBOSS
> (Mozilla Compatible)</source><dnas>2.5.5.733/posix(linux
> x64)</dnas><cpu>1/8</cpu><stats><listeners>21</listeners><uniquelisteners>19</uniquelisteners><avglistentime>17260</avglistentime><newsessions>2</newsessions><connects>3</connects></stats><metadata><title
> seq="1">Hallo U Luistert Naar Station P.T.V. Voor Reacties SMS/APP
> ***</title></metadata></cmd></yp>
> 2018-04-23 17:08:45 DEBUG [YP] gotResponse Request key=1 cmd=2
> Response body=[
> <?xml version="1.0" encoding="UTF-8"?>
> <yp version="2"><resp
> seq="1"><id>1831369</id><stnid>1634183</stnid><updatefreq>600</updatefreq><publicip>194.88.105.64</publicip><station><name>Piratenhits.FM</name><genre>Folk</genre><genre2>Country</genre2><genre3>Polka</genre3><genre4>Top
> 40</genre4><genre5>Oldies</genre5><logo>http://i.radionomy.com/document/radios/c/cc01/cc01449a-006e-4ff6-993c-e588ab9c718c.jpg</logo><url>http://piratenhits.fm</url><callsign>cc01449a-006e-4ff6-993c-e588ab9c718c</callsign><admode>1</admode></station></resp></yp>;
> ]
> Response code=[200]
> 2018-04-23 17:08:45 DEBUG changing setting /yp/resp/id to 1831369
> 2018-04-23 17:08:45 DEBUG changing setting /yp/resp/stnid to 1634183
> 2018-04-23 17:08:45 DEBUG changing setting /yp/resp/publicip to
> 194.88.105.64
> 2018-04-23 17:08:45 DEBUG changing setting /yp/resp/station/name to
> Piratenhits.FM
> 2018-04-23 17:08:45 DEBUG changing setting /yp/resp/station/genre to Folk
> 2018-04-23 17:08:45 DEBUG changing setting /yp/resp/station/genre2 to
> Country
> 2018-04-23 17:08:45 DEBUG changing setting /yp/resp/station/genre3 to Polka
> 2018-04-23 17:08:45 DEBUG changing setting /yp/resp/station/genre4 to Top 40
> 2018-04-23 17:08:45 DEBUG changing setting /yp/resp/station/genre5 to Oldies
> 2018-04-23 17:08:45 DEBUG changing setting /yp/resp/station/logo to
> http://i.radionomy.com/document/radi...88ab9c718c.jpg
> 2018-04-23 17:08:45 DEBUG changing setting /yp/resp/station/url to
> http://piratenhits.fm
> 2018-04-23 17:08:45 DEBUG changing setting /yp/resp/station/callsign to
> cc01449a-006e-4ff6-993c-e588ab9c718c
> 2018-04-23 17:08:45 INFO [YP] Updating listing details for stream #1
> succeeded.

Am I overlooking something simple? I tried support@shoutcast.com, but no reply here yet.
AxisNL is offline   Reply With Quote
Reply
Go Back   Winamp & SHOUTcast Forums > SHOUTcast > SHOUTcast Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump