Prev Previous Post   Next Post Next
Old 4th August 2017, 14:32   #1
tnteverett
Junior Member
 
Join Date: Jul 2017
Posts: 17
Page Displayed Language Error

Using "Unicode true", the coded language string does not display in page correctly.
For instance
sélectionné
does not display the "é" correctly. What is displayed is an "A" with tilde above and a copyright symbol.

NSIS Version 3.02.1
Windows 7 Pro

Code specifics:
Quote:
; MUI ------
!include "MUI2.nsh"
Unicode true

!define MUI_WELCOMEPAGE_TITLE $(WelcomePageTitleLang)
!define MUI_WELCOMEPAGE_TEXT $(WelcomePageTextLang)
!insertmacro MUI_PAGE_WELCOME

LangString WelcomePageTitleLang ${LANG_ENGLISH} "Welcome to ${PRODUCT_NAME} ${PRODUCT_VERSION} Setup"
LangString WelcomePageTitleLang ${LANG_FRENCH} "Bienvenue dans la configuration ${PRODUCT_NAME} ${PRODUCT_VERSION}"
LangString WelcomePageTextLang ${LANG_ENGLISH} "Setup will guide you through the installation of a selected ${PRODUCT_NAME}.$\r$\n$\r$\nIt is recommended that you close all other applications before starting Setup. This will make it possible to update relevant system files without having to reboot your computer.$\r$\n$\r$\nClick Next to continue."
LangString WelcomePageTextLang ${LANG_FRENCH} "Le programme d'installation vous guidera lors de l'installation d'un ${PRODUCT_NAME} sélectionné. $\r$\n$\r$\nIl est recommandé de fermer toutes les autres applications avant de commencer l'installation. Cela permet de mettre à jour les fichiers système pertinents sans devoir redémarrer votre ordinateur. $\r$\n$\r$\nClicer sur Suivant pour continuer."
tnteverett is offline   Reply With Quote
 
Go Back   Winamp & SHOUTcast Forums > Developer Center > NSIS Discussion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump