Old 26th May 2012, 19:44   #1
diegosolo
Junior Member
 
Join Date: May 2012
Posts: 2
Is port 80 a good choice?

Hi, I'd really like to have a fancy URL for my broadcast, like http://radio.mysite.com. This looks great, but I'm concerned about broadcasting on port 80. Will I have troubles sending my radio through that port (with proxies or whatever else)? Thank you!
diegosolo is offline   Reply With Quote
Old 27th May 2012, 16:16   #2
louislouw
Junior Member
 
Join Date: May 2012
Posts: 8
Port 80 is the best port as generally this is the most open port for listeners to connect through. So if you can get it going on port 80, go for it!
louislouw is offline   Reply With Quote
Old 27th May 2012, 18:11   #3
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: On the streets of Kings County, CA.
Posts: 3,013
Send a message via Skype™ to thinktink
If you already have a website running then that won't work because the webserver and the SHOUTcast DNAS can't both use the same port at the same time.
thinktink is offline   Reply With Quote
Old 29th May 2012, 16:21   #4
diegosolo
Junior Member
 
Join Date: May 2012
Posts: 2
Wow thanks! So, I have my own webserver running CentOS, and I can buy another IP (I think they add a net card when I do that). So, the I could have one IP for Apache and the other for ShoutCast. The thing is... how do I make ShoutCast work in the other IP? (and apache alone in the main one)

Well, if you can guide me I'll appreciate it...
diegosolo is offline   Reply With Quote
Old 29th May 2012, 17:53   #5
DrO
 
Join Date: Sep 2003
Posts: 27,873
you'd need to use the destip config option which would make the DNAS bind to that IP as long as you've configured anything which is needed for having multiple IP on a single CentOS host.

-daz
DrO is offline   Reply With Quote
Old 30th May 2012, 00:46   #6
idobi
Senior Member
 
idobi's Avatar
 
Join Date: Feb 2003
Location: Washington DC
Posts: 119
Send a message via AIM to idobi
Make sure you also set httpd.conf to bind to only one of your IP address also:

Listen x.x.x.x:80

Most likely it's currently set to:

Listen 80

Which will bind to all your available IP addresses.

idobi Network - http://idobi.com/
idobi Radio - http://idobiradio.com/
idobi App now available for iOS, Android and Windows Phone (http://idobi.com/app/)
idobi is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Technical Support

Tags
broadcast, port 80, proxy, trouble

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump