Old 21st March 2012, 14:32   #1
lee369
Junior Member
 
Join Date: Jan 2012
Posts: 2
how to get winamp to prevent screensaver

I am using Winamp and my computer to play music through receiver to my outdoor speakers. I am wondering how to get Winamp to prevent my screensavers from starting (I am using screensavers with sound) while I am using Winamp to play music. Winamp is used just for my music collection. My screensavers come on after 15minutes if I am not inputting something with my keyboard. So while I am outdoors the screensaver comes on and I can hear both Winamp and the screensaver. I would prefer not to change the screensaver start time everytime I use Winamp, and it is very inconvenient to come back in the house and go to my computer and click the keyboard to turn of the screen saver every few minutes. Any suggestions as to how to do this. I use a different player for videos and it has a place in the settings that I can check or uncheck which will prevent the screensaver from coming on (so I never have this problem using this other player). I can't find anything like this in the Winamp settings.

Thanks for your help.

Last edited by lee369; 21st March 2012 at 14:41. Reason: re wording
lee369 is offline   Reply With Quote
Old 21st March 2012, 14:45   #2
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,841
Hi lee369,

There is an option for disabling your screensaver when Winamp is playing videos, but I'm not aware of one for when it is playing music.

You can just disable your screensaver (not change it's timing) when you want to use Winamp the way you described. A quick way to get to your screensaver settings is to right-click on a clear part of your desktop and choose the option that lets you personalize your computer.

Winamp Pro v5.666.3516 fully-patched - Quinto Black CT v3.6 skin
Windows 10 Home 64-bit v21H2 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 21st March 2012, 14:52   #3
DrO
 
Join Date: Sep 2003
Posts: 27,873
one of my plug-ins (auto fullscreen) did have an option for disabling the screensaver when Winamp is in use but the last few reports i had indicated that it was a bit hit and miss.

-daz
DrO is offline   Reply With Quote
Old 22nd March 2012, 02:14   #4
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,841
If DrO's plug-in does not work for you, my suggestion for disabling your screensaver may not have been clear enough. When you get to the screensaver settings, scroll through the list of available screensavers and select "(None)", at the top of the list. This preserves all the settings made for the screensaver you were using. So to get it back working the same way, you just need to select it again.

Winamp Pro v5.666.3516 fully-patched - Quinto Black CT v3.6 skin
Windows 10 Home 64-bit v21H2 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 22nd March 2012, 15:50   #5
DrO
 
Join Date: Sep 2003
Posts: 27,873
well yeah that would be the solution to globally disable it but it sounds like lee369 specifically wants to be using a screensaver when Winamp or the other program isn't running.

-daz
DrO is offline   Reply With Quote
Old 22nd March 2012, 16:21   #6
thinktink
Forum King
 
thinktink's Avatar
 
Join Date: May 2009
Location: No longer on the streets of Kings County, CA.
Posts: 3,094
Quote:
Originally Posted by DrO View Post
...for disabling the screensaver when Winamp is in use...
Out of curiosity, what was the method you used for stopping the screensaver?
thinktink is offline   Reply With Quote
Old 23rd March 2012, 11:30   #7
Aminifu
Forum King
 
Aminifu's Avatar
 
Join Date: Aug 2011
Location: Phoenix, AZ
Posts: 4,841
Quote:
Originally Posted by DrO View Post
well yeah that would be the solution to globally disable it but it sounds like lee369 specifically wants to be using a screensaver when Winamp or the other program isn't running.

-daz
I guess I'm still not being clear enough. If lee369 can't find a way for Winamp to automatically disable his screensaver, I'm only suggesting he disable it manually when running Winamp and manually re-enable it when he's not running Winamp.

A few extra steps, but it solves his problem.

Winamp Pro v5.666.3516 fully-patched - Quinto Black CT v3.6 skin
Windows 10 Home 64-bit v21H2 desktop - Logitech Z906 5.1 speaker system
Aminifu is offline   Reply With Quote
Old 23rd March 2012, 11:36   #8
DrO
 
Join Date: Sep 2003
Posts: 27,873
thinktink: whatever was the suggested way of doing it off google in 2005 - all of that code is archived away so i cannot check it currently. was probably some sort of response to a windows message. will probably break that out this weekend if time allows.

Aminifu: you are being clear, but also clearly the OP wants the screensaver on. though without a response from them it's all moot anyway.

-daz
DrO is offline   Reply With Quote
Old 6th May 2012, 19:13   #9
lee369
Junior Member
 
Join Date: Jan 2012
Posts: 2
Thank you to everyone who replied. I now change the screensaver time when I have to sound on outside. That way when I turn off my monitor and am outside listening to music I don't hear the screensaver; and hopefully I remember to change it when I return to my computer. It has sorta worked so far.

But Thank you all for your replies.
lee369 is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump