Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Reply
Thread Tools Search this Thread Display Modes
Old 8th December 2000, 06:53   #1
DimsDale
Guest
 
Posts: n/a
This looks like another "enhancement" visited upon me since I upgraded to IE 5.5 (yeah, yeah, I know, I deserve it.....)

When you click on a "Tune In" icon on a ShoutCast station, Winamp used to start up playing the stream. Now, I get the dammed file download dialog box, asking me if I want to save the playlist to disk, or open it from its current location.

I've seen a similar post in one of the other discussion groups here, but no answer. If anyone else has seen this and has come up with a workaround I'd love to hear it.....

Thanx!
  Reply With Quote
Old 8th December 2000, 07:06   #2
Sawg
Guest
 
Posts: n/a
Select open and check never ask me again (its something like that). It does open with WinAMP right?

If that doesn't work, what version of Windows are you using (folder options varies upon version).




------------------
sawg
ICQ: 5943529
  Reply With Quote
Old 8th December 2000, 09:03   #3
CmhGreg
Guest
 
Posts: n/a
I have been having the same problem. Here is what worked for me. First, make sure Winamp Agent is disabled. Second, uncheck Register File Types at Startup on the Preferences/File Types page. Make sure that the pls file type is highlited under Associated Extendsions, then shut down Winamp.

Go to Windows Explorer/View/Folder Options/File Types and find Winamp Playlist file. Click Edit and make sure Content Type (Mime) says "audio/mpeg". If it doesn't, fix it and click OK.

Now for the weird part, but it worked for me. Start up Windows Media Player and go to Tools/Options/ and click the format tab. Place a check box under MP3 Format Sound. Close Media Player. Open it again and uncheck the box. Now go to Shoutcast and see if Winamp opens up for you automatically.

Good luck.
  Reply With Quote
Old 8th December 2000, 21:35   #4
DimsDale
Guest
 
Posts: n/a
Thanks for the suggestions; unfortunately, after I went thru the process everything is still the same.... I suspect that this is somehow related to IE 5.5, because if I open a link in Netscape everthing works as it is supposed to........

  Reply With Quote
Old 9th December 2000, 19:18   #5
george883
Junior Member
 
Join Date: Dec 2000
Posts: 3
i'm having the same problem. if you click on the "more info" button on the file download dialog box, it says that .exe and .com files are always going to be prompted. i searched at support.microsoft.com but came up empty. there has to be a reghack for this somewhere. if you find it before i do, please let me know.
george883 is offline   Reply With Quote
Old 9th December 2000, 19:26   #6
Tom
Moderator
 
Join Date: Apr 2000
Posts: 4,491
This thread deals with the same problem. I suggest you read the whole thing before trying any of it because they were trying stuff out so sometimes it didn't work and then they come back and offer another solution.

[edit]
Modified url from old ubb link to new vBulletin link
[/edit]

[Edited by DJEgg on 01-03-2001 at 10:21 PM]
Tom is offline   Reply With Quote
Old 10th December 2000, 16:23   #7
george883
Junior Member
 
Join Date: Dec 2000
Posts: 3
success!

i was able to get the .pls to start automatically. i had to uncheck the "register file types on winamp start" in preferences. then i installed another player. this one did the same thing. so, i unchecked the same option in this new player. then i went back into winamp and selected the "register" option again. after i did this, the "always ask" in the file download was availble. in my opinion, all the other advice in this thread and the other about file options and editing the registry don't work at all...
george883 is offline   Reply With Quote
Old 10th December 2000, 17:15   #8
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,857
Well it definitely is something to do with a registry setting.
To determine exactly which setting it is, we need someone with IE5.5 who's experiencing this problem to run a search in Regedit for all keys containing audio/mpegurl & audio/scpls. The guilty string will become obvious once it's found within the same IE download security key as exefile [application/x-msdownload] & comfile [MS-DOS Application].
Once determined, we can then report it to Micro$oft so they can remove this bug in any future IE upgrades/patches.
I'd do it myself but I'm staying with IE5.1 SP1 for quite a while yet.

-------
DJ-Egg
DJ Egg is offline   Reply With Quote
Old 10th December 2000, 22:09   #9
l3rendon
Guest
 
Posts: n/a
Here's what I did:
I clicked a playlist link in a web site, it prompted me to open from current location or save it. i saved it to my computer. then, i browsed for the file in windows explorer and double clicked it. a prompt appeared asking me what program to use to open it with. scrolled down the list to winamp, made sure the always open this file with this application was checked, and now i'm golden. hope this works for others.
  Reply With Quote
Old 11th December 2000, 03:21   #10
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,857
Yeah, but couldn't you just go to Winamp Prefs -> FileTypes & select pls & m3u to associate playlist files with Winamp ?
DJ Egg is offline   Reply With Quote
Old 12th December 2000, 04:46   #11
DJ Egg
Techorator
Winamp & Shoutcast Team
 
Join Date: Jun 2000
Posts: 35,857
I take it you've all tried:
Folder Options -> File Types -> Winamp Playlist file -> Edit
Change the MIME type to : audio/scpls
Uncheck : Confirm open after download
Make sure the default Open command (Play in Winamp) is:
"C:\Program Files\Winamp\winamp.exe" "%1"
Click "Okay", then hi-lite entry & click "Set Default" button.

nb.
If you have "Enqueue" as default, make sure you edit that entry too.

You might also want to try changing the MIME type to any of the following:
audio/mpeg
audio/x-mpegurl
audio/x-scpls

Maybe one of them will work?

There's also the possibility that these MIME types aren't included in the Registry.
Further tips on how to rectify this = here:
http://forums.winamp.com/showthread.php?threadid=37053
(Warning: only edit the Registry with Regedit if you know exactly what you are doing; otherwise get someone qualified & experienced to do it)

btw:
Windows Media Player uses "video/mpeg" as the default MIME for mp3 & m3u files (weird, I know).

[Edited by DJEgg on 01-03-2001 at 09:59 PM]
DJ Egg is offline   Reply With Quote
Old 14th December 2000, 05:42   #12
DimsDale
Guest
 
Posts: n/a
Your wish is my command; I ran REGEDIT, and surprise surprise, no key found with the strings you specified.... hmmmmm, maybe that's why IE 5.5 doesn't know to do with the MIME extensions. Probably a M$ or RealPlayer plot.....

Now HERE'S the kicker; the file types are registered in Netscape 4.7, which, of course, works fine....

Thanks for the suggestion; I hope that this helps....

[QUOTE]Originally posted by DJEgg:
[b]Well it definitely is something to do with a registry setting.
To determine exactly which setting it is, we need someone with IE5.5 who's experiencing this problem to run a search in Regedit for all keys containing audio/mpegurl & audio/scpls. T
  Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Winamp > Winamp Technical Support

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump