Old 27th September 2002, 19:57   #1
dougieha
Senior Member
 
dougieha's Avatar
 
Join Date: May 2001
Posts: 236
Slider Depression: Is this a bug?

Ok...I'm working on a script for animated eq bars. Look in the Maki Cheats thread.

Now, here's my problem. In WA2.xx, when you clicked on a slider, it didn't move until you actually moved the slider.

So, for example, if you clicked on the very bottom of a slider, it didn't move until you moved it.

In WA3, however, if you click on the bottom of a slider, the slider automatically moves so that the button becomes centered under your mouse cursor.

Can anyone tell me if this is a bug? Or was it designed that way? It's a pain for making eq sliders that snap correctly, and I want them to behave in the WA2.xx manner.

Does anyone have a solution to this?

Thanks for any of your help.


Dougieha

My skins: Sony MPFX3-WA5 (Just for WA 5.x!!) and Sony MPFX3.

Last edited by dougieha; 27th September 2002 at 22:04.
dougieha is offline   Reply With Quote
Old 27th September 2002, 22:45   #2
dougieha
Senior Member
 
dougieha's Avatar
 
Join Date: May 2001
Posts: 236
Hmmm...does anyone have any ideas?

Should this be moved to bugs?

I've tried accessing Bugzilla to search, but it's slower than molasses in winter right now.

I'm beginning to think that this is a genuine bug.


Dougieha

My skins: Sony MPFX3-WA5 (Just for WA 5.x!!) and Sony MPFX3.
dougieha is offline   Reply With Quote
Old 28th September 2002, 07:34   #3
Naamloos
Forum King
 
Naamloos's Avatar
 
Join Date: Mar 2001
Location: irc.tehflap.org/*******
Posts: 3,085
It's not a bug, its just how it was build.

with a little maki you could set em correct :
code:

/**
onLeftButtonDown()

Hookable. Event happens when the left mouse button
is pressed.

@param x The X position in the screen where the cursor was when the event was triggered.
@param y The Y position in the screen where the cursor was when the event was triggered.
*/
extern GuiObject.onLeftButtonDown(int x, int y);



Just use the x and y it gives
Naamloos is offline   Reply With Quote
Old 28th September 2002, 08:58   #4
dougieha
Senior Member
 
dougieha's Avatar
 
Join Date: May 2001
Posts: 236
Thanks for the suggestion. I've been using MAKI to script such things as an animated volume layer and the eq bands in my skin.

However, there is a strange effect that occurs, and it still doesn't seem right to me. It does it in the default skin, too, and it didn't do it in WA2.xx. I suppose I'll just live with it. I tried to minimize its effect, but it is still there.

When you click on the lower half of a slider button, the button automatically snaps down, such that the slider button is centered under your mouse cursor. This happens regardless of what I do in MAKI.

Anyhow, thanks for the reply.

Also, does anyone know what's up with Bugzilla? It's been really slow for me for several weeks now.


Dougieha

My skins: Sony MPFX3-WA5 (Just for WA 5.x!!) and Sony MPFX3.
dougieha is offline   Reply With Quote
Old 28th September 2002, 10:00   #5
Naamloos
Forum King
 
Naamloos's Avatar
 
Join Date: Mar 2001
Location: irc.tehflap.org/*******
Posts: 3,085
Yeah i see your problem...

Bugzilla works fine for me...
Naamloos is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Skinning and Design > Modern Skins

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump