Old 25th November 2019, 07:47   #1
Klaas
Senior Member
 
Join Date: Sep 2018
Posts: 117
Ad insertion sometimes working sometimes not

Hi,

I've got an issue with the ad insertion instead of the ad replacement. Sometimes it is actually working and returning correctly to the stream but most of the time it is doing ad replacement instead.

Is this case somehow known?

I'm using Shoutcast 2.6.0.753

Thanks for any help.
Klaas is offline   Reply With Quote
Old 28th November 2019, 08:35   #2
LStratmann
Guest
 
Posts: n/a
Hey,
Do I understand correctly that advertising sometimes, but not always works?

Greetings.
  Reply With Quote
Old 28th November 2019, 08:39   #3
Klaas
Senior Member
 
Join Date: Sep 2018
Posts: 117
Advertising always works. However I selected ad insertion instead of ad replacement. The insertion sometimes happens but not always. Instead of inserting an ad it replaces the stream then which overlays news, jingles or songs.
Klaas is offline   Reply With Quote
Old 28th November 2019, 08:43   #4
LStratmann
Guest
 
Posts: n/a
Hey,
Look at my other answer here: http://forums.winamp.com/showthread.php?t=455187

"2. So you mean that after the advertisement not the content was played after the trigger but the current content? (So, that you didn't have a delay, but you came into the middle of the song)"

Greetings.
  Reply With Quote
Old 4th December 2019, 07:00   #5
Klaas
Senior Member
 
Join Date: Sep 2018
Posts: 117
So ad insertion is till not working properly and neither Shoutcast nor Targetspot are responding to requests.
Klaas is offline   Reply With Quote
Old 24th January 2020, 08:45   #6
LStratmann
Senior Member
 
LStratmann's Avatar
 
Join Date: Dec 2019
Location: Germany
Posts: 258
Hey Klaas,
I just wanted to let you know that Ad Injection works with SHOUTcast for Business!
I talked myself into testing it!

Greetings.
LStratmann is offline   Reply With Quote
Old 24th January 2020, 09:00   #7
Klaas
Senior Member
 
Join Date: Sep 2018
Posts: 117
Thanks. But I am afraid I'm Not interested in Shoutcast anymore. The product is dead for me.
Klaas is offline   Reply With Quote
Old 13th March 2020, 07:29   #8
Klaas
Senior Member
 
Join Date: Sep 2018
Posts: 117
Just tested Shoutcast for Business out of curiosity. Unfortunately I cannot install a reverse proxy in front of the Shoutcast URL to use my own URL. The x-forwarded-for header of the proxy is not interpreted.

So sadly that solution won't serve me very much. At least the Support responded immediately on deleting my account.
Klaas is offline   Reply With Quote
Old 13th March 2020, 07:43   #9
LStratmann
Senior Member
 
LStratmann's Avatar
 
Join Date: Dec 2019
Location: Germany
Posts: 258
Whereby I have to say that SHOUTcast recently started to respond to the requests. I would have no problems to use my own URL. For example with an Apache2 reverse proxy: https://www.digitalocean.com/communi...roxy-extension
LStratmann is offline   Reply With Quote
Old 13th March 2020, 07:58   #10
Klaas
Senior Member
 
Join Date: Sep 2018
Posts: 117
The connection is not a problem at all. However the server at Shoutcast doesn't interpret the XFF headers. This means the dashboard shows wrong statistics and probably the ad server won't know where you come from.
Klaas is offline   Reply With Quote
Old 13th March 2020, 08:07   #11
LStratmann
Senior Member
 
LStratmann's Avatar
 
Join Date: Dec 2019
Location: Germany
Posts: 258
Ah, okay.
LStratmann is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast For Business & Monetization

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump