Old 26th August 2019, 10:38   #1
Horia_B
Junior Member
 
Join Date: Aug 2019
Posts: 9
Useing Mixxx with Shoutcast

Hello,

I have successful install Shoutcast and done some tests, Winamp is nice but I can't automatize the broadcast music or cast my voice even though I have a mic.

I like the Mixxx software but it is not compatible with Shoutcast V2, I've seen people setting there sound card so that the DSP broadcast over the Sound Card Input.

Please if you are kind give me a hand with the software problem, or if you will recommend me another software
Horia_B is offline   Reply With Quote
Old 26th August 2019, 13:56   #2
djSpinnerCee
Forum King
 
djSpinnerCee's Avatar
 
Join Date: Aug 2004
Location: Hollis, Queens/The Bronx, NYC
Posts: 3,512
you can use mixxx with shoutcast v2 -- the "secret" is how you config mixxx: you configure as a v1 shoutcast. the host and port are the same as winamp, for the password you have to use the legacy passsord which is your_password:#1 -- that's your password + a colon ":" + the # symbol + the v2 sid you're connecting to. the dnas admin page shows this in the source connection details page.

v2 features like album art, next playing, etc are not provided by mixxx, but track title updates, and history work fine.
djSpinnerCee is offline   Reply With Quote
Old 27th August 2019, 07:20   #3
Horia_B
Junior Member
 
Join Date: Aug 2019
Posts: 9
Hi djSpinnnerCee

I have configured the server on port 8000 with the same host, but I don't get it. I have to set the password of the stream like this: password:#1 where 1 is the source?

Or I have to put the normal password without the :#1 at the end in the server and then insert the legacy password in the mixxx in the live broadcasting option?

And another thing the correct port is 8000 or I have to open another one

When I try to connect to shoutcast I get this error:

Socket is busy

Please check your connection to the Internet and verify that your username and password are correct.
Horia_B is offline   Reply With Quote
Old 27th August 2019, 14:17   #4
djSpinnerCee
Forum King
 
djSpinnerCee's Avatar
 
Join Date: Aug 2004
Location: Hollis, Queens/The Bronx, NYC
Posts: 3,512
you don't change the server configuration in any way.

in mixxx, you use the same host and port that worked with winamp. for the password, use the legacy password (actually, but not to confuse things, streampassword_1 and/or password as set in the dnas can also be used, as they imply sid 1).

if you look at the dnas admin source connection details page, stream (sid) 1 may not show a legacy password, even though it can be used.

so, try both, look at the dnas log on the dnas admin page for help.... if you get the host and port right, the log will show a failed source connection attempt. if you don't see the source connection attempt from mixx, most likely you have the host part wrong.

also, stay away from localhost, use 127.0.0.1 whenever you are talking to the dnas from the same box. it'll save you some headaches.

if you still have problems, it's possible that your server config or your firewall is not allowing v1 connections to your server -- it goes like this.... a v2 source connects to the server on portbase (8000 for you).... the v2 server also listens on portbase+1 (8001) for v1 sources like mixxx --- that means for your dnas to allow v1 sources to connect, you have to open port 8001 in addition to 8000 in your firewall (and in your router if you want to allow a remote source).
djSpinnerCee is offline   Reply With Quote
Old 27th August 2019, 16:36   #5
Horia_B
Junior Member
 
Join Date: Aug 2019
Posts: 9
Got it!!!

Just have to assign a name to my station, nothing more.
Horia_B is offline   Reply With Quote
Reply
Go Back   Winamp & Shoutcast Forums > Shoutcast > Shoutcast Discussions

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump